Auto direct monitoring not working all of a sudden

Over the past while direct monitoring refuses to work on my system with Cubase 9 and 9.5.
I can usually get it to start working by selecting 'no driver’and then selecting my RME driver again.

When arming a track with DM turned on there is no audio passing through until playback. Turning off direct monitoring also works fine so its def a Driect monitoring issue

RME support say they have not had this reported and asked me see if its a Cubase thing. I dont have another DAW that uses direct monitoring on my system.

Has anyone else had problems with this of late? Is it a Windows 10 update that has caused the issue I wonder?

Direct monitoring is normally a knob on your interface. Direct monitoring because the input is sent directly to the output, bypassing the computer and the latency involved to give you zero latency.
This has nothing to do with Cubase.

Cubase is responsible for facilitating its use though. (i.e. turning it off and on) so I’m just asking the community am I the only user experiencing this or is there a problem

That is ASIO direct monitoring, not direct monitoring. So which are you talking about?

How are your preferences set, Tape Machine style monitoring ?
DM enabled in the preferences ?
Tried to reset TotalMix ? (yes it can get confused, resetting or calling up a snapshot usually clears that up for me)
Tried disabling any WDM connections in the RME driver ? (can really mess things up, might be Win10 related)

Cubase has nothing to do with direct monitoring as that is a hardware thing only. As Svennilenni says, maybe you are talking about ASIO direct monitoring which is a different thing.

Yes I’m talking about the Cubase management of ASIO Direct Monitoring ’ Tape Machine Style’ as I have always used.

Peake - Dm is enabled for sure as always. Thanks for your other suggestions I’ll try looking at WDM connections. It would appear to be Windows 10 update related as its a new phenomenon on a system thats been working fine for 4-5 years now in a busy studio (used 9 hours a day every day).

Yes there is something with how win10 handles wdm that must have changed.
I suddenly could not go below 512 buffers, anything lower and I got no sound or only static.
Disabled wdm in the RME driver setting, fired up Cubase again and now I could go 32 buffers without problems.
I have later enabled wdm again, and it is now working fine and can use all buffer settings.

Still having major issues with this. Here’s what I’ve done:

Completely uninstalled all drivers and semblance of my rme driver software from my computer (including old driver references from registry). Even removed the hardware. Reinstalled. No difference
Direct monitoring works at manual level if I use totalmix on the rme to configure channels manually. This is not auto monitoring though and is very cumbersome.

I’ve tested cubase 9.5, cubase 9, protools 12.5, personas studio 1 v3, magix sequoia 13 on my system and none of them are able to direct monitor where available in those softwares.

So the DAWs are not properly communicating with the hardware… at some level. What to try and where to look from there is a real mystery. I’ve been onto rme to no avail. At what level in software or the OS does the DAW communicate to the hardware? I’d have thought it’s directly between cubase and the rme driver… but is there a windows layer between that a windows update could have messed up? After 10 years of daily use?
Stressful one!!

Hello mart, I am affected as well.
My system was also working fine over the last years and suddenly there is a unexplicable change in the ASIO direct monitoring.

In February, the problem started every now and then. I restarted Cubase and sometimes the PC. This helped, but it was embarrassing if you are working with customers and they have to wait until your PC has started again.

Yesterday, within a recording session, the problem appeared again and since then I cannot change it anymore.
I did the same efforts as you: deleting old drivers, renewing RME software, drivers and TotalMix. Nothing.
So no solution until now.

For documentation purposes:
I am running a PC system with Windows 10 (all actual updates) and Cubase 9.5., all actual RME drivers and software.
My recording chain is managed via the Cubase control room, not via TotalMix. "
ASIO direct monitoring" is always “on” and everything was running fine over years until these days.

Until now, I could usually get it to start working again by clicking another workspace snapshot in TotalMIx.
This trick only works as long as I do not move the volume knob in Cubase.


That’s interesting you have the same problem.
You’ll be glad to know I seem to have fixed it with no huge explanation as to how but…

I had Daniel at RME work with me on Wednesday and after a while we ran out of things to try. They hadn’t seen it before. I suggested I borrow an RME Babyface to see if ADM worked on that hardware. At least it would rule out windows and cubase if it did. So I did that. I installed the RME babyface USB driver from the RME site. Straight away the Babyface ADM worked. Then I went back to my HDSPe and right away ADM was working again!!

Only explanation is that the Babyface driver install overwrote something that the HDSPe needed for ADM, maybe in the registry.

Anyway try and install that driver or one of the other rme drivers to see if that helps. That’s all I did to fix it on mine. Unfortunately we don’t have a ‘why’.

Also definitely go to RMe and log this. Daniel and those in rME do great support and he’ll be very very interested to see a user report the same problem as he hadn’t seen it before

If you’re using TotalMix, make sure that Options/Preferences/Disable ASIO Direct Monitoring is NOT checked.

“If you’re using TotalMix, make sure that Options/Preferences/Disable ASIO Direct Monitoring is NOT checked.”

Its not. Thanks though

Today I remembered that the Operational Mode was set to Full Mode from the troubleshooting. I had been using it on DAW mode so I clicked DAW mode. ADM once again ceased to work back in Cubase. I then went back to Full mode on Total Mix. Still nothing.

Then I went back to Cubase Audio preferences and selectred No Driver. Then I selected HDSP Hammerfall driver again. ADM Started working again.

I tried the same while in DAW mode in Total Mix and I could NOT get it to work. So I’ve left Total Mix on Full Mode in the mean time. Its working, but theres definitely something tetchy going on under the bonnet either in the RME Driver or a Windows subsystem setting thats able to disable ADM from working. Maybe this might help someone in the future as its been a real puzzle for me and also for RME Support!

Hi there.

I recently decided to go from TM direct monitoring to Cubase ADM to get the advantage of using only one software and also because I plan to program the 56 moving faders on my neve board to MIDI-control musicians Cue mixes as I find it a tedious task with the mouse. My first idea was to MIDI-remote control RME’s TM but I was very disaponted to realise the only way to get there was through this awful mackie protocol. So I decided to use Cubase’s more flexible MIDI implementation.

All this to point out that I don’t have a past history using ADM-RME (9652) so I can’t say it was working BEFORE.

I soon was hit by the same bug described by MART and LUCKY90099090.
I followed mart’s (or lucky’s?) suggestion to selecte “NO DRIVER” then selecting RME’s driver again and it worked for me. Thanks for that. Messing with the WDM options on RME’ control panel had no effect at all.
I’m sticking with a WINDOWS 7 OS.

Hope this helps.

If you could take the time to contact RME support about this as support had not seen t before.

After a while the selecting no driver and selecting the rme stopped working for me. I got ADM only thru fluke by installing a Babyface driver (I have a HDSP Madi) and it can back. Weird

I am having the same issue. Running osx 10.14.5 and Nuendo 10.0.20 all worked fine two weeks ago. Now direct monitoring no longer works. With MR816 x

My problem was with windows. I never really got to the bottom of it but by not using DAW mode on the RME and I think either installing a different RME driver it seemed to trigger it back on. If I choose DAW mode in RME preferences though Direct Monitoring stops working. RMe support were good and spent a while with me even taking control of my PC to remote troubleshoot but couldn’t fix the issue. What I have is a strange workaround. Good luck!

I’m having exactly this problem. Total Mix seems to have taken control of everything - monitoring via Cubase doesn’t work at all. If I switch Total Mix to DAW mode, no sound can be heard at the input unless I click ‘Cue’ in TM - but that allows me to monitor only a single channel. In full mode, I can monitor via Total Mix - but for me this is an annoying distraction when all I want to be able to do is use Cubase’s faders to control the level coming out of the speakers. Have been having this problem on and off since updating my Fireface drivers. I have a Fireface 800, am running Cubase 6 under Windows 10. Have installed the latest driver for the 800. I know this is an old thread - wonder if anyone has an update on this issue?