Avid Artist Mix and Control - First Real Session

Just finished my first genuine session with my new Avid Mix and Control surfaces. What a revelation… They worked beautifully… The ergonomics are damn near perfect (at least for me). No glitches/issues… Perfect. After years of having worked without flying faders (or any real faders for that matter) the Avid surfaces helped me remember how great it is to use conventional old school interfaces. Besides the Mix, the Control is superb. I did 90% of what I usually do in the UI using the Control and it felt natural, organic and FAST.

I was using the CMCs before the Avid stuff and they are really good although I could never get comfortable with the FDs - The absence of a scribble pad and the ribbons never felt right to me.

I can’t say enough about the Avid gear. Steinberg’s Eucon implementation is terrific too. The integration is so deep and solid I cannot imagine a more complete interface. It is actually somewhat funny (ironic?) that Cubase 7.5.1 works perfectly with the controllers yet when you go to the Avid forum general rancour abounds about how poorly Eucon 3.1 works with PT11.

I know this is a gushy post but, damn, I can’t help myself… Had to share the news…

Now, back to the real faders!

Hi, nice to see that you are happy with the devices. I am using them as well and they are indeed the best Controllers I had so far.

Some questions:

Which Version of EUCON do you use? 2.7.1? 3.1?
Does the Connection always work? If yes, please describe your Setup - especially how the Controllers are connected to your net.

Does the channel visibility on the Artist Mix and Artist control follow the visibility in the cubase mixconsole?
If yes, how did you accomplish this? (It does not seem to work for a lot of users, including myself).

Finally I would be more than happy to get tipps and tricks - sometimes we conincidently find functionality.

One open question from my side is: Can we control Vstis (or Vsti QCs!) of instruments in the Instrument Rack with the EUCON Controllers?

Cheers, Ernst

Hi

Same gear here - Problems with EUCON 3.1, steped back to EUCON 2.7.1, just 4 faders banking instead of 8 (with EUCON 3.1), but more stable within the operation.
Doing almost every recording and editing command using the AVID Artist Control. Very fast action possible compared with the mouse moving all over the screen :wink:

Support the statement from Ernst - there are many users keen to exchange experience with others.
There is an AVID forum as well.
http://duc.avid.com/forumdisplay.php?f=62


Cheers

Hi… My setup uses Eucon 3.1… Firmware 1.5.2 (MC MIX) and 1.3.5 (MC Control). Hidden tracks render for me on the Mix/Control so I cannot say that works in my setup. I don’t use the hidden tracks feature so its not an issue for me. Fader banking works as advertised though… No issues there.

VSTi editing

I do this by holding the input/Insert button for about three seconds. This puts the Mix into VSTi edit mode where I can edit params which spill across the OLED displays and navigate forward/backward using the CFG PAGE keys.

To exit VSTi editing I hit the input/Insert button again (just a quick tap - no three second push is required here) which puts me into insert select mode where I can scroll through inserts using the CFG PAGE keys. To activate the insert I press the rotary encoder on the channel I want to edit (so if you have, say, four tracks, go to the channel you want to edit and press the rotary encoder on that channel and it will open up the plugin). Once open all the rotary keys spill across the Mix and you can edit the plugin. To finish editing I hit the input/Insert button again. I have Eucon configured to show the plugin when the rotary encoder is pressed and hide the plugin on exit.

In terms of using the Control I have customized the first couple of softkey pages to use the features I use most frequently and that has been a great time saver.

If I come across new information I will post it

I am also an AC user. Love it! I am in the process of moving from Logic to Cubase and have been customizing my AC for Cubase over the past few days.

I can not seem to find any way to make a take on a lane active without using the comp tool. I can select a take with arrows keys etc, but I can not make it the currently active take without using the mouse. And since I can’t find a way to accomplish this with the keyboard, I can’t program the AC to do this.

Did anyone here find a solution?

Now THAT’s a good question… I took a look around preferences and so on and could not think of a way to macro or key-command that one… I don’t use comp very much so please forgive this stupid question but… Does Cubase not automatically activate the last lane to have been recorded during comp?

HI,

it is nice to find People who also use EUCON / the Artist series.

my MAJOR Problem currently still is that even with Version 3.1. cubase does not find the Controllers (Or the eucon sercie does not) . After freshly installing 3.1 the FIRST TIME, everything works. WHen I quit cubase then and restart the PC , Switch on the Artist Controllers - they are recognized by eucon but not in cubase.

Does anyone have a clue what could be the reason? It only works with Version 2.7.1.

Cheers, Ernst

I don’t know the reason, but this happens to me once in a while with 3.1, both with Cubase and Nuendo.
When Cubase does not recognize Eucon, open the device menu, remove Eucon from the device list, then add it again, then it’s recognized.

I think the Artist controllers are just fantastic. Eucon and the macro system of cubase makes these very powerful controllers.
Eucon has its issues, but that is just a minor annoyance compared to the benefit of using them.

When this happens, what application/workstation does the Control think it is addressing when cubase is launched? Also, what happens when you launch the Eucon configuration utility when cubase is running? Do the softkeys show the default configuration? Does anything happen when you click on the ‘assignment’ tab?

I love the Artist Control and it works like a dream, except for me it makes Cubase hang on exit, every time. To be fair I haven’t tinkered to redress the issue yet…

Hi Ian,

Are you sure that the Artist Control is responsible for Cubase Crashing on exit?

I don’t mean to discount your findings, but wish to get a better understanding if your issue is the same as mine and others, which appers to be more related to EuCon (AVID EuControl /Steinberg EuCon Adapter) than the Control surface itself.

I do believe that some are having a “Hang” issue and /or a “Crash” issue that may or may not be related!

I’m just trying to pin down if your issue is the same!

And to the OP, I have not had a situation where Cubase has stopped recognizing the controllers, but I have heard of others that have, and the remedy seemed to be to trash the Cubase preferences ( Default.xml and maybe others)… I know… crazy, but there it is!

If you are able to get Cubase to recognize the controller(s) after a EuCon adapter re-initialization as Johngar suggests, then it makes sense to me that something is missing during the startup of Cubase, which also points to the Default.xml maybe being possibly corrupted! Follow these [u]STEPS[/u] to rebuild it!

Al

Sorry, I didn’t mean to give the impression it was the Artist at fault here - I believe it’s the Eucon “hanging” issue you mention that I experience, which I am also aware is not unique to me. I just haven’t had the time to fully troubleshoot it yet…

Gotcha!

Hi Cpechet1 :slight_smile:

Thanks for your questions - I will try to answer them tonight when I am in front of my studiotable. The remarkable Thing is that after fresh install of Eucon 3.1. the first cubase session works without Problems. Quitting cubase then does nothing remarkable or problematic. the next time I start cubase it does not find the Controllers.

But as I said: I will post the detailled Situation answering your questions in the evening.

Cheers and thank you, Ernst

Hi, so now I am in front of my studiotable.

I did the following:

Uninstall Eucon 2.7.1
Trash Cubase Preferences
Install Eucon 3.1
Restart Computer
Switch on McMix and Mccontrol.
Started cubase, activated Eucon.
Everythin works FINE. Eucon Application says “Cubase 7.5 on Studio7” (Studio7 is the Workstation Name)

Now: When I quit cubase and restart it - everything is fine.
When I quit cubase, Switch off the Controllers, Switch the Controllers back on and start cubase - it does NOT work (Eucon Panel says “Cubase 7.5. on” (no Workstation Name, even though it is connected to Studio 7)

The only way to make it work again is to restart the Computer, Switch on the mccontrol and mcmix and then start cubase.

Strange, but workable.

Cheers, Ernst

Hi… Instead of restarting try logging off and on again… This will restart the eucon service…

I have eucon 3.1 on mavericks and it stops nuendo from being able to quit.

Hi

Well, I’m pretty sure, that the EUCON does not quit the service with Cubase , if you close Cubase.
(The touchscreen icons remain with Cubase intead of going to blanc)

I’m not the IT crack, therefore I don’t have a clue what’s going on, but I can state, that this behaviour started with Cubase v7.0.6. Before it was fine.

During the sessions (Cubase and EUCON running) no issues with the functionality.
If I close Cubase, one time it appears a faultmessage, next time bluescreen.

The only solution should be never to close Cubase again :unamused:

Just wait for an update of the EUCON driver - probably this will help… :wink:


Cheers

Crash on exit here in Cubase and Nuendo. I’m very sure about it because when I don’t use it, it does not crash.