Behringer X-Touch Cubase 8

Has anyone had success with connecting any (other than the basic fader and buttons) of the functions with the X-Touch control surface? I think I have tried all the connect options (HUI, Mackie, HUI2) but I cannot get the master fader to work, nor can I access the send sub functions or the plug-in functions…
Anyone have any tips?
thanks for any help/advice…
Max

Hi,

In the Mackie Control protocol, the Master Fader is controller via PitchBend MIDI message on MIDI Channel 9. Make sure, this MIDI message is sent.

Thanks for the speedy reply - how do I make sure?
Maybe midi pitch bend is defaulted to off somewhere?
Do I have to map this somewhere?
M

If Behringer is operating in the Mackie Control mode (I don’t know this, I don’t know the device), add this device in the Devices > Device Setup in Cubase. Click to + button, and select Mackie Control from the list. Set MIDI Inputs and Outputs.

Done.

If you want to check, if Behringer is sending this MIDI message, add an MIDI track, and Insert MIDI Monitor. Make sure, the Behringer is selected as an Input, or set All MIDI Inputs (if you didn’t exclude it from All MIDI Inputs, what you should do, once you start to use it as a MIDI Controller). Move the Master Fader. In the MIDI Monitor, you should see the incoming MIDI Message, which should be Pitch Bend, on channel 9.

Hmmmm - I have not tried MC (Mackie) control mode - maybe that’s the problem…I have been using HUI and HUI2…
I did read somewhere that Mackie Mode only controls 4 channels - maybe that’s not true?
I will try MC mode and see what gives…

Hi,

Mackie Control (in general) can Control Banks of 8 Channels + the Master Fader. You can switch Channels, or the whole Banks. If you have more than one Mackie Control devices, the Bank could be even more Channels: 16; 24; etc.

I tried two units and sent them both back, almost 50% of the controls were non responsive in both Mackie control and HUI mode, however faders worked and you can bank groups of 8 , but also had issues with frozen transport and a few crashes. They have a firmware update that is needed for the meters to work with Cubase, initially no meter.

I had the original Mackie control years ago and that worked great with Cubase. I doubt it’s user error on your part, if you google you will see complaints…

Well I switched to Mackie mode and seems like everything works so far - meters - master fader - even plugin control…
I did do the firmware upgrade - maybe that did the trick…
I will post further when I test some more…

Everything still good?
Does the Time/Bars Beats display work?

Hugh

Yes after installing the firmware update (which corrects a Cubase not X-Touch problem) everything works as expected, including the display. The only issue is that the Cubase docs describing how the functions are mapped uses the names on the Cubase overlay for the Mackie, which the X-Touch doesn’t provide. So the labels you see on the X-Touch don’t match what they are called in the Cubase docs. However there is a user provided template in the Behringer forums that does (mostly) get the names right.
http://forum.music-group.com/showthread.php?9134-X-Touch-Overlay-for-Cubase

I laminated it after printing and then cut holes in it so it would physically fit on the X-Touch.

Ok now I have 2 x-touch remotes - but cannot get them working together as they both show up in the device list with the same name - X-touch. I tried renaming the ports but Cubasis refuses to see them as different ports still. Any ideas on how to get these working?

I think there might a way to configure device to change its device ID. I don’t own one, so I can’t be more specific.

Unfortunately the X-Touch only comes with a Quick Start Guide that only explains the connections & layout, but no manual. And it’s not obvious how you’d change the ID. Your best shot is to contact Behringer customer support and ask them how to set up 2 X-Touches.

Did you see this? https://www.youtube.com/watch?v=CbjXRZ2I_mk

Looks like it’s as simple as daisy-chaining them together.

Wow, that is easy. Almost makes me want a 2nd one (if I had space for it). I just checked the user guide and there isn’t even a hint that this is possible.

You know what’s easy, Rodger? 2 CMC-FDs! (Which I use as CC controllers) :wink: :stuck_out_tongue: Thank you!

Yes - saw this video - and it is supposed to work in Cubase - but I can’t get it working…
Cubase reports 2 xtouch but they have the same name - I can’t get Cubase to discriminate between them.
I tried the cascade midi connection too - no difference…

I know this might seem like a dumb, redundant question, but do you have x-touch 1 plugged into x-touch two, as opposed to both of them plugged into a hub or ports on the computer?

And do you have a Mackie Control in your Device Setup?

Yes - I have tried it plugged both ways - does not seem to make a difference.
I get 2 xtouch entries in the midi port setup either way - but cannot get Cubase to use the second one - seems to be confused because the entries have the same name…

Have you tried having just one Mackie Control in Device Setup, and selecting just one x-touch midi port pair?