Behringer X-Touch Cubase 8

Let’s call your 2 X-Touches A & B. When you have them daisy-chained, if you move the first fader on X-Touch A it should move a fader on the MixConsole (make sure the MixConsole has at least 16 channels). Then if you move the first fader on X-Touch B does the same MixConsole fader move or is it a different? Does the white line underneith the MixConsole faders span 8 or 16 channels?

the span stays on 8 channels unless I add another mackie control.
Then it spans 16 - but the second x-touch is dead.
Just for grins I shut off the original one and checked the second one – it works fine on it’s own also

And I did try just having one Mackie control – the second xtouch stays dead …

Did you play with switching the midi port used? I mean leave all as is, just switch to the other x-touch ports in Device Setup…

When I look in the midi port set up – I can see 2 xtouch - I can also change the show as column to xtouch2 - but regardless which one I choose, only the first physical x-touch responds - seems Cubase cannot distinguish between the ports and default to the first one?

What happens if you switch the order they are daisy chained - instead of A-B, try B-A.

Also try replacing all the USB cables. Probably not the cause but it’s good to rule out a bad cable.

Are both X-Touches using the same firmware? I recall I needed to update the firmware when I got mine (and it was to correct an acknowledged Cubase problem ).

You keep saying Midi Port Setup, and I am saying Device Setup, Remote Devices.

Please confirm that you have added 1 Mackie Control.

You should not do anything in Midi Port Setup.

Good catch Steve. Those MIDI Ports refer to a physical MIDI Port on the back panel of the X-Touch.

Here are the steps:

Change second xtouch name ( show as) to xtouch2
Switch midi in and out of mackie control to xtouch2
Select mackie control 2 (second xtouch)
Without doing anything - select mackie control 1 again - midi in and out have reverted to xtouch from xtouch 2
From this I conclude that Cubase cannot differentiate between these ports…

Yes - added mackie control…

As i mentioned, there is nothing to be done in the Midi Port Setup, you are simply spinning your wheels.

The only things to try here involve the Mackie Remote in Device Setup.

Raino - those ports refer to the USB on the back of each unit…
Plug one unit and see one port - plug two units and see two ports…
Assign mackie control to first port in and out - only first unit responds
Assign mackie control to second port in and out - only first unit responds…

But Steve - I have to ASSIGN the remote to a port - that seems to be the part that does not work correctly

Confirming again that I have added mackie remote.
Cables are good - firmware up to date on both units.
Tried changing order of daisy chain and order of power up.
No joy with any of these.

There’s some confusion in terms. You were talking about changing port names in the MIDI port setup pane. I am saying there is no need or purpose for changing names.

Also we are talking about the Mackie Control pane. You have said your tried different port pairs there. If that’s correct, the only combo you didn’t try was the input from the one x-touch, and the output for the other.

But at this point it appears that Logic has some scripting that accomodates the way this device works. With the old Behringer BCF2000s you would set a Device ID. Though I will say I didn’t actually set up two BCFs side by side.

It’s unfortunate that that company joined the dumb-this-down campaign against people who like to read manuals. :wink: :angry:

Maybe you will get lucky and someone from Behringer can help you, but I saw that you posted there already.

No the MIDI Port refers to the old-school MIDI socket on the X-Touch. I just tested using my keyboard. In device setup you should have the MIDI In & Out set to X-Touch like shown in the attachment, not MIDIIN (X-Touch).

Well, Behringer states it will work with Cubase in the comment for the video I mentioned earlier in this thread.

Every Mackie Control thing I have tried with Cubase worked, whether with the BCF or a korg nanocontrol, or whatever thing I cobbled together. Maybe take a day off from trying to set it up and try again.

Also, try disabling Cubase prefs (search for Cubase Safe Start) in case this is caused by prefs corruption, but that’s not so likely these days.

edit- Raino points out something important. You need to be very detail oriented when troubleshooting. Difference between midiin (xtouch), or Cubase and Cubasis, etc.

My money is on the side of you getting this working!

Can you post some screen grabs from Device Setup etc.

Me too. This is just speculation, but when you get it working I bet Cubase sees the 2 physical units as a single big X-Touch device. I think it would need to see them as one device in order to do stuff like spreading out the parameters like in the video. But as you add more units you will see additional MIDI (X-Touch) ports because you are actually adding physical midi connections.

Raino - yes - to clarify - two ports are added for each xtouch - one is the midi port on the device - one is the USB…
At no point did I mention the midiin (xtouch) since I don’t use them - I use USB on these devices - as you correctly point out this is just named x-touch. Reason I am talking about midi ports is because adding a second mackie in device setup (I have bcf2000s too) REQUIRES adding the second ports before they act correctly - 16 channel paging etc…
At no point previously have I seen behringer devices just use one port for more than one mackie control - hence my focus on the correct midi port…
I will keep you posted - good advice Steve on coming back after a brief respite - unfortunately I have been doing that all week! Oh - and I did try in on one and out on the other - no joy there either lol.
Anyway appreciate you chaps weighing in on the problem - hopefully behringer will have an answer…
Thanks again