Bluetooth headphones not working

My bluetooth headphones aren’t appearing under Device Control Panel in Device Setup and as such I’m not getting any sound out of them.
They’re working fine on other apps on the computer.
What’s up with this?

You are on Windows, I assume. What sample rate is your BT headphone capable of and to what sample rate is Dorico set? Both sample rates must match in order that the headphone will appear in the list of output ports. Also, in the Control Panel, try toggling the option at the top which says something like “Allow host applications exclusive control…”

I think my headphones are at 44.1 kHz and Dorico is at 48 kHz. How do I change Dorico’s settings, because I’m not able to change my headphones.

Edit menu > Device setup

There’s a drop down for sample rate but the only option is 48000

Which driver are you using and to what output port is it currently set? Most likely you need to change some settings on the Windows’ side.

On the taskbar is a little speaker icon, right click that and choose ‘Open sound settings’. Then click ‘Device properties’ of the output device and then ‘Additional device properties’.
A new little window opens, in there choose the ‘Advanced’ tab. Is the shown default sample rate same to the sample rate used in Dorico?

I’m using the Generic Low Latency ASIO Driver, and it’s currently set to my internal laptop speakers. I thought it might also be useful to know that it’s not picking up the microphone on my webcam.

The headphones are running at “2 channel, 16 bit, 44100 Hz (CD Quality)”. Dorico is running at 48000 Hz, but there’s no options to change the sample rate on either the headphones or Dorico.

As described earlier, in the Windows’ sound settings, on the Advanced tab is at the top the Default format, set that to 44100 Hz. Also, untick the option “Allow applications to take exclusive access”. Then Dorico should also be able to run at 44100 Hz.

We’ve got one step further. I can now set Dorico to 44100 Hz (the same as my headphones), but the headphones are still not appearing in the input or output ports.

Okay, now go in Dorico to Device Setup dialog and click in there on the Device Control Panel button, a new little window shall appear. In that new window is in the middle a list of output ports. Does your BT headphone not turn up there? If not, try to toggle the option at the top of that window (the one about exclusive access). If then the BT headphone turn up, check mark them at the front of the name and close the window. Also close the Device Setup dialog, that should be it if there was not a little bug. You have to close the project and reopen again, and then sound shall come through your BT.

Unfortunately that’s still not working.

Sorry, your posting is not very helpful either. Did your BT headphones now turn up in the list of output ports (in the Control Panel)? Did you toggle the “exclusive” option? Did something change? Could you maybe post a screenshot?

Sorry for that mildly unhelpful reply.
I’ll give a quick overview of what’s not working.

I have four sound outputs on my computer:

  • Headphones (WH-H900N (h.ear) Stereo – BT headphones


  • Headset (WH-H900N (h.ear) Hands-Free Ag Audio – BT headphones again?


  • Speakers (Realtek High Definition Audio) – laptop speakers


  • HL272HPB (Intel® Display Audio) – monitor speakers

Both the “Headphones” and the “Headset” have the “Allow applications to take exclusive control of this device” checkbox deselected.
The headphones are running at 44100 Hz, and the headset is running at 16000 Hz.

The Dorico Device Setup panel has the following information:
ASIO Driver: Generic Low Latency ASIO Driver
Stereo Output: Speakers (Realtek High Defin 1, Speakers (Realtek High Defin 2
Sample Rate: 48000

The Device Control Panel has:
Allow ASIO host control application to take exclusive control of selected port configuration currently deselected, but it doesn’t seem to make a difference whether it’s selected or not.
The output ports are the laptop speakers and the monitor speakers, both on audio channel 2 with 16 bits per sample.
The only input port is the inbuilt laptop microphone.
Device Setup.png

Hello,

I believe I am having the same issue, and wanted to post my troubleshooting in case it may be helpful. I have followed the same steps in Audio settings as Lucas.

I have the same four options for sound outputs, except with a different model of headphone (WH-CH700N). I have deselected the exclusive checkboxes in both Control Panel and Dorico (I am running the most recent version of Dorico Pro 2.2). My device panel looks identical, and my headphones will not show up in the dropdown. My screenshots look identical (slightly different UI of Dorico 2). I have also restarted my computer, and nothing has changed. I also tried editing the rate in the preferences file, but that caused an error on startup.

I am a bit puzzled as my headphones worked on the previous Windows 10 machine I used with Dorico. The only difference I can think of is that that was a desktop, and thus didn’t have built in speakers.

Ulf, please let me know if you would like more detailed information, but Lucas’s settings appear to be identical.

@Lucas: Okay, since the headphones can only deal with 44.1kHz, you first need to switch also Dorico to 44.1kHz in the Device Setup dialog. If that is done, open the Control Panel and see if then the headphone turns up. If not try again to toggle the ‘Allow ASIO host applications…’ option from the top of that window. It really should in that case. I’ve had already two different BT headphones working with Dorico, a JBL and a Sennheiser, so I know it is possible.

@Mystery: If it is true that the Device Setup and Control Panel look exactly same to that of Lucas, then I don’t need further info, just try the same as just stated above.

Per the attachment, my Device setup does not allow me to switch to 44.1 kHz. I’ve tried toggling, to no avail.
doricodialog.png

In that case: On the taskbar is a little speaker icon, right click that and choose ‘Open sound settings’. Then click ‘Device properties’ of the output device and then ‘Additional device properties’.
A new little window opens, in there choose the ‘Advanced’ tab. In there, set the default format to 44.1kHz and untick the option ‘Allow applications to take exclusive access’. Close that dialog and return to Dorico and see if you then can switch to 44.1kHz there as well.

I have tried that, and it still will not let me change rates.

Sorry, one little bit was missing. After you changed the default format to 44.1k and switched off the ‘exclusive’ option in the Windows’ sound settings, you also have to restart Dorico. After restart it will offer you a variety of sample rates in the Device Setup dialog.

I disabled and reenabled my speakers, and, in conjunction with the tickbox in Windows sound settings, it works now (I had been restarting Dorico, anway).

Thanks for your help!