Bounce In Place is possible in C7 New [Video]

great bounce macro winter rat , thank you for the time you have spend doing these

many thanks

Very very cool macro, great stuff.

I made a variation on the export vsti with a few changes.

New macro tweaked for bouncing just part of a vsti track.


  1. It combines the selected midi
  2. It adds a bar to the loop so the bounce includes the tail
  3. It mutes subsequent midi parts so they aren’t bounced and then unmutes them.
  4. It mutes only the bounced midi part (not the track) and renames the part


  1. New Key Commands file
    For Export (RaggedyJack Edit).zip (16 KB)
  2. Additional Project Editor file
    Name (806 Bytes)
    Requires winter rat’s project editor files

Winter Rat Rocks, credit to him

This isn’t a StudioOne forum.

Very good work!!!

But still a workaround :frowning:

+1 for Bounce in Place!!!

Hey guys,
I’m glad if somebody finds my macros useful.

Raggedyjack, cool addition to the stuff.

Audiocave, you’re absolutely right, it’s my bad and misunderstanding. :blush: Now I see, that my macros are way far from the real “Bounce in place” and sure I had should have named the topic in a different way. I’m sorry for my excessive optimism about the subject. :unamused:

don’t listen to him winterrat it is still a bloody good work around and has been very very useful for a lot of eople i should think , it’s certainly speeded up my processes

Nice to hear about it, filterfreak. But Audiocave is right about the real “Bounce in place” and hence the name of the topic is confusing a bit.

Now few words about my macro. I’ve discovered that if you use divided track list, like this:

then macro can work incorrect, i.e. your new Audio Track will not be placed right under your MIDI (or Instrument) track.
So, to fix this problem you have to add the key command “Divide Track List” at the beginning (possible at the second string) and at the end of the macro (the last string).



Come on Steinberg this feature is obviously over due!

No worries man. What you’ve done here is great because many users (everywhere) whine like babies and never even try making their own macros. :slight_smile: Without guys like you doing the thinking they just wouldn’t have many. Cubase has had macros forever, yet it seems that few people really dig in, they just wait for somebody else to figure it out hand it to them.

The other post (which apparently has been deleted :laughing: ) was only intended to show what modern, fast, good bouncing kinda actually looks like, so people wouldn’t get confused about it, calling it “freeze” or whatever.

If I had known it would annoy people that much i never would have posted it. It’s not like I was trolling, i’ve owned Cubase for decades. Interestingly enough, I’ve done the same on other DAW forums, of DAWS i actually own and use, posting some great features from Cubase with gifs, so people understand what those things actually do, and there’s much less (or none at all) general “paranoia” and defensiveness about it.

Thanks WRat. Great work on the macros.

Hi Raggedyjack,

your macro seems amazin’! Thanks a lot!

I have one problem though: The resulting bounced files are “silent” in my case.
If I bounce the exact same track with the standard mixdown function the files are correct.

Any idea what could be my problem?
I installed your version directly without installing rat’s version first…

Logical Editor files are in place (yours & rat’s).

Thanks for any hint

First go to Export Audio Mixdown and check the following settings:

1.Channel Batch Export
2.Path (wherever you want)

3.Naming scheme: 1.Channel Name. 2.Mixer Index 3.Counter
(This scheme will help to avoid file name conflicts, if you do “Bounce-In-Place” more then once, for certain VSTi. From time to time you’ll need to reset the counter)

4.Sample Rate
5.Bit Depth
6.Import into Project: Pool! Audio track!
7.Close window after export.

I think it can be the culprit.

Hi, first of all thanks so much for the brilliant macro Winter Rat!

i want to ask, how to do this on mac,

i try to put the xml file under Applications - Cubase 7 (right-click - show package contents) - Contents - Preset - KeyCommands…

but when i open the key command menu on cubase, the ‘For Export’ preset is not there, and when i try import the xml file, it won’t select the file…

can anybody help?

thanks in advance.


Love to see Bounce in Place added to 7.0.5

+1 for a real Bounce-In-Place function.

If you use routing, like I do, you also have to re-route the channel to your Master Out first. And then re-re-route again after you are done bouncing.

Steinberg, please add a real Bounce-In-Place function. With realtime option (to use with Virus TI or external hardware). The users would appriciate it VERY much. Especially those of us who works alot with re-sampling.

These macros are great guys…

I love ‘bounce selection’ for audio, it just works, it asks you one question then just does it! Reliably with no fuss.

Something that works the same but with a MIDI event would be my hope as a new feature

Hi, I’m sorry, but I’ve got no idea about Mac OS. I can’t help.

im just going to bump this thread as I feel the new users maybe interested in this macro :wink:

You guys are taking too many steps.

Here’s another method…just export the track(s), and when the export dialog appears, choose “Import Back Into Project”. The file renders, then shows up in a new track right away.

and how many steps exactly does it take to reach the export stage ?

It’s easy, just open the Export Audio menu, select your track and the box that says “import into project”…voila! It literally takes 15 seconds.