Bravura metadata

Could someone point me to where the Bravura metadata.json file is located on the mac, and where metadata files for third party fonts is supposed to go. There is nothing in the default location suggested by SMuFL: /Library/Application/SMuFL/Fonts/, on my machine.

For expediency in the 1.0.0 release, the metadata file is here: /Applications/

You could try putting your metadata file alongside it.

Thanks, Ben!

BTW, you were the one who wrote all the FontLab scripts, right?
They are immensely helpful. Thank you!

Heh, yes - I’m afraid I’m to blame for any bugs you find.

On Windows, this has worked just fine for me.

Came across this thread because I was looking for information now that the changelog for 1.0.20 has been published, which talks about the location for smufl metadata. I went to the specified path on my Mac and the smufl folder doesn’t exist, so I used the path specified in this thread for the .json file, and the font doesn’t appear in Dorico (after restart). I also moved an .otf file alongside the Bravura font. Should I be able to see the 3rd party font in the Engrave music fonts menu if it’s working properly?

The above location is for pre-1.0.20 versions. The new metadata locations are now in an OS-specific, common location that won’t change (AFAIK) as outlined in the SMuFL documentation:

Did you put the metadata file(s) you have there? The fonts should be installed just like any other text font (i.e., the system font folder). You will also need to create a folder with the same name as the font and put the .JSON file in that.

For example, if you had a font called Picasso.otf, on Windows, the font metadata’s full file path needs to be the following:


By the way, %COMMONPROGRAMFILES% will most likely evaluate to “C:/Program Files/Common Files/”

Yes, I can see 3rd-party fonts in the Music Fonts list.

  1. Create the folder “SMuFL” in /Library/Application Support. (not the user Library, though I haven’t checked if that works).
  2. Inside that, create the folder “Fonts”.
  3. Inside that, create a folder named {Whatever your font is called} e.g. “November2”
  4. Inside that, add the json file, which should also be named with the font name, plus “.json”.
  5. Restart Dorico.

Thanks, Ben. I tried this and it worked. Strangely, when I load an existing file and change the music font to November2, Dorico changes the line weights considerably: staff lines and stems become much thinner. I’ll experiment some more with this…

I’ve noticed that too, Vaughan. Hairpins are hideous

Yes, the user-specific path also works, e.g.,
~/Library/Application Support/SMuFL/Fonts/fontname/fontname.json

What you see are November2’s default engraving rules, as set in its .JSON file, so nothing strange there. However, when changing the music font to November2 (or any other font for that matter), if you de-select the option to use the font’s engraving rules, then only the font will change and none of the engraving rules/settings.

If you open the JSON file in TextWrangler, or some other text editor, you will see at the start there are a bunch of default engraving prefs.
I can see the advantage to different fonts having different settings, but you can either turn them off as said above, or modify them.

I installed MuseScore which comes with the Gootville SMuFL font, but the fonts doesn’t show up in Dorico, so this is because of the json file? Where can I find this file and where should I paste it?

If you followed the link I gave you, then the json file is in the same location as the Gootville font on Github.

I’ve given the Mac instructions for where to put the json file in this thread. The Windows instructions are also here.

Thanks, I got it to work. It seemed that not all the fonts I installed showed up in Dorico.


I’ve installed November2 following the instructions but the font isn’t recognized by Dorico.

To be precise:

  • osX
  • November2 installed
  • created a specific folder for the json file (path: HD/Library/Application Support/SMuFL/Fonts/November2/november2_metadata.json)

Incidentally, MTF-Cadence shows up in Dorico.

Thanks for any help


I think the metadata file must have the exact same name as the folder, that is: november2.json


Hi all,I’m sort of a newbie on Dorico. I installed MuseJazz font into right folders and json in Smufl folder. But I can’t see the font as an option in Dorico. The json filename ends with .html, I believe I should compile the file somehow, but I have no clue how to do it.
Please help.