BUG! All recording with a click must happen from a bar and never a beat!?

I have a real problem that’s already cost me money, the respect of my customers and likely cycles of my lifespan.
You see I can’t help but be incredibly frustrated with the continued over-complexity of Cubase 10.
Allow me a moment to provide some background. I’ve been working in pro audio production since 1989. I’ve seen the birth of the DAW, the death of record sales, and the continued degeneration of the industry. When I was forced to use a new DAW I found only a couple of viable options. Pro Tools, Logic or Cubase. Logic has a decent workflow and ease of use that I find incredibly appealing. However, I’m moving further and further away from the Mac OS, and have now switched to Windows for the foreseeable future. Pro Tools was simply too expensive to justify based on previous experience with Avid’s lack of capability to introduce features that other DAWs would introduce many years before Avid. Finally, Cubase seemed to be the only option left, as it runs on both Mac and Windows and is incredibly feature rich. Choosing a DAW, as you may know, is a huge choice. Much like choosing a life partner, because once committed, you’re in it for the long haul. The alternative is to switch again and go through a level of pain no one should ever have to endure. (Getting old sessions to move to another DAW is as painful a thing as I’ve ever encountered in my long digital life.)
With that said, I’m using Cubase steadily for about a year now. I have written over 18 pages of my own manual to remember all of complexities and idiosyncrasies of this overblown software. You see Steinberg has long suffered from the philosophy that they should try and please all the people all of the time. This has resulted in an experience that forgets the basics and instead embraces a ridiculously busy interface, a clumsy workflow and obvious frustration. I expected as much work with software this advanced, but could never have imagined that using a DAW could be this frustrating. I’ll go deeper into this giant mess with subsequent posts about the numerous issues I have encountered with no resolutions. However, getting back to the matter at hand here, lets discuss one such issue that Steinburg support will not admit is a fundamental miss.

My use case is very often just songwriting. I like to record parts in a disjointed manner, simply trying to explore options for a song. What this means is that I want to record, with a click (count-in), and get going. Sounds simple enough right? Well in the usual Cubase fashion, it’s not. It still amazes me how awkward Cubase is. I need to do something rudimentary and Cubase inevitably gets in the way. The session and my momentum stops cold, anger ensues and I begin researching a fix or workaround. Coming back to a focused state for composing is a constant frustration with Cubase.

So what’s the issue?------------------------------------------------------------------------------------------------------------------------------

If I want to start recording from a beat and not on a bar, Cubase simply won’t let me. For example, I want to start to record at bar 9 beat 3. I place my cursor here, arm a track, hit record and the cursor skips backward to bar 9 beat 1. Try it and you’ll see. I simply can’t believe it. I DON’T WANT TO START THERE. THAT’S WHY I DIDN’T PLACE THE CURSOR THERE. How can something so fundamental and simple be screwed up? How can this be screwed up and not fixed with a high priority due to the user community screaming for blood? I mean, you’re really not allowed to start recording from wherever the hell you want to?

More on the issue…
This seems to be a function of the metronome getting in the way. If I again start at bar 9 beat 3 and turn the metronome off (no click or count-in), then recording commences from where I intended it to, from bar 9 beat 3. (great, except the musician has no click now) It’s only when the metronome (click) is on that this occurs.
Is this pre-roll? Nope, those settings are off. Should I have to waste session time mucking about with punch recording to overcome this? Hell no! This is simple stuff and should be fast fast fast! I certainly shouldn’t be expected to move material to the bar to record and then move it back after recording might be complete, right? Well this is what I’ve had to do.

I called support to inquire about this. The representative tried to help but had no answers other than to reset my preferences for the application. Long story short, I don’t want to reset my preferences and shouldn’t be expected to, ever. Not ever. However, because support had no insight for a fix, and astonishingly this is somehow still baked into the product, I did reset my preferences and it resolved nothing! But hey, my anger is at maximum levels, my lifespan is shrinking and I’m in a long term relationship with my DAW that apparently would rather kill me before simply letting me use it for the reason it was created.

So what to do? Support was able to replicate this behavior. However, support won’t acknowledge that this is a bug. He did think that it was strange and that there certainly should be a way to defeat this stupid behavior. He also suggested that I reach out here, as if the community is a partner developer for Steinburg. Hey, I have no other option, so lets give it a go and see what comes of it. At the very least I would hope that more community members would acknowledge this issue and comment here to get Steinburg’s attention. Have you ever wanted to start recording from a place other that the beginning of a bar? Can you replicate this? Please comment, and lets make this software better.

Is this recording Audio or Midi?
If Midi then go to Edit->Preferences->Midi and uncheck Snap Midi parts to bars.

just audio, i.e. guitar dubs

Turn off Snap to grid.

It works fine for me. Click on or off, recording starts at beat 3.

Well that’s not helpful. Support was able to replicate it and not resolve it. It’s a real issue.

No. You asked. I answered.

My Cubase 10 works fine in this regard. it records on the beat I put it on.

Just tested and the recording of audio tracks starts exactly where the cursor is located.
Do you by any change have a midi track record enabled as well?

Thanks KHS for providing something to try. It’s great to see someone trying to contribute and not be contrary. Unfortunately, turning off Snap to Grid didn’t do it. I tried different snap modes and turned snap off completely and still the cursor jumps back to the bar. I’ll retry from a new project and see if this isolates the issue. I’ll also be calling support again to see if they have any update on this issue.

KHS - concerning MIDI record enable - No…a MIDI track is present, but the one track is not in record ready mode.

Are you recording in cycle? I usually do and I’ve never found it a problem…
I seem to recall there’s a preference somewhere like “start recording at left locator” or something. Might be a clue there? Or perhaps play with the preroll settings?
If all else fails maybe just punch in manually where you need, then snap the new audio to the best you want it to start on…? Just as a workaround…

UPDATE: I installed Cubase 10.0.40 fresh on a completely different Windows 10 machine that has never had Cubase on it. It’s running version 1809. (other problem machine was version 1903) The problem is still there. This confirms that the issue is not because of an upgrade path from a previous version of Cubase 10 AND that it’s not project or preferences specific. The problem is there right out of the gate. I’m calling support again tomorrow to beg for some attention to this.

SIDE NOTE: Folks here have said that they can’t replicate this issue. I can’t believe that with the testing I’ve done and simple recreation of the issue. To remind anyone interested in testing about what I’m doing in quick terms: new blank project, insert audio track, arm track for recording, adjust metronome to click during count-in only, change grid type from bar to beat so that it can start on beat 3, place cursor at beat 3 of any bar, hit the asterisk on number pad to start recording - cursor jumps backward to bar beginning. (beat 1)

So angry.

Turn off Count-in. Earlier versions behave same way.

I could turn off count-in, but that would mean working around the issue instead of resolving it. The point here is that this is unacceptable behavior. I should be able to record from anywhere with a click, and furthermore, as a community, we should be demanding either an explanation or a fix. I’m getting neither from support.
I’ve been recording with a click for over 30 years and of course at any arbitrary starting point I desire or require.

I’m curious about your comment on this happening in earlier versions. Did you mean major versions like 8.x and 9.x or minor versions like 10.0.30? Has this really been allowed to go on for years?

Thanks for your input.

I said “Count-in” not “Click”. You can use Metronome Click while recording.
Count-in (Precount) and Pre-roll are different thing.

I have good and bad news for you. It’s not a bug if you’re the only person experiencing this but a setting within Cubase or your system. I promise you. I’ve been using Cubase since the 90s and it’s never done this. The good news is that you can fix it now but… you will need have an open mind and inspect your settings.

  1. Is snap turned on in the arrangement window? If so, it will jump back to the bar if the snap region is set to bar. It is the symbol at the top of the arrangement window that looks like >|<

  2. Press F2, then click on the top left box on the transport control that contains text. You want it set to Punch In/Out and Start at Cursor. Also just check that punch in and out are filled with 0s, eg 0:00:00.000

  3. You might like to use under File=>Preferences, Return to Start Position on Stop. This makes it return back to where you start from. If you find that playback is also snapping to the bar then you’ve probably left snap on.

  4. Any connected control surfaces, control apps or rewire programs could be messing with it.

  5. If you use a firewire interface under windows, you might need to use the legacy firewire driver or stop using the legacy firewire driver as clocking info might not report correctly.

Currentsound- It’s good to have such a long time user join.

Where to begin…
It’s not just me. It’s support too. We reproduced it together. I from my system and he on his. I’ve also reproduced it in an entirely different environment to further prove beyond a shadow of a doubt that it’s baked in right out of the box.

Apples to apples…
All I can conclude is that something on your system is therefore different from mine. Believe me, I’m jealous.

Humbly checking myself…

  1. If snap is turned on, the cursor snaps to the bar. If snap is turned off, the cursor also snaps to the bar. So…either way, I can’t start recording from a beat other than the 1 of the bar. Lets clarify - You wrote, “snap region is set to bar” within #1 of your reply. Humor me as I use the terminology within Cubase so that we may communicate as clearly as possible. I’d like snap engaged or turned on in what’s called the “snap type” toolbar. This toolbar reflects ‘grid’ as it’s default setting. Furthermore, located directly to the right of the snap type toolbar is the “grid type” toolbar. Here the setting is ‘beat’. The default setting is ‘bar’. I had to change this setting, otherwise the Cubase cursor will indeed lock to a bar and placing the cursor on a beat is not allowed. Now I’ve checked these settings, and I believe we’re saying the same thing using similar but different terms. However, I can’t locate any setting called “snap region”. Can you point out how to access snap region? Or…are we indeed saying the same thing?

  2. Pressing F2 brings up the old floating transport bar. I’m completely confused from here. The floating transport bar on my system only goes left to right in a single row, so “top left” means??? I see no text except when I hover over a field and get the pop up explanation of the toolbar. I can expand the punch in/out toolbar to reveal 4 fields that can contain #:#:#:#. From left to right they are: Left Locator Position / Right Locator Position / Punch In Position / Punch Out Position
    I’m not activating punch in/out, so the fields are inactive or grayed out. If I do engage punch in/out, the fields light up, but will not accept 0:0:0:0 as this is not a recognized or acceptable time. Finally, if I want to ensure that Cubase will “Start at Cursor”, that’s located in the bottom most section of the project window in what’s called ‘Common Record Modes’. This has been left at the default which is, as you’ve said, “Punch In/Out” and “Start Recording at Project Cursor Position”

  3. I usually do engage the ‘Return to Start Position on Stop’ setting. However, not here in my virgin system which is being used as a control for this testing. This can be ruled out.

  4. No control surfaces, apps, or rewire programs are used. These can be ruled out.

5)No firewire. I use an Apollo Thunderbolt 3 interface from UA.

I’ve played around with the settings I believe you’re referring to, and no fix has been found. I would really enjoy seeing your system work correctly. If you’re willing, I would love the opportunity to do a Teamviewer session with you. This would expedite knowledge sharing. If you’re willing, please message me.

Actually, can confirm on 9.5.50

I think this behavior is related to “Count-in” only.
FYI, Studio One behaves same.

Use Pre-roll (Deactivate Count-in), Activate Metronome Click, Check “Click while Playing” in the Metronome Setup
(If you don’t want clicks while record is running, uncheck “Click while Recording”.)