BUG: Cubase 9.5 Tempo Detection only works properly at 44.1k

I’m going crazy with getting tempo detection to work properly in 9.5.

I’ve used it in earlier versions (6-8.x). Read the manuals. Watched a dozen or more offical and after market help guides and tutorials.

Am I doing something stupid or is this a bug? Freeze at end seems so.

Here’s my workflow:

  1. Tracked multiple songs in a single project (8 channels of drums plus midi triggers, DI Bass, guide vocals and guitar from a different room). Settings: all tracks on linear time base, (not musical mode); 96k 32bit; RME gear; UAD Octo (not used in tracking); win 10; everything up to date (inc 9.5.10);
  2. From a clean start open the “tracking” project
  3. Select a song to work on> save as new project; range select and delete time before and after the target song leaving just the one to work on. Save. Optionally restart.
  4. Open newly saved project. Nothing except clean audio tracks and a single midi track.
  5. Add a stereo track. Select some material with good regular transients (eg kick, snare), record them to the new stereo track.
  6. Select the new event. In the bottom zoom area, set hit point threshold / edits to pick all the transients. Select Detect Tempo. Select Analyse.
  7. Tempo track and signature track get added. Session goes into time warp mode. All good to here.
  8. Issue 1: The detection Never picks the start transient as a tempo point.
  9. Issue 2: if I warp/ drag the grid to the first hit point IT WILL NOT STICK. It just rebounds back. (Snap is NOT enabled)
  10. Issue 3: I then try some other grid points to other hit points, they won’t stick either and just gives me yet another wrong guess at the tempo map overall. After a few more tries, cubase locks up! No crash. No error, just freezes as if it’s gone into some infinite loop (and so have I).
  11. Restart computer, calm down, watch another tutorial, repeat from step 4.

Any help really appreciated - I’ve spent days and days trying to make this work to no avail.

Issue 1 screenshot attached.

Many thanks

I have exactly the same problem. I’ve used previous projects and created a new project and imported an unrelated audio file. No matter what tracks I try to detect and edit the tempo it always ends in the same freeze after a few attempts to edit points, (springing back as described), and even leaving the computer for a few hours there is no resolution. Only way out is to select cubase and “end task” in the windows task manager utility.
Has there been any suggestions how to resolve this?

I’ve found out one thing - Tempo Detection works fine for me at 44100 Hz only, any other sample rate leads to the behavior described by BrendanMcL.
In C8.5 it works OK.

Good pick up. Steinberg, is this something you can look at? Happy to further triage with your suggestions.


@Winter Rat @Oldercodger1946 do either of you have a simple step by step, repeatable process starting from a blank project that doesn’t use any external recorded audio that we can use to allow Steinberg to replicate the error? I’m happy to be a tester if you do. Then we can get this logged as a confirmed bug and get a fix.

I am also having the exact same problem. Very frustrating when I have Clients waiting.

As soon as I’m at Cubase I will answer.

same problem here

Same here :frowning:((
(48kHz project)

Has there been any response from Steinburg on this issue?

I can confirm that tempo detection does work as expected at 44.1 sample rate but not at 48K or 96K.

Tried several different ways all end the same. There is no set of steps that produce this problem, I have not tried 44.1 sample rate. I will post when I get a break. I am using an old dinasour laptop to get around this, it’s slow with lots of to and fro ing but it works.

Yep. Recorded a project in 44.1k and the tempo detection and editing works fine.
Opened an existing project in Pro 9.5 recorded at 48k, this has all the afore mentioned issues. I changed the sample rate to 44.1k, (still set to 24bit), followed the convert audio prompts and on completion, tried the tempo detection and editing. Would you believe it works fine. Same thing with a project recorded at 96k.
The tempo detection and editing only works at 44.1k.
I have updated Cubase to latest V9.5.30, still having the same issue.


How about a reproduction sequence? The posts here give general reports, but no specific way to isolate the steps required to repro.

I did create a 48k project, and tried Tempo Detection on a 48k audio file and did not see any probs.

Here you are.

1.Create a 88.2 kHz - 32 Bit Project.
2.Find in the MediaBay file “05 106 Drums-a”
3.Insert it into project.
4.Open Audio Pool
5.Uncheck Musical Mode (arrow #1 on the pic.)
6.Do Export Audio Mixdown
7.Create New project 88.2 kHz - 32 Bit
8.Import the new file into project
9.Select the event
10. Fulfill tempo detection
11. Try to move Bar #14 (arrow #2 on the pic.) to its proper position (arrow #3 on the pic.)

The Bar jumps back to the previous position.

If you do the same steps in 44.1 kHz project all bars will stick to the places you move them.

I’ve upgraded my PC recently so I had to reinstall everything, now I’ve got the cleanest of the cleanest system.

Actually my post is repeating BrendanMcL’s first post. The situation was already pretty clear IMHO.

There is no specification for the sample rate of the export, and the first 7 steps seem to serve the purpose of creating a file to use for the test, rather than being part of the repro sequence.

I did attempt the repro, but I think the steps are not the ones needed.

I’m sorry, but I don’t have time to read through the narratives about the issue above, but I am willing to attempt a repro if given the steps to do so.

The First 7 steps are there to show that I used nothing but Cubase and Steinberg Content, so nothing else involved, and you can skip them.
Just do tempo detection and try to move a bar to another position being in the warp mode. That’s it.

If it’s that simple,

  • set project sample rate to anything other than 44k
  • record audio file
  • do Tempo Detection
  • move a barline using timewarp tool

There must be more to it, as it worked as expected for me.

Sorry to say, without a clear way to reproduce, there’s no way to analyze the problem. In this case, Steinberg support would have the time and resources to help someone figure out how to make the steps.

For me

  • recorded at 48khz
  • do a tempo detection
  • with tempo detection panel active and reanalysis direction to the right
  • change any dot in the middle of the audio file, and thats it,
    unusable, everything seems to be reanalyzed.

Please, include your OS and OS version details, without it your report is pretty much useless, since this problem can’t be reproduced on every system.