Bug? Moving notes with multiple selection

When I select two or more notes in an instrument and move them (by using alt-arrow) the notes between the selections will be erased. It doesn’t matter to which direction. The first selection behaves as expected. Is there a way to get around that?

insert mode ?

I just checked, and I have the same result as yours. Insert mode does not change anything. What’s more interesting is : why haven’t I tried this in 2.5 years?
Easy workaround : do the move for each note independently :joy:

With insert mode on even stranger things happen… in my example the part between the selected notes jumps two bars behind the second selection. But it works with chord mode on. It’s not really what I expected but that way it works. I just think there shouldn’t be deleted or shifted notes. At least I didn’t find the logic in that.

With insert mode on, I got exactly the same result as with insert mode off. Are you sure you did not change the grid?
I’m not surprised it works with chord (Q) mode, as it’s really non destructive.

This is my result with insert mode on. Same grid (8th) as before. The 4 quavers jumped from bar 3 t bar 5.

you’re right, it is destructive and crazy.
alt-shift-l/r with insert seems to work predictably.