BUG - "Process has locked pages" BSOD - UAD-1 Issue - Solved

UPDATE 2 - Solved!
Following solution provided by Steinberg has worked for me (it only worked after deleting C5.5s data as well for some reason):
i) Please close Cubase and go to START>Programs>Steinberg Cubase 6 > Cubase 6 Application Data Folder
and delete all the files you will find on the pop-up window.

ii) After that please repeat the same procedure but for every other version of Cubase installed (e.g. Cubase 5 ):
START>Programs>Steinberg > Application Data Folder

UPDATE - Narrowed issue down to UAD-1 initialisation issue

System - Windows 7 x64 SP1
At least 1 x UAD-2 PCIE and 1 x UAD-1 PCI
Cubase x32 5.52/6/6.01

Steps to reproduce:
Create a project.
Add some audio tracks.
Add some UAD-1 plugins (make sure that they are set to run from the UAD-1 not UAD-2 via the UAD Control Panel)
Save project.
Close Cubase.
Re-open Cubase & Project > BOOM! BSOD with “Process has locked pages” error.
Verify that the same UAD-1 plugins don’t cause an issue in other VST host programs.


I’ve been checking out the trial of C6 - mostly enjoying the new features.
Upgraded to 6.01 and started getting hard crash BSOD - “Process has locked pages”, when closing/quitting.
Eventually I couldn’t open a project with Cubase 6.01 without the crash occuring.
Uninstalled - reinstalled C6 trial + update - same crashes.
Uninstalled - reinstalled just C6 trial - same.
Uninstalled C6 & Elicencer, then installed archived Elicencer - everything working fine back in Cubase 5.52, but this version of Elicencer won’t work with the C6 Trial.
My hunch is that there’s a problem with the latest Elicencer software, which is really annoying as I was set to purchase an upgrade from the trial.
This is using Cubase x32 under Windows 7 x64 - ATI HD4550, UAD1 & 2, RME Fireface800 & Babyface.
Anybody else have similar issues?

Hmmm…
Up-grading a full working version of Cubase sometimes can be problematic so
I can imagine that up-grading a trial version might also present some probs.


maybe one of the mods can offer some help
{’-’}

Lotsa people having problems that are most likely related…

http://www.steinberg.net/forum/viewtopic.php?f=19&t=3291

I get a similar message to yours, if I try to restart cubase after it has crashed:
0xCB DRIVER_LEFT_LOCKED_PAGES_IN_PROCESS in module KS.SYS

Basically, if Cubase 6 ends unexpectedly, I need to a do a reboot otherwise I have a got a BSOD coming my way…
(Yes, I am on WinXP, but clearly this is not a WinXP-only issue)

Thanks for the replies.
Fwiw my machine is very clean - never, ever had an issue before this one. I’ve subsequently run Memtest intensively and various other diagnostics but can’t come up with anything that doesn’t point at C6/Elicencer. As mentioned, C5.52 is working just fine.
Yep, I saw the “Crash On Exit” thread, but I also noted that they wanted to keep that thread to exit crashing and not BSODs.
Do any mods have any advice to offer at all?

Also, it trashes all my preferences and reinitialises a whole new VST scan.
One thing I noticed, a sign that the project would BSOD - any UAD plugs would be flagged as “Disabled” in their GUIs. Turning them off and on again was needed to initialise them properly.

friendly bump

I had this problem too…
And each time I get a BSOD this happens… I’ve to configure everything again…
Steinberg should look at this and they should think of a solution when there’s a crash when don’t loose the preferences and the presets…

Ok - I seem to have narrowed this down further.
It appears to be a problem with my UADs.
Cubase 5.52 will load project fine with UAD plugins.
Cubase 6.01 will BSOD “Process has locked pages” on loading project with UAD plugins.
Cubase 6.01 will load project fine if I remove “Powered Plugins” folder from VSTPlugins folder.

Right - pinpointed the issue.
For the last couple of years I’ve been running 3 x UAD1 PCI, 1 x UAD2 Duo PCI-E on Cubase 5 x32 under Win 7 x64.
No problems, no issues.
I installed the C6 trial and now as soon as it initialises a Project with plugins running on the UAD-1s:
BOOM!
BSOD - “Process has locked pages”
Cubase 5 now gives me this crash as well.
Projects have no issues running on just the UAD-2.
I’ve weeded through the UAD-1s to see if its a dodgy card, but all 3 individually will give me the BSOD.
I can’t believe all 3 have clapped out at the same time - indeed I can use the UAD-1s quite happily outside of Cubase, in other VST hosts.
Please help!

Just noticed that the others on this thread, also have UAD-2/UAD-1 combination.

Update - Now running full licence C6.01.
No change to the UAD-1 “Process has locked pages” BSOD on exit problem.
Only solution at the moment is to pull the UAD-1s and just use UAD-2.
I’ve emailed UAD about this. If you have a similar issue please do the same.

Hello,

I have reported this issue to our Q&A department for a closer look. (28524)

Cheers,

Chris

Thanks Chris.

I tried it yesterday and my system responds normally. NO CRASHES on reloading a project with both UAD1 and UAD2 plugs applied.

Interesting. I wonder if its related to your older non-hyperthreading Q6600 compared to newer i7s? For me its a really clear issue - UAD1+UAD2=BSOD. Uninstall UAD1s and use just UAD2=ok. Reinstall UAD-1=BSOD.

No problem here with UAD 1 & 2 on Windows 7-32 Cubase 6.0.1

Ok - I’ve been able to narrow it down even further. Its seemingly to do with memory load as well. (All RAM 24 hour tested fine by Memtest).
If I start a new blank project, with just one audio track - no problem using UAD1 & UAD2.
If I open heavier projects - 150 track count say - then I get the BSOD.
(One other difference - these projects are at 48khz).
I haven’t had time to find out what the memory tipping point is for me, or even if 48khz versus 44.1khz or other makes a difference.
For the guys with no problems if you could answer a couple of questions I’d really appreciate it - are these small/medium/large projects? Whats your peak memory usage? What sampling rate?
Thanks.

Updated first post as problem has been resolved.