[BUG] Quantizing sliced drums is broken(video/.cpr included)

I brought this up in another thread a while back and i’ve seen it mentioned here a few times but have not seemed to be able to get any attention drawn to it.

quite plain and simple this is definitely a bug. i just quantized a whole record and it was a nightmare because of this bug. it’s simple.

-make an audio slices manually on multitrack drums in the part editor(this might still not work on single tracks, i’m not sure)
-90% of the time pressing Q will work correctly but other times it will go to the wrong beat(like i’ll be 2ms from the next 16th note but instead it will go to the one 100ms away before it).
-Happens about 1/10th of the time. If you try it once and the quantize function fails as described, press undo, and try again it will once again go to the incorrect beat.
-the only "solution’ i’ve found to this is to bounce the audio on that multitrack segment. Of course that totally messes up crossfading and takes more time than just putting the hit back on beat but it may be a clue to what’s internally messed up here.

I certainly hope they aren’t having trouble reproducing this but i can make a video or something if i have to I’m just not too good at that sort of stuff and this is simple as can be to reproduce. I’ve tried this on several systems so it’s definitely not system specific

I should point out i am NOT using the iQ button and just trying to do a straight quantize. I just want this and the awful inability to make a shortcut to the quantize panel style “crossfade” bugs to be fixed asap because they’re making my job almost impossible when it comes to attempting to hand quantize parts like i used to be able to in C1-5.5

For whatever reason, using the “make hitpoints, use group mode, slice multitrack drums in quantize panel, quantize drums in panel” functions work fine. this is only a problem when i manually slice audio in the arrange window like i always have on versions previous.

hello? anybody? :cry:

I have not yet tried to do this so i am no help. This is supposed to be a big feature in C6 though, shame if it doesn’t work properly.

I haven’t been able to quantize audio succesfully yet either. When I use hitpoints and slice it leaves gaps in the audio. I thought crossfading would make it ok but it didnt. Guess I need more practice…

yea I don’t think that is at all related to the bug i’m describing.

Seriously, i cannot be the only person annoyed that the quantize function is broken.



Seriously people please chime in . I saw in the 6.02 thread that I’m not alone with this. please share your experiences so we can at least get this a registered bug.

OK, since no one else is answering:

I’m on 6.0, and I’ve only tried it briefly, but it seemed to work wonderfullly on most tracks. However, had one slow song where there drummer drifts quite a bit, and there is lots of cymbals involved, and that sort of crapped out. I believe it is because Cubase quantized the hits to the wrong beat, and the reason was simply that the drummer was quite far off. The other irritating thing is that it there were audible stuttering in the cymbals, because they had to be crossfaded quite a lot.

I firmly believe all this was down to the simple fact that the drum performance was too far off to be fixable. On other tracks it has been almost magically smooth. But it is not magic, so there is a limit to what it can do.

Thank you for chiming in. you however are NOT experiencing the bug. I’m guessing you are using hitpoints and multitrack slicing/quantizing. That works flawlessly actually. this bug is when i’m slicing drums in the arrange window(or non drums) by hand and then attempting to quantize them. Sometimes they can be directly next to the correct beat but get moved waaaaay away from where they should be to the previous or next beat.

When you cut in the arranger make sure the snap point has been set correctly!

You can see and edit the part snap point marker from within the sample editor.

can you explain this further? I’m saying in the arranger i’m slicing objects. I’m not doing any further settings…i’ll try to look up what you’re talking about but like i said this isn’t likely it since it’s working 9 out of 10 times. In other words i dont’ think there are any snap points set which should default to the making the snap point the beginning of each cut i make. if that’s not the case…is there a way for me to set it so it is?

I agree, the snap point should default to the cut start, to make sure you can check in the sample editor.

Page 268.

yea this was not related. i found one that was doing the glitch and it most certainly had the correct snap point.

Oh well…

Gotta chime in on this one… I have the exact same issue. Using iterative quantizing sometimes shifts the entire selection of audio backwards by a random amout of bars. This happens no matter where a sync point is.
this is confirmed on 5 computers at the studio running Win7
The only cure seems to be bouncing the audio and quantizing again.

To be clear this happens with iterative quantize off as well. I have only confirmed on 3 computers but i would hope that there is some way to get this bug attention it deserves. slowed me down big time today again. :frowning:

“i would hope that there is some way to get this bug attention it deserves”

Then report it with

1 Clear simple easy to follow reproducable step by step A B C instructions and and wait for many confirmations from other users and/or

2 A downloadable project that others can confirm the fault with if you have and/or

3 A video with comentary that shows the problem



Just butting in because reporting bugs the way Hippo describes allows people to help out by confirming, and that also must make it easier for the devs to find them!

Did this in this thread i felt. Number 1 that is. #2 is obviously impossible. If it’s really going to take #3 to do it does anybody know of some simple video capture software for me to use?

But as far as instructions go

  1. Take an audio track in the arrange window. make a slice and press quantize. repeat until problem appears. It WILL.

I guess I will have to make a video to get this problem any attention though.

http://www.castleultimate.com/glitch.avi (original 300mb uncompressed)
http://www.castleultimate.com/glitch2.avi (lo-fi 7mb version)

Here is a clip of the glitch occurring. It occurs at the beginning and you can see me pressing undo and then retrying several times before just moving the audio clip with my mouse. It then works as it should for a bit and then glitches again at the end of the video as well around 0:32sec.

Also, apologies for the large file size and horrible lack of editing of the video. I had no idea what i was doing but hopefully it gets the point across.