Bug Report: MIDI timing issue Cubasis Loop Mode

This bug is known for a few years (reported by a few other users) but still not fixed and It needs to be done:

When Cubasis 2 is set to loop mode (let’s say a 4 bar audio loop) and is playing along with external midi sequencers or keyboards it looses sync. Cubasis is drifting with each pass of the Loop Point.

I have tested it with different hardware and Cubasis Versions on several iPads with the same result. Other iPad DAWs run fine.


  1. Summary/Title
    (Provide a short but descriptive sentence that summaries the issue or feature request)

ANSWER: Cubasis 2 looses midi sync when using loop points

  1. Description
    (Provide a detailed description and list the step by step process to reproduce the issue to help the team to understand and reproduce the problem)

A) Create a audio track and name it
B) Add a sample (drum loop) to the track
C) Turn on the Loop points (any measures)
D) Turn on the midi clock out
E) Choose the used midi out device and midi channel
F) Click Play
H) Let the devices play in sync

  1. Expected Results
    (Describe what you expected to see)

ANSWER: You would expect the Cubasis to stay in sync with external midi device.

  1. Actual Results
    (Describe what you actually saw)

ANSWER: Cubasis looses sync. Every new round of played loop points grows the time gap. The problem exists no matter how long the time between loop points is (tested 1-8 measures)

  1. Environment
    (Count the hardware and software including version numbers being used)

Hardware: iPad 2018
Operating system: iOS 11.4.1
Software: Steinberg Cubasis 2.5
Midi interface: iconnectivity iconnectMidi2+
External midi gear: Bass Station 2, Novation Circuit, Elektron Digitakt

Hi everybody,
I recently purchased Cubasis (v2.6) for iPad (running iOS 11.4.1) and one of the first things I’ve tried is MIDI clock sync to external gear, which to my surprise, did not work properly.
I had to learn that the subject had already been discussed on different forums without a solution, so I’ve decided to do some research too in order to verify if the problem is caused by Cubasis and not by anything connected.

Describing the issue and the scenario to reproduce it is in fact quite easy:
As soon as you enable Setup > MIDI > Send MIDI Clock, set the left and right locators around a few bars and enable loop playback, cubasis will send 24 MIDI clock messages per quarter bar, but at the transition from the end of the looped section to the beginning, Cubasis will send one MIDI clock message too many.
If you set the loop range to exactly one bar for example, during each loop iteration, instead of sending 96 clock ticks, Cubasis will send 97 clock ticks, causing the infamous audible clock shift that increases with each loop cycle.

I had the chance to test the same setup with two older versions of Cubasis (v1.9.8 running on iOS 7.1 and v2.2 running on iOS 8.4) and only the oldest tested version v1.9.8 worked perfectly, sending exactly 96 clock messages per 1-bar loop.
Version 2.2 on iOS 8.4 already showed the same misbehaviour as the current v2.6.
So apparently the issue was introduced in a Cubasis version between v1.9.8 and v2.2.

I hereby kindly ask the Cubasis dev team to have a look at the code changes done between v1.9.8 and v2.2, some little bugger must have found its way into the code :wink:

Hi all,

As mentioned in similar related topics before, our engineering will evaluate the issue.
However ist is not yet clear, if the issue can be addressed with the upcoming Cubasis update.

@ physicalgear
Thanks for the additional info, which will be shared with our engineers.


I have same problem with my outboard gear as slaves to Cubasis clock all is good unless I loop a section then clock drifts.

Did 2.7 update fixes it ?
Just want to know is it worth to install Cubasis back again…

Hi jjur,

Thanks for your message.

Unfortunately, we have been unable to address the issue in the current 2.7 update.
Please have a look at the Cubasis 2.7 announcement to find the full list of improvements and fixes included in the update.


Thank you for response.
Yes, I have read report and I noticed that some MIDI fetures were upgraded.
So just little light of hope appears that it will finally starts working fine with mobile setup.

Thanks for acknowledging this bug. I am experiencing it as well and can verify that the steps mentioned above recreate the issue.

Dear all,

it seems that the MIDI timing issue in loop mode has not been solved yet.
I have been experiencing it while using Cubasis 3 (latest version) on an iPad Pro to trigger external drum machines.
Tried everything to fix it without success. Now I found this thread, which describes exactly the issue of time shifting increasingly after every loop.

I love working with Cubasis on the iPad, but with this issue I can not work the way I usually do, turning on and off the tracks live in a short loop.

It would be great if this issue could be fixed.

Any help is highly appreciated if there are any other solutions to avoid this timing issue using loops.

Hi castor,

Thanks for your message.
The issue has been shared with the team.

Stay well,

Hi Lars,

great. Thanks for the quick reaction.
Probably important to know that in Cubasis 2.8.4. this MIDI timing issue with external gear is not existing. So this problem had already been solved, but it appeared again in Cubasis 3.


Hi castor,

It would be great if this issue could be fixed.

Our team is unable to reproduce the issue, using an iPad Pro 11 (iOS 14.3), Cubasis 3.2.1, Midimatte II or UR44 and Yamaha W7 (below please find the detailed steps)

If the problem persists, please provide us with a short clip that shows the steps to allow us reproducing the problem. Please upload the clip via Dropbox or similar and let us have the DL via PM.



Testing procedure

- Be careful to always rewind the MIDI clock receiver and also start Playback in Cubasis from the beginning of the song (1.1.1)

• New project, create a cycle of 1 or more bars.
• Create a midi track, a MIDI event and draw a note on every 1/4 beat, eg. HiHat.
• On the Yamaha W7, create a 79 bar long song with a note on every 1/4 beat, eg. Grand Piano key c1.
• Activate MIDI Clock (Setup / MIDI) in Cubasis and start playback in Cubasis from bar 1.

Result: Yamaha W7 song is still in sync in bar 79 on every 1/4 beat, compared to the Cubasis HiHat and metronome click.

Hi Lars,

thanks for your reply.

The MIDI timing issue appears only when looping a sequence using the cycle button of the transport bar and increases after every loop.
When playing the song once from beginning to end everything is fine.
However, once you loop a sequence it gets quickly out of sync.

To check it your team could try looping a 4 bar (or 8 or 12) sequence with a bassdrum on every 1/4 beat and let it run for a while.
After a few loops you clearly notice it getting out of sync.
After a minute the first beat of the sequence is totally out.

In Cubasis 2 this issue is not existing. There you can cycle loop a sequence for hours and it stays in sync.

My setup.

ipad Pro 2nd gen, iOS 14.1, Cubasis 3.2.1., Midimate II,.
Issue appears triggering different external gear: Elektron Rytm, Nord Modular, Volca beat.


Hi Lars,

today I did a new test in order to try to reproduce the issue and good news: now it stays in sync.

The test was just a very simple loop of one track with a bass drum every 1/4 note.
Later I added a second track with hihats.
After a few minutes it was still in sync, so it seems to be OK.

However, it is weird that an identical test which I did a few weeks ago still gets clearly out of sync increasingly after every loop. Same with a project I did also a few weeks ago (when I started working with Cubasis 3 and not 2)
I went through every single detail in the settings and couldn’t find a difference.
I also deleted the track and did a new track in the same way as the new test, but within the old project. Again, it got out of sync very quickly.
The only difference that I can think of is that the projects were created before the 3.2.1 update…

I have no explanation for that. But I’m very happy that it works well for now.
I’ll observe the sync behavior on new tracks and inform you if I notice it getting out of sync.

Many thanks for your support.

Hi castor,

Thank you for your updated feedback.

today I did a new test in order to try to reproduce the issue and good news: now it stays in sync.

We are glad to read that the issues seems to be no longer reproducible.

However, it is weird that an identical test which I did a few weeks ago still gets clearly out of sync increasingly after every loop.

Please let us have a short video clip and the project alongside the exact steps to reproduce the issue. Please share the files with us via Dropbox, and let us have the DL via private message.



I have noticed that the timing issue while repeating a loop and triggering external gear is still there.
However, it is really strange. I am not able to reproduce it.
While on the older project it was clearly getting more out of sync after every loop, on the newer project I can not recognize any sort of rule. It just gets “weird” after a while and starts to stumble.
One day it is stronger, on other days its hardly perceivable, When I try to reproduce it it is not there and then an hour later it is there.

I first thought it might be a problem of the external gear or maybe too many signals going out at once, but I don’t have any of these timing issues on Cubasis 2.
There I can loop a sequence for hours, turning on and off tracks as much as I want and it stays tight.

So all I can say is that something is different on Cubasis 3 regarding the loop mode while sending out MIDI signals to external gear.

I will try to do a video next weekend to reproduce the issue, but as I said it is hard to tell in which particular situation it appears.


Hi Lars,

here’s the video as promised.
I was using an iPad Pro 12,9, iOS 14.4 and Cubase 3 to trigger sounds via MIDI to an Elektron Rytm. Midi interface is a Midimate II.

The shown issue only appears on Cubasis 3.
With Cubasis 2 the timing stays tight all the time.

I hope the video helps to find the issue.


Hi @castor,

Our engineering is unable to reproduce the problem.
Here are some additional questions:

  • Do you have “Send MIDI Clock" enabled under Setup / MIDI ?
  • Would it be possible to send us screenshots or a video showing all Setup pages and the Inspector’s Routing panel?

Thanks again!

Stay well,

Hi Lars,

yes, Send MIDI Clock is enabled.
I also tried switching it off, which made no difference.

The settings for the test were as simple as possible.
See the image attached.

What is really weird is that I cannot reproduce the issue on a new project, but it is still on the old project.
It gets still out of sync, but in a different more random way and not in this continuously increasing way like in the video.
I have noticed that it is also out of sync compared to the software instruments. I compared a 4/4 bassdrum beat from the external gear with a bassdrum from an internal instrument playing simultaneously and there is a slight delay between them.
I thought this might be a problem with the MIDI interface, but the same test with the same hardware works fine on Cubasis 2 without any delays or out-of-sync issues.

I tried to record the delay in a video, but it doesn’t come out well on the recording.

I’m sorry I can not help you reproduce the issue. It is really weird.
I only can say that nothing of it happens with Cubasis 2, so maybe it helps to compare what could be have changed there.
I will stick to working with Cubasis 2 and hope for the next updates of Cubasis 3., which is of course full of great new features that I really miss.


Hi @castor,

So it looks like the issue seems to be related to the old project, and unrelated to Cubasis 3?
Which Cubasis version has been used to create this project?