Bug Report: MIDI timing issue when using Loop Points


There seems to be an issue with the MIDI Clock / tick messages being sent to other apps when you are using loop points (particularly noticeable if you set one bar looping).

Each time the the bar loops the receiving apps tempo will drift out slightly. This doesn’t happen with those same apps if you don’t use Loop Points and just let the song run, they will stay perfectly in sync, so it seems that the transport is definitely an issue at the Loop Points.

This doesn’t happen with all apps, so I guess some apps (depending on how they implemented MIDI Clock Sync, Song Position, Continue etc.) handle this issue better than others, but it is definitely a Cubasis Loop Point issue as it doesn’t happen when your not looping. You can actually hear it drifting with each pass of the Loop Point. The apps that I tested that struggle with keeping tempo when using Loop Points are DM1 and Electrify NXT.

I’ve tested this issue my iPad Mini Retina. I also tested it on my kids iPad 3 and iPad Mini (non-retina) all running the attest OS and version of Cubasis. All devices show the same behaviour.

I’m hoping you guys can fix this issue :slight_smile:


I’ve found this too, although the problem occurs before even trying to sync to another app. There seems to be some kind of internal timing problem when using loop markers.

To illustrate, try setting the BPM to 120 and setting a one bar loop with the metronome on. If you run it against a stopwatch you’d expect the tick of the metronome to occur exactly every 0.5 seconds (so two ticks per second). After just a few loops the tempo will start to drift. Quite noticeably too. So much so that it’s impossible to use loops in Cubasis and sync them to anything else.

Like you, I’ve tried this on several devices and all have the same problem.

I’m surprised no-one else has reported this. Seems like quite a big deal to have such an important thing broken.

I’m really hoping they fix this too as it’s useless to me without being able to sync loops in Cubasis to Ableton Live.

Any chance this can be fixed in the next update?

same Prob here. I get no answer either from support or from forum.
It seem´s to me general midiclock prob. Because Miditempo is calculated, so it must have a few bars to calculat the bpm. But thats not the reason for synced loop desaster alone. I never get a stable loop with extern Equipment. the only workaround for is to set the bpm the extern device and disable the clockout in Cubase. Then record the loop and turn the clock on again.

It’s not a problem with all apps though. BOOM 909! Was released in the AppStore today and it syncs perfectly with Cubasis. I think it’s something that can be fixed by third party developers, but I do wonder if there’s something that could be done with Cubasis that could help to remedy the issue.

@sdesign - I’ve found it syncs with Boom 909 quite well too. But check again! Although they sound to be playing in time, the drift is still definitely there. Again, running it alongside something external which is running at the same tempo and Cubasis is still speeding up when using loop points. So even when apps appear to sync, they’re just syncing to Cusasis’s broken MIDI clock and managing to keep up. It’s as though it’s missing out a tiny part of the loop each time it repeats.

Interesting to see no comment from the Steinberg team. They must still be investigating…

They don’t seem to comment on bugs reports, which I find a little arrogant to be honest.

They usually do actually…

Not in my experience.

I don’t have problem while syncing seekbeats (analog synth drum machine).
Sync is tight ,I can play loop during 30min ,even tweak seekbeats sounds.You re problems
Come from your apps or your iPad probably.

Hi All,

Sorry Customers, I was absence in this forum for cubasis 1.8 automation implementation.

I can confirmed 5 ms cycle jitter only on beat 1 in cycle playback with iElectribe & Cubasis.

It is hardly audible but it’s measurably.

Not all cycle jitter with midi clock and other apps is caused by cubasis, but this 5 ms jitter is definitly caused by us.

We are investigate and looking for a fix and we will inform if we have a solution.

Thanks to all the Guys they hear the grass growing.

best jan

Thanks for confirming this, Jan.

Yes, a 5ms jitter on beat 1 when looped would definitely explain why I’ve been having problems when keeping in time with an external tempo.

Hoping it’s possible to fix…

Yes thanks for confirming, glad you are working on fixing this! :slight_smile:

Has this been fixed? Thanks…

Unfortunately not :frowning:


No, currently isn’t fixed. We will inform you, if we have a fix.


Im getting this problem also. Still no news?
Im hoping someone has found a workaround. I hope it’s not, dont use loops point when syncing!?

Hi Richtowns,

Please provide us with the project plus exakt step by step description, so we’re able to reproduce the issue.
Please use Dropbox or something similar for the upload and let me have the download link via private message.


Hi all and Steinberg support. I’m a new Cubasis user and a new forum member.

Logged in because I have the same problem mentioned on this thread. Cubasis 2 midi timing looses sync when using loop points. Without loop points the sync seems to work. I have iPad pro with latest iOS and my interface is Roland Duo-Capture EX. I bought Cubasis to be used as a companion for my Ditto x4 looper and because of this bug it’s completely useless for me.

This bug was found long time ago, any news or plans to fix it? Thanks!