BUG : Sampler Control Vintage resample quality takes over AudioWarp mode

Hi,

There is an issue in the Sampler Control where the Vintage resample quality takes over the AudioWarp mode.

Reproduction sequence :

  • Create a Sampler Track and load a clip in it,
  • Default quality is set to Standard (AudioWarp off),
  • Play a little with a controller, note that the sample speed changes in relation to the pitch,

  • Enable the AudioWarp mode, and note that the sample is always played at the same speed, regardless of the pitch,
    sampler audiowarp mode

  • Now Disable AudioWarp and select the Vintage quality. As usual, the sample speed changes along with the pitch.
    sampler vintage quality

  • Enable AudioWarp once again, and notice that the AudioWarp mode isn’t working

Result : When the Vintage quality is selected, it takes over the AudioWarp mode. The classic resampling mode keeps taking effect regardless of the AudioWarp setting.

Such an issue doesn’t happen with the other Standard, High, Best and Extreme quality settings.
It only happens when Vintage is selected.

Issues list, number 43

It’s mentioned in the manual that the Vintage quality and AudioWarp aren’t compatible.

Vintage quality switches the Halion sampler engine to linear interpolation, simulating the resampling artifacts of the E-mu SP-1200 (or other 80’s 12 bit samplers such as the Akai S-900 and the Roland S-50 if you change the settings). This conflicts with the idea of AudioWarp, which is to keep the played sound as close to the original sample as possible, no matter the pitch.

So this isn’t so much a bug, but an UX issue. Either setting the resampling quality to Vintage should make the AudioWarp menu inaccessible (like Halion) or using AudioWarp should revert the quality back to Standard.

1 Like

Sorry but at no moment the Manual says that AudioWarp isn’t compatible with Vintage.
I don’t know where you’ve seen such a statement, or maybe you did not interpret it properly.

Please read the Playback Section page carefully.
The sentence “Note : This option is only available if AudioWarp is deactivated.” obviously refers to the Quality selector, not just the Vintage setting in particular. It simply says that the Quality selector is only available when AudioWarp is disabled, which can’t be more logic, right ?..
For the AudioWarp section it says “If AudioWarp is activated, the following options are available in the Playback section : … Mode > Music / Solo”, meaning that it replaces the Quality selector.

At no single moment it is said that the Vintage quality takes over the AudioWarp mode.
It is clearly a bug, the Vintage setting conflicts with nothing at all, and enabling AudioWarp should enable AudioWarp.

Maybe in manual is not clear but @Romantique_Tp explanation make complete sense to me.

1 Like

I read the note as applying to Vintage because of the syntax:

This option is only available if AudioWarp is deactivated.

“This option” is singular and the statement appears directly below the Vintage paragraph - a singular option. The paragraph above it refers to “Standard, High, Best, and Extreme”. If the note applied to them too it should read “These options” which it does not. So sorry, between syntax and proximity, I read it as stating that the Vintage option only is available when AudioWarp is deactivated. Granted they could have made it a little more obvious but I read it correctly the first time so I don’t think it’s that far off.

1 Like

Okay, great, here we go again… You guys are really going too far with that.

This option is only available if AudioWarp is deactivated.

What is hard to understand in this simple sentence ?
According to the above sentence, then what is supposed to happen when we activate AudioWarp ?
Well the direct answer is : Activate AudioWarp.
Of course it is only available when AudioWarp is deactivated ! Because when we activate it, the selector is replaced with the AudioWarp settings !
Your logic is completely contradictory to what the sentence says.
Then it should instead say “AudioWarp is not available when Vintage quality is selected” ?
This makes No . F*cking . Sense.

There’s absolutely no reason the AudioWarp mode would not work when Vintage is selected, they are not even related to each other ! They are two separate modes !

Seriously, I’m containing myself but I’m boiling from the inside right now.

Also, the syntax as you say, the Note isn’t directed to the Vintage paragraph, it is displayed as a third point, like that :

  • Standard, High, Best, and Extreme
  • Vintage
  • Note :

If you look at the AudioWarp section, the Note is directed to the Music mode and is displayed like this :

  • Music
  • Note :
  • Solo

You guys are playing with words and I hate this.

1 Like

what is the doubt? It´s clear that is not one issue, it´s a very technical limitation.

Whoa. Someone puts one sentence and hallelujah this is the truth ? Where did @Romantique_Tp pulled out such information from ?
There’s no such technical limitation, and it does not conflict with anything at all.
AudioWarp is one option, and the “Quality” mode is a completely different option.
It doesn’t matter if the quality is set to Standard, High, Best, or Extreme prior to enabling AudioWarp.
This won’t set the AudioWarp quality. AudioWarp only has two setting : Music and Solo.
This is not related the the Quality settings at all.
The Vintage Quality setting remains because there is a bug that prevents to switch to AudioWarp. Okay ?

1 Like

It is a bug, as when you enable audiowarp it should take precedence and therefore swap to offering ‘MODE’, not ‘QUALITY’ - but it gets stuck following the example provided.

In regards to the user guide. The note regarding “This option is only available” relates to the entire QUALITY selection, not specifically Vintage mode within QUALITY selection.

That’s why the manual is indented as such:

i.e.

Other sections have their notes indented to the criteria they relate to, too:

It’s really straight forward, as @Louis_R says, I don’t know why people are wanting to playing with words.

Is it not obvious that selecting Audiowarp should enable Audiowarp? I can’t see any logic where it’s good to have a button that doesn’t do as it says?! As above, it’s a bug - obvious when you follow the OP’s instructions.

1 Like

I think the @Louis_R is correct. If you change to vintage mode you can make your track sound vintage which is cool… But if you change back to AudioWarp it doesn’t work BUT Cubase does allow AudioWarp to be selects, and the GUI looks like it’s on AudioWarp and it even states ‘Mode: Music’ but it is still using Vintage mode in the background.

If you go into Vintage and select ‘Standard’ before going back to AudioWarp it works correctly. But surely Cubase should do that part automatically and not just make it look like AudioWarp is working when it is not.

Thats the issue, if you press AudioWarp and your in vintage it should come out of vintage mode and select ‘Standard’ but it doesn’t, it looks lke it has done that but it hasn’t.

I agree with what the moderator has said, that they are incomparable, but if Cubase is allowing the user to switch between them then it should work as the GUI has indicated, or simply not allow the user to switch directly between modes.

1 Like

And please explain me why it should go back to Standard ?? Why is that ? AudioWarp is a completely separate mode, it does not have to select anything to work. There is no limitation of such kind, now stop saying the contrary !

Cubase remembers the Quality setting that was previously selected when you disable AudioWarp, since THEY ARE TWO DIFFERENT MODES :

  • Normal mode : with Standard, High, Best, Extreme and Vintage quality settings,
  • AudioWarp mode : with Music and Solo settings.

I don’t know how you guys can have such a hard time understanding that.
You absolutely want the Vintage setting to interact / not be compatible with AudioWarp, but they DO NOT !!!

This is just a simple bug.
Period.

That’s true. In Halion, the whole AudioWarp section is greyed out when the quality is set to Vintage, so you can’t enable it at all. What causes the issue described in this thread is the fact that the sampler engine doesn’t expect you to be able to enable AudioWarp while the quality is set to Vintage.

Cubase 11 worked around this by automatically switching from Vintage to High quality before attempting to enable AudioWarp. This fix was lost when the Sampler Track UI was revamped for Cubase 12. That’s definitely a regression.

@skijumptoes is correct about the manual. The note saying “This option is only available if AudioWarp is deactivated.” is supposed to refer to the whole Quality section. I misinterpreted that as only applying to the Vintage quality setting because of the Halion behavior described above. I apologize for any confusion this may have caused.

2 Likes

at least now, since we know that this don´t work in the way you want, and understanding that, we just don´t waste time trying to use it in this way.

Let´s see if it´s possible to ask it, as a request, to change how it is working right now to the mode you are requesting, and if it is not possible, maybe ask just to block this option in a way people don´t think it is a bug.

2 Likes

@Louis_R Give in to your anger. With each passing moment you make yourself more the emperor’s servant

All I am saying is if you select standard it changes back just fine. But that doesn’t seem like anything the user should have to do to make it work.

However it gets fixed, the solution is really nothing to do with me. I was just pointing that out as I was agreeing with you. If Cubase auto selects high quality or standard or just makes it work or greys the option out unless the user selects one of those and better updates the manual, frankly I care not.

But its nice to have a work around in the posts for anyone who tries this and gets stuck. They can select one of the options above vintage and it will switch back fine…until this bug actually gets fixed that is…Kind of what the forum is for I guess.

Remember I am actually agreeing with you Darth_R.

2 Likes

Sorry I didn’t read all the thread, but I just reported this 2 days ago. I also reported it in the early stages of C11 and it was fixed by disabling the vintage mode when audiowarp was enabled, but seems that there has been a regression at some point.

3 Likes

Great @Alberto_Pedraza, thanks for that.

1 Like

Hey,
I would like to apologize for being rude.
Especially to you @RTT1 , you actually made a post pointing out the issue perfectly, but at the time you posted it, I was still angry and did not the take time to read and understand it carefully.

So apparently everyone is saying that AudioWarp needs the Standard quality setting to work (or anything but Vintage), but in fact we just don’t have to know that, when using the Sampler.
When we activate AudioWarp, all it has to do is to change its settings in the background, without the user knowing, and regardless of the previously selected Quality setting.
Then when we deactivate AudioWarp, it should recall the previously selected setting, even if it was set to Vintage.
When AudioWarp is active, the other settings are hidden anyway, so we don’t need to know what it does.
It simply needs to work properly.

Have a great day guys, and sorry again.

6 Likes

@Louis_R No worries chap, forums can be like that. I’ve typed angry in the past too. Happens to the best of us. :slight_smile:

I was just having a bit of fun with the star wars thing.

Its a bug for sure, just needs fixing. I’m sure whatever we say about it, Steinberg will fix it how they think it should work. They wont be listen to me about it lol

2 Likes

we are all here learning , and since audio is a passion, some times it gets hot, at least in arguments :slight_smile:

2 Likes