[CAN-18940] Some plugs show white GUI

Loaded up New Sonic Arts plugs and the GUI comes up as a plain white box until I close it and reopen the instrument with the “edit instrument” keyboard icon.

https://ibb.co/ekvGjf

Could it be that you have HiDPI enabled in the general preferences? If the plug-in itself isn’t really comfortable with HiDPI this could happen.

No , it’s a fresh install with nothing changed. HiDPI was turned off, when I turned it on it said I had to restart the program and when I tried to exit out of Cubase it give me a blue screen crash with the cause being SeraphAD2.sys - my audio driver , failed.

I had issues with my Marian AD2 when I moved from Pro 8 to Pro 9 too, which needed both yourselves and Marian to fix with updates.

I don’t think we have either the plug-ins nor the hardware here to test. However, I have contacted the plug-in developer to see whether we can test for ourselves.
Regarding the bluescreen and the Marian, you should definitely get in contact with Marian.

Thanks. I emailed James from New Sonic Arms, he said it could be display driver related but I’ve updated the drivers and the issue still stands.

I get this on Waves API plugins.

Open C10
Load C9.5 Program which has the plugin on insert channel (Insert Position 1)
Using Mix Console Click on plugin insert, opens with white / blank GUI. Click on it again crashes C10.
Could not remove plugin either as it crashes C10 (crash seems to occur on second click on the effected plugin)

Adding a second instance of the plugin appears to load OK and GUI displayed (Insert position 3)

Also looking at other posts re plugin issues saw a reference to disabling HiDPI in General preferences. Is this a PC thing as cannot see any such setting on my Mac?.

Any ideas,

I can reproduce it with the New Sonic plug-ins here. It seems to be related to “always on top”. On a white GUI, right-click and switch it off. Now, the GUI is shown.

@Dave
We weren’t able to reproduce this here with the Waves API plug-ins. Is there an update available for them maybe?

We have filed a bug report now. I have updated the topic subject to reflect that.

thank you!

Undertaken a bit more research on this and Waves Plugins.

My version of waves used for this test is V9. Listed in plugin manager as Vst 3.02 64bit. It appears that all users of Waves 9 will find they have GUI crashes in Cubase 10. No idea if Waves V10 update will solve this. It appears from the Waves site that those updating from Waves 9 to Waves 10 run into their own sets of problems so no guarantees there then for C10 users.

A possible work around is use the generic editor interface in Cubase 10 which appears to bypass the GUI processing in Cubase 10 and passes the audio without crashing Cubase.

No idea why this is a Cubase 10 only issue though. All work OK in Cubase 9.5. Will need further testing to find out if Cubase 10 is the only DAW they crash in. Have tested in both High Sierra and Mojave, C9.5 OK C10 crash unless generic editor used.

David

Same problem here with Roland Cloud instruments VST.
VST3 versions of the same plugins display GUI correctly

Further digging re Waves v9 Plugins and C10.
It appears the Waves V9 GUI Pugin crashing C10 are only occurring for Mac users not Windows, as several users on windows seem to be running V9 versions OK (They may have other issues connected with HiDIP though).

The weird thing here is the plugins when first selected for use in a project do display correctly but it’s when you close the plugin and re open using the editor button that this problem occurs. So it appears there’s some handling issue in the code used between closing and reopening, so surely this is fixable at the Steinberg end.

So Mac users be wary re upgrade to C10 as you may get an indefinite wait to get your plugins working again as you fall between two heavyweights each claiming the other should fix, and not for the first time.

David

Also tried rescan of plugins in C10 but still same effect. One other user told me it worked for him solving his crashes so it appears Waves 9 plugs can load on C10.

Can someone clarify if I should move / delete the Cubase Pro VST3 Cache preference folder so Cubase rebuilds the directory and contents on next load (assuming I don’t get the eLcc load errors).

Thanks
David

It appears the Waves V9 GUI Plugin crashing C10 are only occurring for Mac users not Windows…
…The weird thing here is the plugins when first selected for use in a project do display correctly but it’s when you close the plugin and re open using the editor button that this problem occurs.

This is an exact description of what I’m seeing. The only difference is I see a black window, not white after reopening a Waves plug. Attempting to edit will crash C10. Of note: the offending plug can be dragged out of the slot and deleted without crashing.

On WIndows 7 x64, Cubase 10, my Waves 10 plugins behave ok (JJP series, CLA’s and Ren Reverb). The plugin I have an issue with is the Eiosis Premium Air EQ. The top half (scope) displays but the bottom half (controls) is all white.

Don’t know if it’s relevant re this GUI plugin problem but when I first got this the reopened window was white, now after rescan it apppears the blank reopened window is black, either way I can’t get any of the Waves v9 plugin to display.
I’ve also noted today that trying to switch to the generic editor from the blank black plugin window now also crashed Cubase, this wasn’t happening before plugin rescan as generic editor displayed allowing plugin to work.

Can’t get any consistency in results in these C10 crashes which makes debugging or accurately reporting issues a challenge.

David

I’m seeing this a lot on all sorts of third party plugins. Not all but the ones I would like to use:(.
It started in Cubase 9.5 pro and does the same in Cubase pro 10. This is on a Windows 10 64 bit pro 1809 update system with 16 GB of memory and an i7 8700 CPU Nvidia Geforce CTX 550 GPU.

Is this still the same in Cubase 10.0.10? If so, which plug-ins exactly are these and which exact versions are installed?

The list is long so those that are the developers Melda, Nugen, Newfangled, Eventide. The latest versions of all of them.

Yes this is with Cubase Pro 10.0.10.

Hi Ed.

Sorry to derail this thread, but my issue report has been kind of acknowledged (by Martin) but doesn’t have a code like this, i.e. “[CAN-18940]”

https://www.steinberg.net/forums/viewtopic.php?f=286&t=150390

This is the thread, step by step reproducible. Thank you.