Cannot update 4.2 Authorise Download Assistant hangs?

Hello, I have tried several times to upgrade Dorico 4, but come to a halt with the message Authorisation needed (or something like that )

What am I doing wrong ?

It’s late on Saturday night with a heat wave in England so responses to you might be slow. They always suggest that you start with Steinberg Download Assistant to update the Activation Manager and make sure you’re using the correct email address which can be different from previous log ins.
Hopefully someone will help you soon.

@bill19, I’m afraid your message doesn’t provide quite enough information for us to be able to advise. Can you tell us exactly what you’re trying to do, and perhaps show a screenshot of the error message you’re seeing?

When I try to log in to Steinberg Download Assistant, a page is displayed asking me to authorise this, without there being any details or link as to how I can do this.

Is it better for me to start from Dorico 4, going via the ‘Check for Updates’, or to start from the Steinberg Download Assistant ? - both bring me back to the page I have described - I cannot proceed.

When you run Steinberg Activation Manager, if you are prompted to sign in, you should find that clicking the button to sign in takes you to your web browser, where you may be prompted to sign in (if you’re not already signed in with your Steinberg ID), otherwise you should see a prompt from your web browser that tells you you need to authorise Steinberg Activation Manager. I’m guessing that this prompt doesn’t appear for you?

What web browser are you using?

Hello Daniel,
The problem seems to be that the prompt from my web browser (I am using Firefox,) does not give any indication as to how I authorise Steinberg Activation Manager - this page is displayed, but no way to authorise .

I’m not sure where in your browser settings you might find options controlling the appearance of these kinds of prompts. Are you running any extensions in Firefox that might interfere with these kinds of prompts? It might be worth temporarily disabling all your extensions, then trying the sign-in process from SAM again. If you still get nowhere, it may be worth trying an alternative browser. If you’re on Windows, you will have Edge installed; if you’re on Mac, you will have Safari installed. Either of them should do the trick.

To temporarily change which is your default web browser to a different browser, see here for Windows:

And here for macOS:

Sorry Daniel, I tried by changing to Outlook - no change - then I changed back (I do not use Edge ) and I still get the same message

“To authorize Steinberg Download Assistant, you must allow your browser to open Steinberg Download Assistant. Once authorization is completed, you can close this page and continue working with Steinberg Download Assistant.”

I also tried to disable Adblocker, but this had no effect - the same message appeared.

It is a bit of a mystery, or is there something obvious I am missing ?
Sorry about all this - everything seemed to be going so well.

Outlook isn’t a web browser, it’s an email program, so I wouldn’t have expected that to work :slight_smile:

What version of Windows are you running, exactly?

Sorry - I realised that outlook was not a browser.
I have looked at the Firefox download details - Steinberg Download details are shown, so I expect it will be possible from there, otherwise I will have to try to set up Opera, or something like that.
I am running W10.

If you have Windows 10, you should have Edge installed already, as it’s built-in to Windows. Can you try searching for it (type “edge” into the Search bar on your taskbar)?

Sorry, Daniel, but when I upgraded to W 10, Edge was not part of it. When I was offered Edge, it seemed to be such an intrusive app that I have consistetnly refused to install it.

I hope that there is another way.

Yes, I’m certain there is. I’ll ask one of my colleagues who has more expertise in the area of handling this authorisation flow to weigh in.

For the record, Firefox has always worked for me with SDA and Steinberg installations. Could it be some setting (like refusing cookies outright rather than on approval) that is causing the problem?

Hi Bill - which version of Windows 10 are you running?

Hello, in answer to your question, could it be the app Ad Blocker I have installed ? I can disable it, but I am not sure if this is the cure for this problem

I know that I am running W10, but do not know which version - where can I find this info , please.

You can follow the instructions here: Which version of Windows operating system am I running? - Microsoft Support

Thank you. The version is 21H2 - I think

That sounds good. We’ve had reports of people on earlier version of Windows where the login process wasn’t working properly.

Just so I understand correctly, is it Steinberg Download Assistant that you can’t log into?

If so, could you try pasting this into the address bar of Firefox to test to see if things are working:


It should launch Steinberg Download Assistant (it might say “login failed” - this is expected). Let me if SDA doesn’t launch and we can investigate further.