Cannot use Apple AirPod Pros as audio output

I am trying to use my new Apple AirPod Pro headphones as an output in Cubase 11 (on MacOS 12.0.1 Monterey, MacBook Pro 2021, 16 inch, M1 Max). Unfortunately, it appears that there is a bug preventing me from getting this to work.

I think I know how it SHOULD work:

(i) Use MacOS’s “Audio MIDI Setup” tool to create an aggregate audio device, and include the AirPods there as one of the outputs. (ii) In Cubase 11, go to Studio → Studio Setup → Audio System, and select this aggregate driver there as the “ASIO driver”. (iii) For convenience, below “Audio System”, click on the name of your aggregate driver and enter meaningful output names on the bottom right. (iv) Under Studio → Audio Connections → Outputs, add a new output bus that uses the AirPod channels. (v) Use Cubase channel routing to point your audio output to this new output bus.

Unfortunately, I could not get this to work. The problem starts right after step (i), and it appears that there is a bug in Cubase causing this:

With Cubase not yet launched (!) and my AirPods in my ears, MacOS’s “Audio MIDI Setup” tool works nicely, and I can successfully add AirPods as an output to my aggregate audio device; at that point, it displays TWO AirPod output channels, as it should (stereo). However, as soon as I launch Cubase (before the file selector window pops up), the “Audio MIDI Setup” tool start displaying only ONE AirPod output channel. I can see this one output channel within Cubase and at least create a mono output channel from it, but when I route sound to it, I don’t hear anything. When I close Cubase, the channel count in the “Audio MIDI Setup” automatically switches back to 2.

I believe that the changing channel count in the “Audio MIDI Setup” tool is not merely a sign of switching to mono, but rather a sign that something else is going wrong internally, and likely a bug in Cubase 11, maybe in connection with either the brand new macOS Monterey or my new MacBook Pro M1 Max. Unfortunately, I can no longer try this issue on an older system, so I am not 100% sure.

Any suggestions?

I read about this issue over on a Dorico post. Short of it is:

Airpods are not only headphones but also a microphone and so there are two identically named devices. No matter which of the two you choose, always the first one gets picked, which is the microphone. Hack-around mentioned in post, maybe not supported yet in M1. You can read more about it here:

Also, I have the same problem on a MacBook Pro 2021 with Nuendo (used for Atmos work). Which is not a big deal, I wanted to use the AirPods as a quick check, now I just export a mixdown and open it in the actual devices (AppleTV, Macbook, Quicktime player, etc).

I’ve had this problem with wifi headphones as well - Sony WH1000 XM3, which also has a microphone . I work on Big Sur on a 2016 MacbookPro so it’s definitely not only a Monterey or M1 problem.

I got these to work by doing the following:

  • switch to the Sony driver in the Studio Setup-ASIO Driver dropdown
  • open Audio Connections and disconnect the Sony INPUT connection
  • connect the stereo output to the Sony
    voila!

Just checked this with my wife’s airpods and it works.

Not sure if this solves your problem as you have to change the ASIO driver - so just flipping over to bluetooth headphones to check mixes is inconvenient.

that should read bluetooth headphones.

Thanks to both of you, this got me at least closer to the solution; unfortunately, there is still a problem – see below.

First, here is what helped me:

(1) In the aggregate device that I create in the Mac’s Audio MIDI Setup tool, as suggested, I must indeed exclude the AirPods microphone (marked with 1 input, as opposed to 2 outputs). This way, upon Cubase startup, Cubase no longer messes up the aggregate device and confuses the AirPods’ input and output parts. Cubase and/or Apple should fix this.
(2) If during the aggregate device setup you have problems hearing the “Test Sound”, leave your AirPods in their case, with the case’s lid open. Don’t take them out until your setup is complete and you have loaded and set up Cubase (not sure exactly when it is ok to take them out).
(3) If in the Audio MIDI Setup tool the AirPods are grayed out or completely invisible, go to the very top right of your Mac’s screen, near where date & time are displayed, click on the small symbol that opens a settings menu (Wifi/Bluetooth/Airplay/Display/Sound…), click on “Sound”, and (with your AirPods still in the open case) select the AirPods. (Also make sure there that the AirPods’ volume is not at zero.) This will make the AirPods appear in the aggregate device setup.
(4) Since you likely want to include both the AirPods and the Mac Speakers in your aggregate device, in the Audio MIDI Setup tool you must go to Configure Speakers (bottom right) and then on the top left select the Configuration “Quadraphonic”. In the four lines that are now visible on the bottom, select the channels corresponding to MacBook Speakers L/R and AirPods L/R. Play a test sound to test and click Done.

So now I can finally route my Cubase instruments to my AirPods. Unfortunately, here is a remaining problem:

Using this aggregate device in Cubase, even if I route my sound to the MacBook Speakers (!), I am getting a crazy large latency (~170ms for both input and output), whereas the “Built-in Audio” driver has only ~4ms. This delay makes it near-impossible to play; so as a result, whenever I record my MIDI keyboard, I still have to switch the ASIO driver…

Any ideas on how to fix this latency?