Can't change A4 print page size

I’ve got a US letter size score in Dorico. I want to print it as a pdf. But (in Print Mode) Dorico won’t let me change the A4 setting to Letter. In fact, it won’t let me change the A4 setting at all.
Does anyone know why this is?

Oh look I’ve found a solution! First, you have to go out of Graphics mode, into Printer mode. There you can find a page setup option which allows you to specify US Letter size. Then you go back Graphics and suddenly Letter is possible.
Duh! Why didn’t I think of that. It’s obvious. Just like it’s obvious that you first have to select png 600 dpi before you can get pdf at 600 dpi.
Hello Dorico team!

Graphics Export greys out the page size in the right panel of Print mode, because that page size is irrelevant. Set the size you want in Layout Options, ignore the one in Print mode, and export.

…and please search - this one comes up frequently.

I can in D2.
in the LAYOUTS panel check the Layout you want to change. Bottom on the preferences (wheel) > Page setup.
There you can select various sizes.
Hope this helps

What you’ve found (Mnatseah) isn’t the solution. I repeat: the page size in Print mode is irrelevant to the page sized used for Graphics export.

The field is greyed out because it is populated by the formats provided by your printer’s drivers, and, as such, irrelevant when printing to PDF. When “printing” to a file, that file will inherit whichever dimensions were specified in Layout Options.

Thanks to you all for your comments. However, I assure you all that my page size was well and truly set to Letter in Layout Options > Page Size. Yet Print Mode was still determined to print it as A4 and nothing else.
But, like I said, I found a none-too-obvious workaround.

David, it really doesn’t matter what appears in Print mode when you’re exporting. Dorico would have been determined to print to A4, but it would have been equally determined to export at whatever size was set in Layout Options.

Your “workaround” is NOT a workaround; it’s merely a way of making one irrelevant value in a purely cosmetic field display a different, equally irrelevant value.

Thanks Leo. And everyone else.

@pianoleo Unfortunately the printer page size IS relevant even when exporting to PDF. My only installed printer is a label printer, and it selects the default paper size for that printer when exporting in graphics mode, which is a 4x6" label. The driver does not include standard letter paper as an option, so I can’t select Letter, Tabloid, etc.

When I try to print to graphics (PDF), it fits the score to the 4x6" page proportions, which leaves blank space at the top and bottom, since it’s taller than Letter size by proportions. I don’t know how to fix this other than to install a dummy printer and select Letter size from there.

This seems like a Dorico bug - they should default to your page setting in layout (which is set to Letter) for printing to PDF, not the printer driver page size selected in Print mode.

Update: Only the preview is wrong. The exported PDF correctly uses the Letter size as I selected in Page Setup in Layout options. The incorrect preview in Graphics output mode is a Dorico bug.

Welcome to the forum, Dan (if I may be so bold as to presume!). It’s not a bug that the print preview doesn’t show the exact PDF dimensions when exporting graphics but rather a limitation of the fact that it’s a print preview, i.e. it really is bound to the paper size chosen for the printer. When you export graphics, you’re not using a printer at all, and we’d have to cook up a fictional printer with an appropriate paper size in order to update the print preview, which is easier said than done. I do agree that it can be a bit misleading, though.