Can't edit in WaveLab

I need some help. I suppose I’m doing something wrong but I can’t properly use the function “Edit in WaveLab”.

I’ve followed the procedure:

Select the file in Cubase/Edit in Wavelab/ perform the editing/Trigger Cubase Update. The file in Cubase doesn’t update but a new file with the same name is created in folder called “WLEx_tmp”.

What I’m missing? I feel stupid.

Hey SteelyDani,

The files in the WLEx_tmp directory are fine. Cubase and WaveLab exchange temporary files which are stored in this directory.

Nevertheless you should see an update after hitting “Trigger Cubase Update” (unless you did not do any changes in WaveLab). Can you please give more details what exactly you are doing? Some screenshots or a video maybe?

Best,
René

Many thanks for your answer.

This is a simple example of what I’m doing:

  1. Select an audio file (“B4 II sin vibrato”) in Cubase
    Audio file selected in Cubase.png

  2. Click Audio/Edit in WaveLab
    WaveLab launches with the file “B4 II sin Vibrato” opened.

  3. Select the second chord left channel:
    WaveLab opens the file.png

  4. Process the selection by applying +10 dB of Gain.
    WaveLab with the processed file.png

  5. Click on Trigger Cubase Update. The file is apparently saved in WaveLab.

Coming back to Cubase the edited file in WaveLab has not been updated. The left channel of the second chord remains intact without any gain applied. The screeshot is just the same as the first one “Audio file selected in Cubase.png”.

Any help?

Yes I know. It’s a stupid question and its solution is very obvious. The problem is that I can’t find it and I’ve tried in two different computers.

Believe me or not but I’ve been a WaveLab user for almost twenty years. I remember when Cubase files could be edited in WaveLab but if I’m not completely wrong they didn’t update. May be I had the same problem.

Heeeelp please!!!

Hi,

does this problem also occur on another audio file ?
I tried to reproduce but here it works so far.

cheers
Kay

I’ve repeated the whole process ten times with a file called: Gt Mute Formula_11.wav.

When clicking Edit in WaveLab, WaveLab launches and opens a file named Gt Mute Formula_11.wav. Likewise a new file with the same name has been created in the WLEx_tmp folder.

I’ve edited the file in WaveLab increasing the gain by 10 dB. Now the name in the WavelLab tab is Gt Mute Formula_11*. I’ve clicked on Trigger Cubase Update. The tab name is now Gt Mute Formula_11, what means that the file has been saved.

Coming back to Cubase I’ve got two different results (6/4):

  1. Nothing happens in the original file. No Gain has been applied to the Gt Mute Formula_11.wav file.
  2. A new file called Gt Mute Formula_11-01.wav has been created in the correct Cubase track but just at the beginning of the project. The original Gt Mute Formula_11 file in Cubase remains identical with no Gain applied.

In both cases a file named Gt Mute Formula_11.wav remains inside the WLEx_tmp folder. After performing each of the ten tests and before starting the next one I deleted this file from the temp folder.

When verifying the path of the Gt Mute Formula_11.wav file opened in WaveLab, I note that it is inside the WLEx_tmp folder not directly inside the Audio project folder. I mean that the file has been actually edited IN WAVELAB but HAS NOT BEEN UPDATED IN CUBASE. The WaveLab file is inside the Temp folder while the Cubase file is inside its own audio project folder. Two different files. One edited (WaveLab) and one intact (Cubase).

I’ve lost more than two hours fighting against this new feature. Very frustrating.

Hey SteelyDani,

Correct. WaveLab will never touch or even modify the original audio files which are open in Cubase. This is why it works with temporary files which are copies and which will be put into WLEx_tmp.

Correct.

Correct. As explained above the original audio file will never be changed by WaveLab.

Creating Gt Mute Formula_11-01.wav is correct as we never modify the original file. What you should actually see is that the audio event on the track will be updated and uses Gt Mute Formula_11-01.wav instead of the “old” Gt Mute Formula_11.wav.

Correct. It is just a temporary file which will only be used by WaveLab and which Cubase does not use.

Correct.

  1. Audio/Gt Mute Formula_11.wav will never the be changed/modified/touched
  2. Audio/WLEx_tmp/Gt Mute Formula_11.wav is a temporary copy in order to let WaveLab modify it
  3. Audio/Gt Mute Formula_11-01.wav is a copy of Audio/WLEx_tmp/Gt Mute Formula_11.wav after WaveLab has finished editing. This file will be used in Cubase.

So please keep in mind that the original audio file does not change in Cubase. The event on the track will be updated though with the modified audio file from WaveLab.

Does it clarify things? Do you see any update on the event?

Best,
René

Thank you very much René for your exhaustive analysis and explanations. Everything is much clearer now.

I’ve repeated the process taking the precaution to previously delete the temp folder created during prior trials and in this occasion the Cubase event has been properly updated. I suspect that the problem could be in the temp folder mess full of files created during previous trials.

Thank you again.

Unfortunately the problem persists. Different computer. Different OS. Different sound card. Different project. Files edited in WaveLab doesn’t update in Cubase.

I’ve selected an event that makes reference only to a small fragment of a much bigger file used in other parts of the project. I’ve followed the usual process and the result is:

A new audio file has been created in the Temp folder, but after editing its name remains exactly as the original. No new file with similar name as the original but adding ”-01” has been created.

The Cubase event has not been updated with the modified audio file from WaveLab.

I give up. If it is not a bug it resembles a lot.

I have the same problem, even on a clean installed system, open file in wavelab through cubase, i can see the cubase icon in wavelab, but saving the edit does nothing. have given up on using the feature :frowning:

Well, I’ve been able to edit a Cubase file in WaveLab, but only if the track has only one event, I mean only one and unique file.

For example, if I record a mix of the project I can edit this file in WaveLab and triggering the Cubase update icon actually updates the file in Cubase.

Unfortunately, there is still a small issue. If I delete in WaveLab one part of the file, let’s say a couple of seconds at the end of the file, when updating in Cubase all the editions are properly kept except these couple of deleted seconds that still remains in the Cubase track and must be deleted by hand.

Has anyone this same issue?

Last update:

Even with one unique file the problem persist in most occasions.

Saving alone is not enough. You need to hit the [Trigger Cubase/Nuendo Update] button.

Greets,
René

That’s the current behavior. While “reintegrating” the modified audio file/snippet into Cubase, it does a “insert and replace” operation. So in case you change the length of the audio file/snippet in WaveLab the result will be exactly as you describe.

Greets,
René

Just in order to clarify: after updating you do not hear any difference, right? Or is it just the graphical representation which is not updated correctly in the Cubase GUI whereas the audio file actually is updated “under the hood”?

Greets,
René

OK. Understood. Thanks

After updating I don’t hear any difference. In my last test, a couple of weeks ago, I changed the pitch in Wavelab to eliminate any doubt about the changes.

I just repeated the whole process with a short file recorded in Cubase. Click on Audio/Edit in WaveLab. WaveLab opens. Sift the pitch two semitones down. I can hear the change in WaveLab. Click on Trigger Cubase/Nuendo update. Nothing happens. Now the button doesn’t even grey out and the temp folder (WLEx_tmp) inside the Audio Cubase project folder has not been created.

The weirdest thing is that I managed to correctly perform the update three or four times a couple of weeks ago just like I wrote in a previous post.

Ok, it is really hard to track down where in the chain of actions the error takes place. No chance here to reproduce the problem unfortunately :neutral_face:

There is some logging mechanism in WL which I would like you to activate and track something for me.
Do as follows:

  1. Open WaveLab
  2. Goto [File -> Preferences -> Global]
  3. Hold [Alt] Key and press [Global] again (a [Diagnostics] tab shows up)
  4. Check [Allow Logging] and choose [Log.Exchange] within [Extra Log Codes] menu
  5. Run the application [C:\Program Files\Steinberg\WaveLab 9\Tools\Tracer.exe] and see the output
  6. Do your [Edit In WaveLab] procedure as you always do
  7. Copy & Paste the log here. It should only contain log messages of type [Log.Exchange]
  8. Afterwards DISABLE logging again!

I really hope I can see in the log what is going on.

Greets,
René

3C10: [ 0.278 / 15376 W default] - DumpSubscription “DisplayNotifier”
3C10: [ 0.278 / 15376 I default] - 5
3DB0: [ 16581.603 / 15792 I default] - Specific Logging Rules: “Log.Exchange”
3DB0: [ 16581.604 / 15792 I default] - *** Logging Rules ***
3DB0: [ 16581.604 / 15792 I default] - “Log.Exchange=true”
3DB0: [ 16581.604 / 15792 I default] - “.warning=true"
3DB0: [ 16581.604 / 15792 I default] - "
.critical=true”
3DB0: [ 16581.604 / 15792 I default] - “*.debug=false”
3DB0: [ 16581.623 / 15792 I Log.Exchange] - Sequencer Project for “Gt Solo Pruebas_19-01.wav (C:\Users\JuanJosé\AppData\Local\Temp\Steinberg\WLEx)” is “” Length: 0 Cursor 0
3DB0: [ 16659.722 / 15792 I Log.Exchange] - SequencerRemote::finishedFileEdit “C:\Users\JuanJosé\AppData\Local\Temp\Steinberg\WLEx”