Can't get 10 staves on one page.....?

In a part I have 11 staves, on one page. It’s a bit crammed, so I like to combine staves 1 and 2, where spacing is very wide. If I do that, with “make into system”, that stave looks nice, but Dorico decides I now need a second page to put the last stave on, even though I am reducing the number of staves (!). So I go from 11 to 9 staves, and a second page - that I dont want - for the 10th stave. If I try to go back to one page with “make into Frame”, it splits that first stave again (even if I do “lock stave” beforehand!). Is this a bug, or am I missing something?

(problem solved)

how did you solve your problem, Justus?

Something tells me you have been using “staves” and “systems” words as if they were equal… Dorico cannot decide to put staves belonging to the same system on two different pages, so I guess you reapplied Make into frame properly and it worked. In any case Dorico will do what it is told to, even if the music does not fit. It can be ugly and staves overlapping, but that’s the risk when you override the system.

k_b: I wish I knew! I clicked on “wait for next system break” on the first Frame-break, and this time it worked, even though I tried exactly that before and it didn’t work. So it’s one of those mysteries that won’t help anybody much… It remains strange that if I “make into system”, and then lock that, that I still need to set it to “wait for next system break”, I would have thought that should be automatic. It also remains strange that if I join two staves into one, thereby reducing the number of staves, that Dorico decides another page is needed. It obviously recomputes optimal stave-spacing and thereby ignores stave-spacing adjustments I had already made. Mind you, I think Sibelius has similar oddities in stave adjustments…

MarcLarcher: I’m not 100% sure I understand you. In any case, this specific situation was an oboe part, so a single instrument. In that situation system and stave should be the same (I reckon?).

Basically, Dorico doesn’t like it if you try to use “make into system” or “make into page” multiple times on overlapping material.

Try this thread as a primer: https://www.steinberg.net/forums/viewtopic.php?t=130088#p704965

Indeed. I’m discovering (slowly…) that I’m better off inserting frame and system breaks, and adjust the “wait for” parameters as needed.

Ok, Justus, forget my post. Yes, the “proper” workflow — until you really know what you are doing — is insert system breaks (shift-s) and frame breaks (shift-f) where you want them. Remove them if you want to change them to another location… You’ll notice Dorico is remarkably reliable for this (as it is for everything else) and won’t do anything you have not told it to do :wink:

What does “Wait for Next System Break” do?

In my experience, you don’t need to Lock every system, as you might be used to in other apps. You can get better global results by altering the Note Spacing values and other Layout Options to get a better overall fit, and then add system/frame breaks where needed, to avoid bad page turns, etc.

Depends what sort of music/layout you’re doing, of course.

It tells Dorico to not automatically break the system until the next (manually-inserted) system break appears.

This thread is the inspiration for the thread I just started here: https://www.steinberg.net/forums/viewtopic.php?f=246&t=142074

Ben, you might find that clicking through some of the links in my new thread helps to further explain.

Ah. That fixes a problem where I’ve deleted a system break and everything bundles up into one big spiky mess.
I think “Join to Next System Break” would be a better descriptor. “Wait for” doesn’t really make sense to me.

I’ve also been unaware of the other useful Properties of a System Break, which include displaying stave labels and adjusting the staff size “going forward” (for want of a better phrase).