can't open & edit effect from send anymore?

Am I missing something here…

Used to be when working on a channel send effect we could click the “e” button to quickly open the connected effect device for editing. Can’t seem to figure this out now. Do I REALLY need to scroll or jump to the effect channel to open the effect or am I missing something here?

Update: Okay, I have discovered if you right click the send, you can then scroll down and select “edit [effect name]”.

However, this is problematic if you’ve double-clicked the effect send and the number entry still exists; you’ll need to first hit enter to go back to the original send button state before you can right-click.

Seems to me the old mixer’s send set-up was far more efficient and easier to use, especially in the “heat of battle”. Clicking a button IS better than a conditional right-click and scroll, right? Honestly… WTF??

:confused:

opt/alt-double click now.

it only opens insert 1 of the send channel.

wish it could open all inserts, same behaviour when clicking ‘e’ button on channel strip [alt+cntrl] held down.

Thanks for this post, it made me go and check things out and I’ve been reminded of a couple of behaviours that I’m sure were in the tutorials but got lost in the avalanche of new features. They may help you out too.

Once the Channel Edit window is open you can, as before, select a new channel to edit without closing. What’s different now is that:

  1. There are back/forward buttons so you can flip between two channels you’re working on.

  2. Either side of the Channel Selector are input and output (Target) selectors so you can skip to connected channels.

  3. These targets and inputs are collected at the top of the Channel Select Menu.

I’m gonna find that very useful and anticipate that I’m going to be making even more use of Channel Edit than before, rather than scrolling around the mixer looking for buttons. Perhaps it’s the new way of working. I don’t know if it exactly addresses your issue but having (re-)discovered it thanks to your question I couldn’t resist sharing it. This version just keeps on rockin’!

@Crotchety

To be clear, I was talking about the behavior for the send button on mixer window, not the channel edit window.

JP

Okay. Thanks for the tip. Good to know.

So to summarize editing effects from a send button:

C6 = click edit button with mouse

C7 = hold option/alt with keyboard hand and double-click with mouse hand

@Steinberg

So instead of a simple mouse click, we now have a two-handed function with a double-click for this commonly accessed control. Supurb.

:unamused:

JP,
I’ve found this to be a problem as well. I preferred the simple point and double-click method in C6 to Edit my Send Effects. Now I have to hold down ALT and double-click. Oddly this is not the case for effects loaded in the Inserts. They are the simple point and double-click method.

And even stranger, on page 242 of the Operation Manual it states that to edit an effect, “Double-click the center part of an insert or a send slot to open the control panel for the loaded plug-in.”

Hope this gets changed back to the way it worked in C6 soon.
Thanks for listening,
Joey Daddario

Ha!
Raised this question a few days ago.
https://www.steinberg.net/forum/viewtopic.php?f=175&t=38674

That thread got a bit off-topic.
including the famous p.242. Cubase is cool just the new guy in the department has messed up the mixer. There has been speculation senior management was on holiday when this update was birthed. :smiley:
Thanks for raising the topic again. :slight_smile:

Hi Stephen,
Thanks for the reply. I read the thread you were talking about. Hilarious. None of us should ever be intimidated for asking a question. I read a cool quote recently: “Only a fool runs out of questions”.

I’m sure the Edit Sends issue will get sorted out.

Take care,
Joey

I also just wanted to echo my preference for having the “e” button (as an option at least). I’m using Cubase 8.

It seems like they really tried to shrink the size of the mixer, but I think they took it too far for my workflow. The default is so small that there are barely enough characters visible on a send effect for me to determine what that effect is (e.g. Is it a reverb? Is it a delay? Which reverb/delay?). Fortunately they put in a zoom setting for the mixer, so I can make the columns wider.

I’m glad this came up. I was going to post about it.

I echo this comment in particular:

…The default is so small that there are barely enough characters visible on a send effect for me to determine what that effect is…

As for this line below, I can honestly say for sure that I’ve tried every tiny single position anywhere even remotely close to the center looking for this ever illusive ‘center part of a send slot’.
…the Operation Manual it states that to edit an effect, “Double-click the center part of an insert or a send slot to open the control panel for the loaded plug-in.”…

Seems like such a miniscule thing to be fixed, and yet a completely huge annoyance for how many of us - tens of thousands?
I don’t know how many times I’ve clicked on a send only to alter the level.

And of course with no ‘Mixer Undo’ option, I then have to guess where I had it before - or close the un-saved program and re-open it.

And these are the guys that came up with the industry standard VST Technology concept?

Almost hard to believe - when so many of the little quirks, bugs and annoyances are so small - almost trivial.

Kind of embarrassing for them - and off-putting for many of us to say the least. :angry: