Can't register for roomworks se

Hi, the link to register for roomwork sse through cubasis android keeps leading to 404 page, anybody else see this? Thanks

I did successfully register. It worked when I opened the app. Then every time I open Cubasis after that time it keeps saying I need to register. SO it looks like the system is flaky at best.

Uhm i had the same problem in the beginning

I was able to get roomwork after i purchased a paid dlc (registration applied)

Thanks Eddie and CJ for your replies. I’ll either wait until somebody from Steinberg chimes in here, contact support or try CJs way of buying myself into favor. Guessing Steinberg would prefer/recommend Plan C;)


I’m having the exact same issue. No resolution yet.

1 Like


Cubasis 3.4.3 for Android is not registering RoomWorks SE.


  1. The app Cubasis 3.4.3 is opened on the Android tablet.
  2. The current song that is loaded displays the message stating that RoomWorks SE is not available.
  3. I then press the shop icon at the upper right hand corner of the program.
  4. A message is then displayed stating “You will be automatically redirected to the target page. If you aren’t forwarded to the new page click here.”

Expected Results:
I expect to be taken the Steinberg login site so that RoomWorks SE can registered.

Actual Results:
Nothing happens and the page displaying the message does not change.

Samsung Galaxy S7+, Android OS 12, Cubasis 3.4.3.

Dear @delgado, @Eddie_Stealth_Studio, @CJ_Monster, @Jon_Seale, @Saint_Bertrand,

Many of our users were confronted with the issue, that registering Cubasis to receive the free RoomWorks SE plug-in has failed.

After evaluated the topic, we’ve found out that an accidental change in the data format caused the problem, which already has been solved by our digital unit department.

We apologize for the inconvenience.


1 Like