Can't resize Mixing window in Dorico 4.3

Is there a way for me to do a clean install of Dorico Pro 4.3 without losing my license?

And by-the-way, I did not have this problem in Dorico 4.2. The problem started immediately after I installed Dorico 4.3.

I generated a diagnostic report as I’ve done in the past for other support issues. However, it doesn’t appear I can submit an email from your support site. How can I get the diagnostic report to you to get help with troubleshooting?

You can post diagnostic reports direct to this forum, or you can email Daniel directly (d dot spreadbury at steinberg dot de).

Do note that it’s now 3.30am in the UK where the bulk of the Dorico development team are, so you may need to be a little patient.

I went ahead and emailed, including the diagnostic report. I don’t know what else to do. Again, the mixing window worked in Dorico Pro 4.2, but is not displaying correctly on my Windows PC in Dorico Pro 4.3. So, even if my computer is partly to blame, there must be something about Dorico 4.3 that is contributing to the problem.

Could I trouble you to answer these questions:

Could you try Daniel’s steps for removing the dialogGeometry key, but then reboot your machine immediately afterwards (before running Dorico). Unfortunately the values in that key are cached (either by Qt or by Windows) so deleting them doesn’t take effect immediately.

Also, could you post a screenshot of your whole screen (not just the Mixer) when the caption bar on the Mixer is missing? If you resize the Mixer - by dragging one of the window edges - does the caption bar then reappear?

I think I have this issue also. When I open the mixer it fills the whole screen. No possibility to close it. I made a keystroke for that so that is no prblem. In Dorico 4.2 the mixer always opened a little to much downwards. I have Windows 11 all latest updates. I don’t see it as an problem now because I like the mixer as big as possible and it fills the screen nice and this is better then 4.2. But you can not close it with your mouse.

I have 1 screen. 2560 - 1600 but screenshot shows 1920-1200

I think to remember that the first time in 4.3 I opened the mixer, it was smaller and that I maximized it with this result.

4.3 is amazing. Thanks a lot.

See screenshot of the whole screen.

If you follow the steps I describe above, and additionally reboot your computer as recommended by Richard, does that sort things out?

Do you mean deleting all this?

Feels a little scary, I don’t consider it as an big problem.

If you want to delete the least amount possible you can just delete HKEY_CURRENT_USER\Software\Steinberg-Dorico4\dialogGeometry\qrc:\Dorico\Mixer I think.

This solved the problem one time. It is back after 2 times opening and closing the mixer.

I think it is an resolution issue. I have 2560-1600 the screenshot I made has an label 1920-1200 but if you check it in affinity it is 2560-1600 so problaby somewhere the system is communicating different things.

BTW, for me this issue is not a problem I only posted it beacuse you know there are more people having this issue.

What display scaling are you using (in System > Display in your Settings app)? 100%, or something bigger than that?

150% thats is recomended. Lenovo ThinkBook 16p G2 ACH 20YM0048MH

Thanks. There’s at least one problem here, which is that if you close the Mixer using the button in the caption bar (instead of with the F3 shortcut) then the next time you open it then it will be higher up the screen (by the height of the caption bar). That’s the main issue, I think, as that will end up with the top of the Mixer being offscreen.

I think that is the right diagnosis. Thanks.

This is what it looks like when I first open it. And yes, I did already delete the key in regedit and restarted and it didn’t fix anything, other than the bottom where the instrument names are, are now completely showing. The title bar is still missing.

And there is no border that I can latch on to, in order to resize the window.

Without the title bar (before playing around with the show/hide options for the task bar)

After playing around with the auto show/hide options for the task bar (this is what I was expecting.

It’s a little hard to see in the second screenshot, but the title bar is there, but not there in the first screen shot.

Once you’ve got the caption bar to display, can you then grab that and drag it down to resize the window? Then if you close it with the F3 shortcut the new size might “stick”.

Also could you let us know the answer to Daniel’s previous questions, i.e. how many displays do you have and what resolution/scaling are they using?

I have two displays and they’re both at the same frequency and resolution.

What is the resolution that they’re at?