Can't Save VST3 Plug-In Presets

I’m running on Mac OS 10.13.6 High Sierra.

When I click on the Presets button in order to save a VST 3 preset, and then select “Save Preset As”, nothing happens. I get no save dialog.

Screen Shot 2021-01-09 at 7.05.56 PM

With VST 2 plug-ins, a save dialog will appear. I’ve tried this with VST 2 and VST 3 plugins from a few plugin manufacturers, including Steinberg.

VST 2:
Screen Shot 2021-01-09 at 7.06.16 PM

VST 2 Save Dialog:

I understand that I can save presets in many plug-ins using that plug-in’s built-in preset manager. But it would be cool if the Wavelab VST Plug-In Preset Manager would also be an option.

bob weston

Anyone? Anyone? Bueller?

I’m having the exact same problem bud. Did you ever find a fix?

With what plugin? In general in works, but maybe some plugins don’t support something that is needed for this function.

Hi PG
I’m trying to save a dynamic EQ prest in MasterRig.
I keep getting this dialog;

"You are not allowed to save the preset to this location. Please choose the following folder or any subfolder.

‘/Users/user/Library/Audio/Presets/Steinberg Media Technologies/MasterRig’

I’ve tried doing this with no luck.

Probably this folder is locked for writing. Change the permission of this folder and parent folder.

Many thanks. This has solved a long lasting issue for me.
Best wishes,
Joe Carra

I had this issue for awhile with certain plugins and it wasn’t the final folder, it was a folder upstream that was locked. I think the issue came from manually copying my /Users/user/Library/Audio/Presets folder from my previous Mac.

Did you happen to do that too or was a totally natural install?

It was a totally natural install bud.
p.s. I loved your videos on using Wavelab. Killer.

Interesting. I guess who knows why some folders decide to go into a read only state. Glad you got it sorted!

Guys, is there a way to remove ISRC codes. They seem to be locked in this project and I can’t find away to simply delete them.

Hi!

Well in the Montage, CD wizard dialog just delete ISRC code
or in CD track window and save Montage.
Backup if needed or rename montage…

regards S-EH

Double click on the cell. Press Backspace. Press Return.

Hi PG.
I wish it was that easy. I’ve done that many times but a random code keeps appearing in the ISRC field. It’s stopping me from making a DDP image as the software keeps saying invalid ISRC code. It’s really got me puzzled.
Sorry for all these beginner questions but I’m migrating from Sonic after 25 years so I haven’t quite got my head around all the Wavelab details.

I know the issue and for some reason it’s really finicky. To clear an ISRC code in the CD Tab, I have to double click the code to highlight it, quickly press the DELETE key (the one two rows above the RETURN key), and then press the RETURN key.

This should clear it but again, it’s more picky than it should be. I think I’ve just gotten used to it.

Thanks for the tip JP. I will definitely try this once I’m back in the studio on Monday.
If I can ask one last question? Overall I’ve had a great transition going from soundblade to Wavelab. Never going back. One thing that scares me a little is the ‘crashing’ on start up. This has happened to me twice over the last few months where Wavelab simply crashed 50 times in a row upon trying to start up. This can be emabarrasing when clients are in the same room. Is there are list of remedies you can list to fix this issue? Trashing preferences seems to help, but I was wondering if there were other fixes for this. Is it possible that clocking can cause this crashing? If the system is clocked to 44k but I’m trying to open a 48k project, could this cause a crash upon booting up? Thanks for letting me chew your ear on these issues.

This definitely shouldn’t happen and doesn’t ever happen here. If it’s crashing that much, there should be a crash report that you can share here (probably in a new thread) for PG to analyze.

Crash reports can be found here:
/Users/username/Library/Logs/DiagnosticReports/

You should see some WaveLab ones in there after it crashes. If the crash report isn’t helpful, PG can tell you how to open the Diagnostics Tab in the Preferences to hone in on the issue.

Deleting the Preferences can usually help but is certainly not ideal, especially for somebody like myself who has tons of custom presets, settings, etc.

All I can think of is maybe you have a plugin in the global master section that remains when you quit WaveLab and causes a crash on startup. For more than a few reasons, I never use the global master section for anything.

I’ve not experienced WaveLab crashing if the montage or audio file that is open doesn’t match the clock sample rate so I’d lean towards it being something else like a plugin left in the master section if you’re using that.

No, because during startup, the audio device is not accessed. It is accessed the 1st time you trigger playback or record.

One thing you can try is to maintain Control key pressed (Command on Mac), while launching WaveLab, to prevent loading the last config.

Many thanks gentlemen. I generally have the Adptr ‘A/B’ plugin left on in the master section, so from now on I will colse this at the end of a session. You’ve both been super helpful.

Thanks for the ISRC tip JP. Worked like a charm. I don’t want to know how many hours that took you to work out!