Can't use MOTU Midi Express 128

No matter what, VST live doesn’t transmit anything at MIDI Express 128 port.
All Other Interface

ports are working but as soon as I try to make use of any Midi Express port, nothing is sent (no lights on MOTU outs)
The interface is working flawlessly with every other software on my system. Windows 11 - 23H2
VST Live

… can you please install the latest Pre-Release 2.0.23? It can be dowloaded here. Is it better with that one?


It doesn’t work with neither.

I configure the port in "Devices/Connections… ".
Then when I select it as Midi Out port in the Layer, it reverts to < nc >.


Yes. For example, I name the port “Kyma”, I assign the physical motu out port (no matter wich one) and when I choose “Kyma” as output as a midi out in a layer it turns immediately to < nc >

Very weird, never had that reported. Is that Windows, or Mac?

Latest win 11, quite a serious bug and I just bought VST live… :frowning:

Are there other users here with a Motu 128 that could check this?
And maybe try to remove all Motu ports, then select the hardware output directly from the Layer, just confirming the suggested name: will it still show ? And if so, did it yet create a port in “Devices/Connections”?

I tried it at first with no luck, the name is registered in “devices /connections” when I create it from Layer but still turn to nc. I also deleted all user datas and re install.

may be that I can help.
I have a MOTU midi Express XT.
It works with VST Live 2.


I’m very puzzeld by that one. Motu proved to be the most stable interface I had in years and never glitched in the most multi client intensive usage on windows 10-11. It’s still rock solid with every other piece of software, Steinberg Cubase and Dorico included. In fact, I jumped into the VST Live band wagon because I was confident that such bugs would not show. I hope Steinberg can find out what the issue is because now I’m stucked with a useless piece of software.

Thanks. That’s on Windows too, right?

Confirmed. But did you upgrade to latest drivers though.

Yes I am on win 10
The last conversation with you was

Ah, sorry, hard to keep up.
This is a different issue, you can assign and use your Motu ports (that is good to know), but kx3 can not. Thanks for clarifying!

Only just seeing this…what is “MME Midi: VST Live”? There is no such hardware, so we need to suspect that you use some sort of virtual MIDI device/driver. That is most probably the culprit, whatever it does. Can you clarify?

VST Live is indeed a virtual port that just works fine. I use many Virtual Ports that work flawlessly: Cubase, Dorico, Pianoteq, MobileSheets, StreamDeck’s, Cantabile, Haken are all perfectly working virtual ports in all applications, including VST Live.

Surely, I use the latest available MOTU driver wich is 89606 on win 11

I suspected a too high midi port counts (welcome windows 98!!) but ports "after "MOTU are working. As well as when they get the same enumerator rank when MOTU is unplugged.

Doesn’t look good: I installed VST Live2 on another computer, I moved the Midi Express 128 on that computer and the same problem still there.
Again, the only software that can’t use the Motu interface is VST live. No other interface installed (nor virtual ports) and it’s on a Windows 10 machine. The only common point to this bug point to VST Live…

It might indeed be too high a port count. VST Live opens all MIDI ports initially, Cubase only those which are enabled in its settings.
We changed it such that only ports used in „Connections“ are opened. Please try again with the next version and let us know how it works out for you.

I tried on another computer with Win10 and only the MOTU; it doesn’t work either.

… we’ll release a new version tomorrow (Friday). Please re-try with it and let us know your results.


1 Like