Caps lock in Spanish keyboard switches Tenuto articulation

I have an issue where whenever I hit Caps Lock while having Dorico configured as Spanish keyboard input, it toggles the tenuto marking. This is unfortunate, because I tend to mistype that key a lot, which in normal circumstances doesn’t have any other effect that making me write as if I where shouting.
Is this a known issue?

I haven’t read about it… Have you searched the keyboard shortcuts for tenuto articulation? It should be as easy as to select that shortcut and delete it (with the trashbin icon)
Hope it helps!

Hello Marc. I did. Mine is the default ‘$’, which would be Shift+4. I also had F18, but I delete it and still pressing Caps Lock triggers the toggle (only when switching it on, BTW).

This is curious… I’m afraid I have no clue. Have you tried with another similar keyboard?

Caps Lock doesn’t normally register as a standard key. If you go to the Key Commands page of Preferences and try assigning the Caps Lock key to a shortcut for something benign like the About Dorico dialog, what key does it show in the editor there?

It does register as this:

Only if I play it twice again can I log the shortcut:

But anyway pressing Caps Lock again just activates tenuto, it doesn’t bring on the About window.
I’ve tried with both an external and the built-in keyboards. Both exhibit the same behavior.
I’m on the latest version of macOS Ventura and Dorico.

Very odd. I don’t have a good explanation for this, I’m afraid. What shortcut shows when you select Note Input > Set Articulation > Tenuto?

The $ sign, which in Spanish corresponds to Shift+4. That shortcut works right.

BTW, removing the $ shortcut from the “set tenuto” makes the issue disappear. Assigning $ to any other thing makes Caps Lock do that thing.

I’m not sure this is related but I get a text item (staff attached) when pressing Caps lock on a Norwegian keyboard.

I’m also able to register caps lock as a key command. I tried registering it to “About Dorico” and it worked once then went back to creating text :thinking:

So what we’re saying, then, is that Dorico is interpreting Caps Lock as Shift+4 in the Spanish keyboard layout.