CD-Text Character Issue

Here’s a minor but annoying quirk I’ve noticed over the years that I’m hoping can be solved.

I always copy and paste album and song titles from my email form or an email from a client. I almost never manually type the titles.

Sometimes, an apostrophe in a title will trigger a question mark in the CD-Text field and resulting DDP in HOFA DDP Player Maker, but not too frequently. When this occurs, I have to delete the apostrophe in the CD-Text and then manually type the apostrophe and then all is OK down the line.

Is there a reason this happens? Could the incoming apostrophe somehow be of a different style that triggers this error but is solved when I manually type it?

I keep “Restrict To ASCII” turned on.

There are 2 types of apostrophes, one being asymetric `, not ascii, the other ’ being ascii.
I guess this is the problem.

The “wrong” apostrophe often arises when text is copied from a word processor rather than from a basic text editor.


Thanks. I had a feeling this was due to two different apostrophe styles and it does seem that it happens more when I copy from a Word document vs my web/email form.

However, when the problem occurs the apostrophe doesn’t look quite as crooked as the one PG showed here.

Next time this happens I’ll post about it here.

PG, both of those characters in your post paste into Wavelab CD Text set “restricted to AsCII” without problem. Maybe Justin is running across even another type of apostrophe?

Yes, when I do encounter the problem, the apostrophe doesn’t look like it would be a problem until I find out either in the CD-Text editor or sometimes not until I make a DDP and check it.

The problem apostrophe looks very much the same as a legal one which makes it hard to troubleshoot.

If the original character was ascii, wouldn’t it stay ascii even through multiple copy/pastes in different programs? Or do different programs actually change it into another character without your knowledge? Does “removing formatting” or “adding formatting” (or whatever the programs do) actually change it from an ascii character to a non-ascii character?

Word processors typically have a “smart quotes” feature which may well change both single and double quotes into symmetrical pairs under some circumstances. But what I meant was copying text originated in a word processor, in which case smart quotes would be expected even if only ascii characters were typed.

But the characters used for smart quotes ( ‘ ’ “ ” ) are only available in full Unicode. I suspect that some older programs imitate them using the ascii ’ and the ` character which is not in the base ascii set but in the upper half of the character table, which varies between languages and so is not actual ascii (like the basic accents). Some people might even type it in ignorance, as it’s right there on a PC keyboard (well my UK one anyway) just left of the 1 key in the top row.


Thank you Paul, that’s brilliant. I was just finding all sorts of information about how to type a “proper” apostrophe, and smart quotes in word processors would certainly explain why it’s so common to find non-ascii apostrophes in use. I just use the old improper ‘dumb’ ascii apostrophe and Notepad, and couldn’t get it to turn into a non-ascii apostrophe no matter what I put it through.

Also the keyboard key just to the left of the 1 on a US keyboard is the same as on UK I guess (has the reverse or backquote character). Using that key in notepad, it’s also ascii like the apostrophe key.

I guess people have written scripts to convert non-ascii characters to logical ascii equivalents but I haven’t seen anything like that in use.

Wouldn’t you think word processors would have a way to go the other way if they’re smart enough to make Smart Quotes in the first place? I haven’t found any that do, besides do-it-yourself Find and Replace with Smart Quotes turned off. Unless I’m missing something. You certainly know a lot more about this than I do.

FWIW … I have found that when this does happen, it mostly seems to be where the email/word document was generated by the Microsoft Office for Mac suite.

Makes sense, if all the word processors default to making Smart Quotes (curly) (non-ascii). I just tried it with Libre Office on Windows, and it defaults to the same, and of course the quotes are turned into question marks when you paste them into Wavelab CD Text with “restrict to ascii” enabled.