Changing Dorico's Default Music Font


I’ve tried browsing in preferences for this, but couldn’t find it. Is there a way to change Dorico’s default Music Font? Bravura looks great, but I’d like to replace it as default with Robert Piéchaud’s November2 (which is also a SMuFL font.) I do know how to change the Music Font in Engrave Mode, what I’d like is to make Piéchaud’s November2 the default Music Font.

Any hints or insights on this issue would be much appreciated.

All the best,

You can’t at present change the default music font. The best you can do for now is create a template project file and start your new projects from that.

1 Like

Ok, thank you for the tip. I will try that.

For what it’s worth, you can probably glitch your way into changing your default music font. I’ve done it somewhere along the line and it stuck throughout updates (although I can’t recall whether it predates v2). This sounds silly, but I think I changed the music font (in, err, Music Fonts), then changed the Default text font in Paragraph Styles, and hit Save as Default for this configuration. The music font might be dragged for the ride, but, as I said, I did this in an earlier version of Dorico, and it might’ve been dependent on a specific interaction.

The following .doricolib file will set the default font for new documents.

  1. Quit Dorico.
  2. Download the attached .doricolib file and unzip it.
  3. Save this to the “DefaultLibraryAdditions” folder. (This folder may need creating if not present.)

On Mac, this is in your root level Library: /Library/Application Support/Steinberg/Dorico 2/DefaultLibraryAdditions/
On Windows: %PROGRAMDATA%\Steinberg\Dorico 2\DefaultLibraryAdditions

Needless to say, if you experience any odd behaviour, removing this file and restarting should be the first thing you test. (1.43 KB)

1 Like

Thank you so much, Ben. It works perfectly.

Ben, is there a way to modify your .doricolib file to include the font Gootville? I tried doing it myself, changing all values of November 2 to Gootville. Dorico is selecting Gootville as the music font in blue correctly, but it isn’t actually applying it to the score. Any help would be greatly appreciated!

Have you installed a .json metadata file for Gootville? If Dorico isn’t actually using Gootville, then something’s not right somewhere, but probably not with the lib file.

I’m just wondering… I installed the MTF fonts bundle sold by Notation Central, and now, each time I create a new document, the music font is MTF Arnold… I would have expected to stick to Bravura — Arnold is not complete, there are glyphs missing, such as octava G clef… And no, I did not tweak my doricolib file !

I wouldn’t expect that to happen. You might have to test removing your user settings files, and then put them back if nothing changes.

This happens when you change the font style ‘Default Music Font’ rather than the actual Music Font. Make sure you’re in Engrave Mode>Engrave>Music Fonts and selecting the MTF Font from there.

Hi Evan. I never changed the fonts in any other place than Engrave menu >Music fonts
I’ll check whether I find that default music font you’re talking about — I actually looked for it and could not find it.

Thank you Evan. This must be something quite recent (given Daniel’s post #2 of the thread). Font styles do have a Default music font entry, and as you said, it was set on MTF Arnold. Well, this is a report then : I did not change it, and it was set to Arnold. So I might not be the only one wondering what’s happening when squares appear where there should be a g clef (with 8va marking) :wink:

1 Like

Glad that fixed it! I just have to keep in mind that when I change the Music Font, it also changes the Default Music Font (text style) too.

Just to say: For me changing the music font never changed the default music font, although last time I did it was probably still in 3.1

Dear klafkid.
I believe that it is a new behavior, but I am waiting for Daniel to confirm this. (I own November 2 for a long time now, and it’s the first time I notice this non-bravura start when creating a new document.
Btw, I studied Tonmeister in Paris’ conservatoire before becoming tenor opera singer, some of my masters had studied in Detmold :wink:

Wow awesome! I heard a lot of great things about the studies in Paris (very musically intense!), and also met some students some years ago. I wish, I would’ve visited the conservatory in my studies…
Tonmeister is really such a broad field that can develop in so many directions - amazing to actually meet in a notation forum! :smiley:

I can also confirm, that in 3.5 when creating a new score, it chose MTF-Cadence as standard. I never changed default as well, but I used Cadence in a project prior to installing 3.5

Very sorry to bump this thread, but I’m experiencing this exact issue under Pro 3.5 with Sebastian: I used it in one project and now it’s the default for all projects, and I can’t reset the default to Bravura. Is there a way to reset the default music font in 3.5?

Me too, exactly the same.