Changing Sample and bit Rate on existing project

I have a number of projects that were created based upon template default at 44.1/16 which contain both audio files and midi information.

I want to convert them to 48/24 or even 48/32. I say yes when it asks if I want to convert the existing files to the new sample rate. The problem is that it seems like if I choose to keep them at sample position or not, everything ends up out of sync.

Can some one describe the correct process for up converting sample and bit on an existing project containing audio and midi so that everything plays back relative to how it did before?

I’ve searched the forum so forgive me if I’m asking something that has been covered. I couldnt find the answer.

Nobody? Anybody?

Personally I’d say there isn’t much point but if you keep at sample position then it should sync.

Make sure you have no frozen tracks/instruments and if you still can’t get it to work maybe consolidate all your audio & midi events from start to finish of the song first by glueing or bouncing. You can easily split them afterwards.

That´s just when it does not sync (at least if you have several single parts / events on a track.)

You will just be adding empty bits, unless you rerecord or render instruments again

If you convert the sample rate it will not after the conversion sync with your midi track(s)

The only solution is to bounce your midi tracks to audio before you convert them all to a higher rate.

Hope this will help !

This is exactly the problem, thanks for confirming what I am seeing. I kept thinking I was doing the conversion wrong.

Sounds like this is a bug as the midi should be adjusted relative to the audio, no?

Do I just post this in the bug reporting forum?

Aside from the midi sync problem when converting which was confirmed above this, the problem with this solution is that I need to reset my i/o sample rate each time I work on one of the old projects so would just like to convert them all and be over with 44.1 and not think about it when jumping between projects.

Thanks for the responses guys. I was pulling my hair out for a couple months on this.

So I reported it as a bug but got response from Steinberg that it wasn’t and they moved it back to the general discussion??? Any way I’ve pleaded my case in the response in that thread so folks here let me know if I am not being being logical, especially for the product considered to be the best midi with audiio composition tool on the market

http://www.steinberg.net/forums/viewtopic.php?f=181&t=64484

Hi,

I sort of have the same issue,
I’ve started a new project and made VSTi drums track
and then I remembered to change the project’s sample rate to 96k…
Everything now is Slowww…
Any quick way to fix that??
It’s not a recording, there must be a way…

Thanks,
Guy D.

This is an old post now so you probably have work arounds in place;

However I just implemented a good work around for this as I didn’t want to bounce to audio as I was still in production phase of editing midi.

I had to revert to a saved project from which I hadn’t already adjusted sample rate, and I just started a new project at correct sample rate (which was the activated one), and dragged and dropped the midi from old to new and it all lined up perfectly at new sample rate.

Then obviously you have the option of adjusting the audio to new sample rate when dragging and dropping also.

Cheers. Felt obliged to post a work around as I have gained so much useful help and insight from these forums.

Thank you , this post helped!