Color multiple tracks at once

I’m with stupid, but I can’t figure out how to color multiple tracks at once.
I selected a few tracks (no events, just the track lanes), clicked the bucket button at the top and selected a color but nothing happens…
what am I doing wrong?

1 Like

It works here on a Mac. Does it say “Colorize Selected Tracks or Events” for the tool tip? That should work. You can also assign a Key Command to do it.

It just says colorize selected events - not tracks.

I think there is a bug in Cubase to do with colorize, if the selected multiple tracks are the same colour, then multiple colorize works all OK, but if the track colours are different then multiple colorize does not work. In which case only one track changes colour.

Strange - double and triple check that you really don’t have any events selected before you select a Track header. I say this, because it all works fine here (even selecting different tracks of different colours).

Not that it should make any difference, but I am using the ALT+SHIFT+C command to open the pop-up colour window, and choosing from there.

[EDIT - just tried the paint-pot button on the toolbar and that works too…]

It’s a buggy thing and sometimes it works, other times not.

This mostly works for me, but not always.

First, make sure nothing is selected. Ctrl+Shft+A
Next, select the tracks you want to have all be the same color. This is done On the Project Window, not the Mixer.
Pick the Color, and, if Cubase is in a “good mood” all the selected tracks will take the color selected.
If it doesn’t work the first time, try selecting the tracks and set them first to Default Color, and then, try to set to the color from the color picker. On alternate Tuesdays, or even more often, that seems to work.

The best way I’ve found to color tracks is with the Project Logical Editor. To do that best, defined the colors you want to use first, you may name the colors for the Parts. Then, select the tracks to be assigned a color and use the PLE to set them to the named color. Good luck.

1 Like

That helped. Thanks a lot @stephen57

yeah, this works well but I wish there were option for parameter 2: “+1”, so colors could change.
Put images for convenience.

An quick and easy way to colorize all tracks at once is to use the Logical Editor with a Macro.

  1. Name all your tracks. Bass, Guitars, Drums, Vocals, Strings etc.
  2. In the Project Logical Editor create a preset for every track “name” and select a color for it. (See picture from Soundpeaks)
  3. Go to Edit-Key Commands and create a new macro as in the picture below.
  4. In your project select the tracks to colorize and go to Edit-Macros and execute the Macro you created.

I hope this helps.

1 Like

I forgot to include the image with the settings for the Logical editor.

Amazing. I have just reclaimed WEEKS of my life lol. Thank you!!!

My guess is you simply forgot to press the modifier key CTRL while choosing a colour from the palette icon in the top menu.

Make sure you have “Color Menu” enabled in the top menu bar (if not, right click and tick Color Menu).

Here’s what I do to quickly change colour of a bunch of tracks:
Select the tracks you want to colour, press and hold CTRL while selecting a colour of your choice from the palette icon (if enabled), otherwise via Project/Colorize selected tracks. Boom, all the same colour.

As akways, there are multiple ways of achieving the same thing in Cubase - and give you lots of activity to to but writing music. :smiley:

1 Like

You don’t need press anything, just make sure you didn’t select any events in the arrangement.

Wow! That did the trick! Thanks, man.
This was bugging me since I started using Cubase half a year ago.

ALT+SHIFT+C did the trick here- thanks! (that was not at all obvious in the UI…)