Convert to Musical Mode Changes Audio Length

in 10.0.30, when converting audio to musical mode, the audio resizes - out of sync with the rest of the project. I noticed that I have both 96K 24bit and 96K 32bit audio in this project, with the overall project settings now set at 32bit. It looks like the 24bit tracks resize when converting to musical mode, and the 32bit audio does not. Please advise. thx

Hi,

This is what Musical Mode should do. It stretches the audio and tries to match it to the tempo.

It might happen the source audio signal tempo is not detected correctly. Then the match to the tempo (Musical Mode) doesn’t work as expected and you have to do this manually.

There is another thread here about how recorded audio is sometimes marked with an incorrect tempo in the pool when it was created - i.e. it is recorded at 120 bpm but the Pool shows it as 117.8 or whatever. So it is a good idea to verify and if necessary correct the tempo in the Pool before anything else.

https://www.steinberg.net/forums/viewtopic.php?f=283&t=163494

This song uses a Tempo map fyi. Some audio tracks when converted stay in their position and length, others don’t, resize in length. I’ve been using musical mode for a long time, never noticed this problem before.

I’ve attached a screen capture, that shows better what i’m talking about. The top two tracks are before. Then you can see the two tracks after changing to musical mode. One track in original position, the other jumped to the right. Finally the two tracks info from the Pool.

Are the Tracks all set to Musical Timebase?

Hi,

If the start time changes, then it’s about the time-base of the track.

Thanks for the replies. I ensured musical was toggled in each tracks timebase. Also copied track settings from the top track that stays in position, to the other track that jumps when converted. Problem remains. I duplicated this with linear time base enabled for both tracks as well. Weird. This project has a tempo map btw. But if both tracks are identical, why would one act differently?

Hi,

Could you make a video-screen shot, please?

https://www.dropbox.com/s/3efwmvkcc9htk8g/musicalmode.mp4?dl=0

Both tracks are identical as to settings, type of file etc. One stays in place (as it should), the other jumps and resizes a bit.

Hi,

As I can see these are two instances of the same Audio file, right?

Could you share an example project, please? Just the one Audio track and the Audio file. I would like to try it here on my side, please.

They are two different files and names. No, can’t share project at the moment. Screen capture at top of thread shows the two files and specs - identical, as are track settings. This isn’t just with those two tracks - it’s like this throughout this project. Some stay in their place, some resize.

Looks like this issue has been around for a long while. See https://www.steinberg.net/forums/viewtopic.php?t=5259

The ‘bounce selection’ solution here works. I suspect that this has something to do that the earlier tracks were brought in to this project as 96/24 mono tracks. And the project and subsequent audio trax are 96/32. Also some of these trax have edits and are chopped up - may be related. The bounced selection is one solid track merging the edits. dunno, but thanks for the input.

Hi,

Therefore it would be nice, if you could share a project (with this only one track) to see, how exactly does it look like. What is applied on the track/events, how are the events structured (multiple layers), etc. Then I could slim it down, find the core, the real bug and report it to Steinberg.