Converting .arr files in sx 3.1 doesn't work

Hi all,
I did post this in “older Cubase versions” but no one seems to be there so - apologies for posting in this forum:

A client sent me some old .arr files and wants them converted. Only midi. She doesn’t have the .all files.
They seem to import fine in Cubase SX 3.1, but no tracks appear.
They are around 4-9 KB. I checked in a hex editor, and they are not empty.
Any suggestions ?

I dug out some old .arr files as a test and I was able to import them with the downloadable SX3 – it prompts for a project folder, multiple tracks appeared as expected, which I could then save as a new project (.cpr) which then opened fine in Cubase 10.5.

Is it possible to install sx3.1 on win 10? Ive still got a few .all files I missed when I originally converted them all. Cheers

Yes, I have SX 3.1 installed on both my Windows 10 systems.

Just checked on some old .arr files of mine and it works just fine as it did for Mr.Soundman. Maybe something up with the files? Happy to look at one if you want.

@Mads, if you think it would be OK with your client, perhaps you could upload one of the files here to see if one of us can convert it.

Thank’s guys :slight_smile:
Here’s one. As I said, it apparently loads fine but is empty.
Mads (3.75 KB)

No joy I’m afraid! Same here, it loads OK but the resultant project is empty.

ok - Thank’s for testing :+1:

Excellent. Thanks :smiley:

I’ve also gotten SX3 to work on Windows 10 by simply copying over the folder from an old XP installation (i.e., don’t run the installer). It doesn’t matter if not everything works, you only need it to load the .all files and save them as .cpr. Your current eLicenser will allow all older versions to run.

If you do run the SX3 installer, make sure to download and run the latest version of the eLicenser immediately afterwards, as the old version that comes with SX3 will not allow newer stuff to work.

Thanks for the tip about the licencer. Shame I don’t have an old installation otherwise I would do that

You can still download SX3.1 from here:

Thanks I know about that. I meant an old version already installed that I could just copy across :smiley:

Ha, right…bizarrely that didn’t work for me. I originally had a version installed on my Win '98 partition and others had said to just copy it across but it never worked. Doh!

Now this is really strange: :open_mouth:
I found some old .arr files that I know works, because I have converted them before.
But I get the same result now with these - empty window :frowning:
I’m on Win 10 pro version 1903 - could it have something to do with that ?

That is weird, I shall look up some old ones of mine to make sure they still work…

I don’t think so, but perhaps the source is the key? Do you know:

  1. The file attached earlier from your client, what OS and Cubase version created them? (Atari/Mac/OSX/Windows etc.)
  2. Your own .arr files that now won’t open, what OS and Cubase version created them?

I don’t know about my clients files - mine were made between 1987-1992. Atari and Cubase.

Mine were also from that era, and converted OK … what I’m wondering is, if your client’s files would load using an actual Atari, but the problem is that there is no legally downloadable Cubase for Atari (there’s a Cubase Lite, but that can’t load .arr files).