CPU overload error in Cubase 9 mixdown

So I go to export to audio track in mixdown using real time and it crashes on CPU overload. I have 32Gb of RAM and 1TB SSD drive with intel i3 CPU.

Why? How do we avoid this other than export in non real time?

I’ve been experiencing the same thing?? Amazingly there is no consistency with the problem. Sometimes it will be a CPU error other times a hard drive error. Some songs export in real time with no issues, some songs it works after several attempts and some songs will never export real time.

I have tried to google this with no joy. I have found discussions about the errors but never a solution or even a suggestion. Seems the discussion always goes sideways with folks wanting to argue about the need to export in real time. Hopefully someone here has some helpful insight.

I think that this is an old unfixed Cubase bug as I did a google search and it has been around since version 5! See here:

https://www.steinberg.net/forums/viewtopic.php?p=45477

Maybe someone from Steinberg development can chime in here? It happens once a while on larger audio files that I export in mixdown.
I am surprised that Steinberg has not created a patch to fix this in version 9 for software that we paid $600+ for a DAW? Never have this issue with other softwares like Ableton, Reaper or Bitwig!

Doing realtime mixdowns using an i3 is pushing it, try non-realtime if possible.

Even with 32Gb of RAM? Wow! I run high end AAA video games without issues except a few. Time to budget for a third PC well that can run Pro Tools and other softwares. Does Steinberg let you run Cubase license on multiple computers in a network as long as one has the dongle?

Ram just lets you using more VSTi’s/plugins, but if the CPU can’t push all the data then it’s useless.
You can install Cubase on any number of computers, it will only run on the computer that has the dongle plugged in.
If you want to run Cubase on another computer at the same time, you will need to buy another license + dongle.

just remove 1 plugin or dissable 1 channel for testing purposes and see if it completes.

Good to know, thanks!

Try rendering in place some of the more CPU intensive plugins (then turn them off) and try again. You could also try freezing those tracks. You might find that having lowered your CPU overhead t,he mixdown might work.

There is no reason to use RIP for that. VSTi can be freezed and unloaded with two mouse clicks at any time.

True, but sometimes I find it useful to have the vsti available without unfreezing.

Just out of curiousity, if you have no external gear or instruments, why would you like to mixdown realtime?

It gives a chance for ‘different’ set of ears to listen to ‘finished’ project.

Last time I remember this never happening was back in XP days, when I could mixdown, in realtime a 24Bit/96khz project everytime: now I rarely can, even at 44khz. I have never really understood why, as I mix and edit and compose, add tracks and play project from start to end, many times, then a Realtime Mixdown gives me a CPU Overload message, generally two thirds through: very annoying, but an option one has to try to forget exists, I suppose.

If you haven’t tried this already, always make sure your buffer size is as high as possible when mixing and mastering and go to Devices/Device Setup/ VST Audio System and click on Reset and then OK before doing an audio mixdown.

Doing the above usually resolves the CPU Overload issue for me!

I in fact make a habit of clicking on Reset quite a few times during a days session as it definitely improves stability.

Also, if you get the overload warning shut down your computer which rebalances memory consumption which seems to help the issue too!

Hope this all helps?

Kind regards

James Colah
http://www.jamescolahproductions.com
http://www.facebook.com/jamescolahproductionsgb
http://www.twitter.com/jamescolah

Thanks for this tip: I shall try it :slight_smile:

Higher buffer settings also improve offline mixdowns.
Try offline (non-realtime) mixdown, and listen to the resulting file afterwards.
Listening to the realtime mixdown while it happens is not going to tell you if anything went wrong writing the file.

Offline mixdown is just applying the math set out on the timeline crunching the numbers ASAP, buffers have nothing to do with it. Realtime only is needed when you have realtime signal that can not be rendered quicker.
Buffers can affect realtime performance

Just increase your buffer size!

The CPU overload error is very misleading. For me at least it simply means that I got an ASIO overload during mixdown.

Maybe you never noticed but you are probably getting ASIO peaks with cracks and pops at playback already.

So if you get them at mixdown, Cubase crashes with a misleading error about CPU overload while it is in fact an ASIO overload.

So simply increase your ASIO buffer size and all problems will be fixed, for both playback and mixdown.

In Preferences --> VST --> “Warn on Processing Overloads”

Turn it off, uncheck box. :slight_smile:

When is realtime Export Audio Mixdown actually needed? I’ve used it a few times but don’t seem to hear any improvement in the final export.