CPU spikes in 10.5.30

I had to stop using Cubase because of CPU spikes and resulting artifacts (pops) in the sound, that I don’t get in other DAW’s.

I was able to replicate the same configuration (same VST’s, EQ, limiters and MIDI routing) in Studio One without any problems and a lighter CPU load.

Here’s the evidence (you can hear the sound pop in Cubase):

The only plugin producing sound is the ARIA player (last update: 1.959) which is gentle on the CPU but there are a few more in different tracks, and particularly Analog Lab V (VST version) seems to be CPU hungry even if it doesn’t receive MIDI notes.

If Cubase had a per plugin performance meter we could examine if there is another plugin causing problems but it would be strange because this doesn’t seem to be the case with Studio One.

Those are my Audio settings in both DAW’s for more details:


Activate ASIO guard. Start with Normal, but try High if needed.
Set Audio Priority to Normal not Boost (Boost gives Audio priority over MIDI so since you’re working with MIDI that can cause problems)

Thank you for the advice but that didn’t help. The CPU peaks (resulting in sound pops) still occur even after switching the priority to normal and activating normal ASIO guard. I can’t activate high ASIO guard because it would introduce 100ms of latency which is too much.
I have also noticed that I get peaks with buffer sizes of 128 and 256 samples in Cubase, while Studio One is able to produce sound without pops with both buffer sizes.