CPU Usage

Hello all,

I wanted to double check and see if this CPU usage is normal. Seems a bit crazy to me but I’m also not a computer wiz. All I have loaded on my project is a single piano with a few added staves. When inputting notes or standing by, the CPU usage seems really low but as soon as I press play it seems to jump way up above 100%. I’ll add a couple of pictures, including my computer info, which I admit is on the older side. I also have an 1TB SSD on board.Just want to make sure so if I need to reinstall or tweak some settings I can get to it. Otherwise just pray my computer will survive this project!

Screen Shot 2019-11-15 at 12.32.02 PM.png

Definitely not normal. Almost certainly the answer lies in some incorrect audio settings. Can you give us more info about that?

Sure thing! What information should I gather? Again, not super tech savvy here…

Check Preferences, scroll to the bottom. Click on audio device. What are your settings?

Here is what is under my audio device set up. I do not have “suspend audio device in background” checked.
Screen Shot 2019-11-15 at 2.44.02 PM.png

And you do get audio, and it sounds normal?

Yes audio is fine. My laptop does seem to be working hard though, it gets a bit loud.

Sorry, not sure. I’m sure one of the team members will chime in soon. Have you searched the forum for this issue?

Thanks man. I am searching around to see if I find something right now.

Is this just an Apple issue? My laptop doesn’t seem too excited about Dorico, although my scores are not yuuuuge. Just numerous little things.

That buffer size might be a bit low. Try setting it to something higher, like 1024. That will certainly improve playback performance.

I’m not sure it’s an Apple only thing. I hope not. I increased the buffer size same problem :frowning:

It seems like it is Dorico acting up as I tried a Kontakt instrument in Dorico and the CPU spiked. However when I open up Kontakt on it’s own the CPU was much much lower.

Here is a list of things I’ve tried and CPU still spikes
-Turned off HSO and pressed play
-Dinked around on my midi keyboard (both with HSO on and off)
-Set instrument library to nothing
-Increased buffer
-Selected and deselected midi devices under preferences
-Increased bit rate to 48000

I can continue to experiment, but if anyone is smarter I am willing to learn.

I did just run into a few posts suggesting I create a spindump and a Diagnostics report. Who do I send that to?

You can attach it here, just zip it first.

Here they are
Spindump.zip (222 KB)
Dorico Diagnostics.zip (496 KB)

I have the same problem but in Dorico 2 the problem did not exist. The same flow jazz quintet only halion uses 15% of CPU usage in Dorico 2 in Dorico 3.0.1 about 50% or more it looks not stable. When I use 4 VST instruments and a tentet it is 100%. I don’t use condensing and nothing really dificult. Very simple arrangements of 1 flow and 32 or 64 bars. It only is with playback.

I have Windows 10 i7 dual core 8gb ram.

Again in Dorico 2 the problem was not there. I remember the problem is mentioned earlier and the suggestion was that the videoengine was doing something it should not. I hoped it had to be solved with the update to 3.0.1 but it is still there.I hope there will be a solution.


Interesting. I just ran the same project on Dorico 2 and then on Dorico 3 and yes the CPU usage is quite drastic. It also seems like Dorico 3 spikes CPU usage even just while booting up, drops back down only to spike again during playback. I might just continue my project on Dorico 2 while this gets resolved… I can even load up larger libraries and not get the same CPU usage as the default piano sound on Dorico 3.

The most likely culprit is the video engine, which uses more CPU power in Dorico 3 than it did in Dorico 2. Please see this earlier thread.

Confirmed Daniel. I removed the video engine file as Ulf suggested on the other thread (saved it in folder on my desktop for now) and Dorico is running the same project at 15-30% CPU depending on the amount of voices going on at any given time. More importantly my fan and/or hard drive aren’t even running at full speed. My computer is deadly silent. Thanks! Looking forward to the next update!