[crash] Key Commands, please have a look

Cubase 6 64Bit, Windows 7 x64

Would you please have a look:

  1. download the attached “TabSel Default.zip”, unzip it and put the “TabSel Default.xml” into your Key Commands Preset folder: C:\Users(your user)\AppData\Roaming\Steinberg\Cubase 6_64\Presets\Key Commands"

  2. Start Cubase 6, create new “Empty” Project

  3. Go to menu “File” -> Key Commands, and choose Preset “TabSel Default”

  4. click “OK” to leave the Key Commands window.

  5. Go to menu “edit”

result: The Preset Browser window opens. You can’t access the menu “edit”!!!

  1. now click “cancel” in the Preset Browser window to leave the window

  2. Go to menu “File” -> Key Commands again

  3. click “Show Macros” at the bottom of the Key Commands dialog

  4. try to delete the macro “Esc”

result: Cubase 6 crashes!

Please can anyone confirm?

\


TabSel Default.zip (14.4 KB)

Bump

Interesting, I will check it out soon…

Thanks.

Hi there,

I can confirm it with your attached preset file. Very odd. I have filed a report for it. (28128)

From which Cubase version is this file coming from?

Cubase 6

I created the macros after a fresh install of C6 with no other cubase version in this machine.

I had other issues, too: http://www.steinberg.net/forum/viewtopic.php?f=19&t=3147

Thanks for confirming.

Any news on that?

Bump

is “ready for testing” at the moment. But please understand that we will not report the status of every bug here in the forum. For a status update you can look in the bugbase. And YES, this one is currently not in the bugbase. Will be added later

Cheers,

Chris

Still the same with Projects created with 6.0.0 in pre-Release 6.0.1 …

Clicking main menu item “edit” opens the vst preset window, deleting macro “ESC” crashes cubase… Unbelievable…

now with video proof:

http://www.youtube.com/watch?v=xlXkjfzaboA

please Steinbgerg! It was mentined as “fixed” in the changelog, but it ISN’T!

Please again have closer look!

I already PM’d this to TabSel, but here is our current status (tested in Cubase 6.0.1 pre-release):

Win x64 Cubase version: Issue 5) can be reproduced
Win x86 Cubase version: Issue 9) can be reproduced if after deleting Esc macro “reset all” is selected
Mac OS X: both issues not present

We aim to fix the issue finally in 6.0.2. In case this turns out to be complex in this stage it will be fixed in the next following update.

Best regards,
Helge

I sure hope and wish this to be fixed finally. Thanks for your reply.

Somehow keyboard/mouse Input behaviour seems to be altered in General? Rightclicks are ignored often
And require another rightclick. Remote Controlling my Desktop using teamviewer won’t Pass any Mouse click to the Application…

Video proof?

I can still reproduce the Macro crash with 6.0.2 but not the preset browser issue. That doesn’t happen anymore.
Have you tried to trash the preferences and start with new ones and then add your preset?

I’ll forward the Macro issue!

Correction: I just found that this has been added to our bug base by Christian D. already again.

Here’s a video proof that I still can’t access the menu “edit” (german: “bearbeiten”) with v6.0.2: http://www.youtube.com/watch?v=osCenuX0JyU

I trashed preferences before and rebuild macros…

I really don’t know what to do more…

HELP!!!

No acknowledgement. Neither here nor to my PM.

I am angry and dissapointed.

Tabsel, we have been very busy with the company move, sorry! I have forwarded this again and there is still a pending bug report on this, so it is not lost and development will have a look again. We only need to find a way to reproduce the part you have with the “Edit” menu…

Thank you!

Maybe, if you build the macros as in the attachment MANUALLY, as I did, one after the other, it occures at your machines, too…

Please take your time and sort this out, I really can’t work with this failure… :frowning:

Hi TabSel,

I had a look again at the issue but this is totally mysterious.

We have to divide it into two issues:

A. Opening the Edit menu accidentally opens a Preset Browser
B. Crash while operating in the Macro section of the Key Command window.

For problem A we indeed could reproduce the issue with your key command file using Cubase 6.0.0. We found an issue and fixed it, since that all we do to reproduce the issue again (in 6.0.2) have failed (means the fix has worked). I have just tried it again at three different systems with 32-bit C6.0.2 on 32-bit Vista, 32-bit C6.0.2 on 32-bit W7, 64-bit C6.0.2 on 64-bit W7 using your key command file attached to the first post hre. Though I have not yet rebuild all the macros in the preset file…

Apart from the macros you have added, did you remap or added new keyboard shortcuts in your preset file? And just to be sure, if you have a virgin Cubase 6 installation (no old preferences) you the issue appears as soon as you add your macros?

For case B the issue is still open and clearly reproducible (28472). Crash-bugs are bad, though I am wondering: Why removing a Macro and then using “Reset All”?