Crash on VPN

Cubase 12 just completely crashes when running Windscribe VPN on Windows 10 64 bits.
All up to date.
I’m wondering if this could be due to the VST connect feature, or a call from some of the plugins to verify licenses. Either way it might be worth strengthening the protocols so that if there is such a network change the app either offers a message asking to reboot or ignores the change and blocks the calls.

No. And as far as plugins go, Steinberg plugins don’t ‘phone home’ and never have.

Do you have a crash dump file that you can upload here? Would be helpful to see what process was responsible for the crash.

If you have a live connection and change the VPN in between, or change anything to your network settings, the connection will be disconnected. That is how a network works. However, this shouldn’t crash Cubase at all, so yes that might have to do with VST connect and a crash dump might show it.

As @steve said, Steinberg is not calling home.


Attach the DMP file, please.

I tried several times and get crashes absolutely every time.
Big workflow issue for me.
I noticed there are 4 dmp files created:

I’ll try to attach the smaller ones first.
Would love some help even if that means killing VST connect which I do not need at the time being.
SteinbergLicenseEngine.exe.28008.dmp (730.6 KB)
SYNSOPOS.exe.27816.dmp (648.0 KB)

The big ones cannot be uploaded…
AWCC.exe.20740.dmp is 19 MB
Cubase12.exe.20736.dmp is 68 MB

Kindly let me know if we can work something out I can send by email or Dropbox or Wetransfer with an email.

Just paste the dropbox/wetransfer links here in a post…

I had a tentative look at the two dumps, and it sure looks weird. Both have the same exception:

ExceptionAddress: 00007ffe624a286e (ucrtbase!abort+0x000000000000004e)
   ExceptionCode: c0000409 (Security check failure or stack buffer overrun)
  ExceptionFlags: 00000001
NumberParameters: 1
   Parameter[0]: 0000000000000007
ExceptionAddress: 002329d3 (SYNSOPOS+0x001e29d3)
   ExceptionCode: c0000409 (Security check failure or stack buffer overrun)
  ExceptionFlags: 00000001
NumberParameters: 1
   Parameter[0]: 00000007

Do all those crash dumps have the same/similar timestamp?

I am not sure what to make of that, this is something for people with Windows development experience.

btw, while Cubase does not phone home, it communicates with the LicenseEngine via TCP, only on, but maybe that’s where the VPN creates problems?

Maybe you have to turn on LAN access in the VPN config. If that product doesn’t have that, maybe change products.

Certainly this is not a Cubase/Steinberg issue.

1 Like

The error is in a Windows library, that comes with the operating system.


This is the “Universal C runtime library” and there are many problems reported if you search the internet for it. It can have many reasons, which means it is hard to catch the real problem.

Did you install some other software lately, or any new drivers? If yes I would try to go back to a previous Windows restore point at a point in time where you did not see this problem.

I would also deinstall the VPN software and see if that has any impact here.

Here is a site that explains several ways of fixing problems with ucrtbase.dll, but without any warranty that it will fix the problem.

How to fix ucrtbase.dll application error on Windows? (

Try to fix the problem as described.

If that is the C runtime, it kind makes sense, what I found out about the FAIL_FAST_FATAL_APP_EXIT from STATUS_STACK_BUFFER_OVERRUN doesn't mean that there was a stack buffer overrun - The Old New Thing is that it is essentially when a program calls abort(), which would be in this runtime lib. That makes it hard to debug as the problem is not in the runtime but in calling program which for whatever reason thinks it rather needs to end itself unconditionally.
It is just really interesting that it happens in both the old and the new license manager…

Well you knocked it down Steve, it worked ! As soon as I turned on the LAN option then no more crashes. Well done and I thank you very much for taking the time to answer :slightly_smiling_face:
I’ll try pay it forward !

best, Antoine