Cubase 10.5 Insert Issue - NEW Work around

When I put a WAVES 9.92 effect in the insert section of a track it opens and shows the GUI. If I close it and then reopen it the effect is still there but the GUI is black. I then go into my effects drop down and select it again and it opens the GUI with the effect showing. This does not happen with any other plug ins I own. Also the Shift Command clicking e button will not open all the inserts on a track.

I tried reinstalling the plugins. That did not work.

WORK AROUND-

At the bottom of the upper right corner drop down on the GUI select “generic editor”. When you then open and close the GUI it shows the settings.
Not as nice to look at but it works and more usable than a blank black one.



Mac High Sierra.

I’ve seen several plugins showing a black GUI that were perfectly OK in 10.0.50 - what’s changed?

Same here.
I am on Mojave and all Waves plugin V9.92 shows up with GUI blacked out, not matter newly inserted or reopened.
Never had this issue in Cubase 9.5.

Seems v10.5 has introduced lots of problems with plugins. So far for me at least, the Reason Plugin makes Cubase unresponsive, need to force close it. Others have reported similar issues with other plugins. I just installed v10 for now (I moved from 9.5 to 10.5), hopefully, that’s more stable.

Any word on this issue? Keepin’ it alive

I contacted support and received an email saying that the plugins doing this probably needed updating as they are using an old version of Juce that has issues with OpenGL on Mojave.

This ‘may’ explain the issue on a Mac - although I’t doesn’t explain what Steinberg has changed since V10 where these plugins are working fine.

The issues with Macs freezing may also be related to this change -

Hi,

Cubase 10.5 is built against the Mojave SDK, that’s what changed since C10.
OpenGL is deprecated on Mojave, it is still present for compatibility purposes, but there are indeed some issues (there are a few interesting threads on the JUCE forum, for those who like to read about it).
There are also other changes that might trigger issues with plugins built against older SDKs.
Specifically to Waves, I have used with no problems both V10 and V11 with C10.5. Blank UIs are an issue when the host is built against the 10.14 SDK and the plugs against 10.12.

But please keep on reporting the issues you have, we’re still looking into this.

[Edit] https://developer.apple.com/documentation/macos_release_notes/macos_mojave_10_14_release_notes

I’ve found that using the generic view can be frustrating for some of the W9 titles. For me, the generic view kills my visual “muscle memory” as to where and what controls I may need to tweak. Yes, it works, but it slows down my work flow.

I found another work-around. Unfortunately, it requires the use of a paid plug-in. But it works. Plogue’s Bidule. I use it as a wrapper for the W9 AU versions. The good news is Bidule doesn’t appear to add any additional overhead to the CPU and the Waves GUIs appear and work normally. Once I’ve inserted a W9 plug-in into Bidule, I save it as a Cubase preset (including the name of the plug) so I can quickly recall my go-to units. Not the most elegant solution… but it solves the black GUI issue for the time being.

Hold on, guys.
I had the same issue, mostly also with Waves pi.
In the German Forum I found help.
It seems that some pi need some time to insert propperly.
If you have the timing compensation “0n” (down left corner, watch-symbol get´s orange when on) it won´t work.
Put it off and it works again

That is a completely different problem! That was a malfunction on your part and no Bug in cubase!

Thanks docmidnite! This fix worked for me. I opened up a session in 10.5 that was created in version 10. For whatever reason the timing compensation switched to active and any instances of the inserted stock Gate and Voxengo PHA-979 blacked out…I clicked off compensation and all went back to normal.

Thank you so very much! I was going bonkers and that solved it for me!

I have a somewhat related issue with the Waves GUI - whenever I click and drag one of the controls in a Waves (V9) plugin, like Q4 or Renaissance EQ, and release the mouse button, the cursor jumps to a completely different point on the screen. This basically renders my Waves plugins unusable in Cubase 10.5, so for the moment I have to go back to using C10. It would be great if it would be possible to find a fix for this - if I had known about the SDK changes between 10 and 10.5 and the consequences, I would probably have stuck with C10.

I found a way to use my Waves V9 Plugins. You can download de Studio Rack V11 (It’s free), and there you can load your old plugins with the classic interface. Each time you have to open the Studio Rack and then open your plugin, but at least you don’t have to use the Generic Editor…

Thanks for this workaround! Just tried it and made an interesting discovery - once I’ve inserted StudioRack somewhere in my project, the jumpy GUI control behavior stops and all other Waves plugins (not just the ones in the StudioRack) on all channels in the project (not just the one with StudioRack inserted in them) work just fine again!! No idea why that’s the case, but it seems to work. Thanks a lot!