cubase 10 Class not registered (0x80040154)

I am getting the following errors on windows 10 pro 1909:

elicencer version 6.12.1.1266
Application ‘LCC2’ has caused the following error:

2020-04-29T11:28:53.068 - ACC - -> 2020-04-29T11:28:53.068
DCOM connection to program ‘Synsopos.exe’ failed.
Class not registered (0x80040154

cubase 10 version 10.0.60
Application ‘Cubase / Cubase Artist’ has caused the following error:

2020-04-29T11:30:28.967 - ACC - -> 2020-04-29T11:30:28.967
DCOM connection to program ‘Synsopos.exe’ failed.
Class not registered (0x80040154)

Before you ask I have followed all the instructions and suggestions I can find online and on the steinberg site.
I have done the following;

  • updated windows 10 to the latest update


  • run sfc /scannow


  • removed elicenser and manually removed all associated files as per steinberg instructions


  • reinstalled with latest version from their website


  • installed latest version of cubase 10 again


  • updated vb and .net


  • updated drivers


  • used different usb ports

had the steinberg remote control my computer for over an hour and he gave up
has anyone any suggestions as my only option seems now to be to reinstall windows 10 from scratch and the thirty odd programs including 50 vst’s, many of whom I am not really sure I have the serial numbers for.
This has been working fine for about two years and now suddenly won’t work. Is there a hidden problem in the windows updates prior to 1909 i should know about and uninstall??
Please help me as I think steinberg have given up.

Open eLicenser software as administrator and run maintenance.

Thankyou for the reply.
Steinberg remote control operative has already tried this.
The error occurs when I open the program as an administrator.
A window pops up showing
elicencer version 6.12.1.1266
Application ‘LCC2’ has caused the following error:
2020-04-29T11:28:53.068 - ACC - -> 2020-04-29T11:28:53.068
DCOM connection to program ‘Synsopos.exe’ failed.
Class not registered (0x80040154

Then I cannot do anything within the elicenser interface. None of the buttons work.
do you have a suggestion as to getting the maintenance button to work when it is greyed out.

Try to reinstall everything or if possible install just the eLicenser software on another computer and move the USB stick to the other computer. If it still fails it might be a broken USB eLicenser.

Thanks,
I have removed and reinstalled elicenser and cubase 10 and done an in-place windows 10 reinstall.
I did not insert the elicencer USB afterwards but ran elicenser anyway and the same error occurred so I am guessing the stick is damaged. I’ll try another PC.

I have tried the elicencer in another computer (windows 10 home laptop)and it works straight away. Ran maintenance and then reinserted in the old computer. Get the same error.

Then it seems like a USB problem on your old computer. Maybe the USB ports are fried or the driver is missing or not working.
I assume you are also using USB for keyboard and mouse? What happens if you plug the USB stick into the USB port used by keyboard or mouse?

I had problems a while back ,the problem was usb 3.0.
As soon as I inserted USB key into usb 2.0 it worked straight away.
Small point but might help.

Thanks for the advice
I have moved it to the 10 available USB 2.0 ports to no avail
I have used the two keyboard and mouse USB ports with the same result
I have used the 6 USB 3.0 ports and no joy
This sabretooth motherboard is supposed to have military grade chips.
Can’t understand why this suddenly happened after two years maybe I need another motherboard.

I’m out of ideas about this one other than something wrong with you motherboard. Military grade chips are nothing but a marketing stunt, so don’t put too much into that.

I think you are right definitely a m/b problem. I may have to downgrade and get a lower spec fx board but hey ho I’ve been without cubase for two months now and I am going unexpected crash crazy using mixcraft and audacity.
Thanks everyone, I’m off to sell my body to Glaxo for medical research so I can get a new m/b. Then of course there is the fun of removing the water cooler,ram, 5 hard drives, power brick, fluff, old socks and loose screws from the maxi tower.
Of course then Microsoft will probably invalidate my licence for win 10 lol.

Solution found, it seems this problem is coming directly from Windows “DCOM service”…

https://www.steinberg.net/forums/viewtopic.php?f=283&t=188701