Cubase 10 Content Storage

Hi; I’ve upgraded to Cubase 10 and I launch Steinberg Download Assistant. There I see Cubase Pro 10 and click on it. On the right I see 'Cubase Pro 10 - 10.0.5 Full and across to the right I see there’s a 21.09 GB Download. Above I see a default target folder on my system drive, but also to the right an option to change the target folder. My system drive is an SDD drive and is a little over 2/3 full, and I really would like to avoid putting that 21.09 GB on that drive. Is it OK to download it to a secondary drive?

Thanks for any input!

Bobby Ryan.

Worked fine here
I down loaded it to a non system drive, then moved it to my Storage drive and installed it from there
All went well

Hippo

In windows you can choose where all the content goes at install, though its not super-obvious. On the page where you select what components are to be installed, each has a small dialog bottom right where the content will go. Select this and put it where you want it.

A choice on install locations for the content it is definitely not obvious in the dialogue. Consequently I have installed everything on my system drive and will want to move it to my sample drive and I think the Library Manager which will do this.

Correct: Steinberg Library Manager supports Halion and Groove Agent content to be moved to another drive.

But (unless i miss something), VST Sound Loop Sets, bought from Steinberg site, can’t be moved. (i am on mac).
Abit of a bummer cause these VST Sound Loop Sets can really add up in taken System HD space
and possibility to move these files to an external drive would be very welcome imho.

Warm Regards.

I want to thank all of you for your info and support. I’m just waking up but I’ll get back to the install shortly.

Thanks again!

Bobby Ryan.

You can move them using sym links. I just did this on Windows yesterday. The files reside elsewhere but Cubase still sees them as being in the original location. Works great.

Same problem here. I had C9.5 + Absolute 3 and all of my VST-Sounds from Steinberg on a different Drive. So far so good.
But during install of C10 I cannot define the drive I want the Content to install to. The path is greyed out. So everything is installed on the C drive.
And indeed only Halion+GA can be moved in the manager. In the folder Prgr.Data on the system drive there still is about 11Gb’s of Vst sounds ?!!!
Absolutely crazy.

Look into Symbolic Links (Sym Links) in Windows. It totally solved this for me. The process was this:

  1. Exit Cubase

  2. In Windows, create a new VST Sound folder on a different drive. This is going to be the drive and folder location where you’ll want to actually store the content. In my case, I created a “Cubase Content” folder on another drive so it was: D:\Cubase Content\VST Sound

  3. Go to C:\ProgramData\Steinberg\Content\VST Sound - cut or copy all the loop data in the folder and subfolders

  4. Paste the data into (modify to fit whatever location you want to use) D:\Cubase Content\VST Sound - now you’ve got a copy of your VST Sound folder on the drive you want all this stuff on

  5. Go back and delete the original VST Sound sub-folder: C:\Program Data\Steinberg\Content\VST Sound (this step is important and tripped me up last night - the OS needs to create the linked “VST Sound” folder)

  6. Open a Command Prompt in Windows - Run as Admin or you’ll get an insufficient privileges error

  7. In the Command Prompt type in the following (obviously, you’ll replace D:\Cubase Content\VST Sound folder with whatever one you created):

mklink /D “C:\ProgramData\Steinberg\Content\VST Sound” "D:\Cubase Content\VST Sound"

  1. Press enter to execute - you should get a message that a Symbolic Link was created between the two folders.

If you get an error, it’s likely that you either didn’t delete the original VST Sound sub-folder, have a typo in the directory names somewhere, left out the quotes in the mklink syntax, or didn’t run the command prompt as admin. I made all these mistakes last night so you don’t have to!

  1. Relaunch Cubase (should be no different than any other launch)

Result: 12GB of space on C: drive freed up. My Cubase content now physically resides on my D:\ drive, but Cubase still thinks it’s installed in C:\ProgramData\Steinberg\Content\VST Sound.

Using Symbolic Links: interesting !
For OSX users, try this free application for creating sym links:
https://www.macupdate.com/app/mac/10433/symboliclinker

I haven’t tried it out myself, will let you know if it works.

Warm Regards.

Thanks for that walkthrough Funkybot.

Though I have to say that I am surprised and disappointed that the Library Manager doesn’t manage all of the relevant files - just Halion and Groove Agent. How about an update, Steinberg?

+1.

Thinking about this - as I don’t use Halion or Groove Agent (I have other vst’s) can I just delete all the content files? Would Cubase complain?

I’ve been busy with a more detailed experiment with the issue and I forgot to look back and check this one. I haven’t tried the Sym Links yet but if it works I’ll be one happy camper. Kudos to Funkybot!

Just when I though victory was at hand, crash! I’ll attach a screenshot of the error message.

Cubase may complain only the first time you start Cubase after removing it from the Content folder. Take it slow… in the warning box that shows, you got three choices (locate, ignore, or remove) > Choose the REMOVE option (I guess this will remove the “pointers” - registered somewhere in the app data).

PS. There may be an easier method to get rid of those “nags” from within the respective app folder within the content folder (eg Halion - which include some settings and stuff in .xlm files. Have a look at those)

I shrinked my content folder by half by removing some Loopmash stuff and some sample libraries +++ that I don’t need. And saved them in a “Steinberg Offline Content” folder (If I should need it later).

The process in Powershell seems to be different than the standard Command Prompt. Run the regular Command Prompt as Admin and try again.

Or look here about PowerShell (which looks more complicated):

https://docs.microsoft.com/en-us/powershell/wmf/5.0/feedback_symbolic

I finally figured out ‘mklink’ doesn’t work in Windows 10 Powershell. I did the standard cmd prompt and ran it that way and when I hit enter I got ‘Access Denied’. Even though my user account is supposed to be ‘admin’ I had a similar incident before and I had to create another ‘admin’ user, which I did and it worked. Anyway, I switched to that user and got the same response ‘Access Denied’. I couldn’t get a screenshot with that ‘user’, but there was a difference in the error message. This time it read ‘administrator’ in the prompt, so I shouldn’t be denied. To say I’m disappointed would be an understatement. Thanks for your help!
Sym Link Error-2.jpg

Your syntax is off in that last screen print. You’re missing the /D. Copy and paste from my post above if you need to.

Also, before you launch it, right click Command Prompt and select Run As Administrator in the pop up menu.

Try both things one last time before giving up.

Serious trouble. I was successful in switching admin accounts and tried the full line this time and after I hit enter I got “Cannot create a file when that file already exists” (screenshot attached). First I thought that was a good sign until I switched back and launched Cubase. I tried to open HALion and I got countless ‘files missing’. Also Groove Agent is virtually empty. I didn’t delete the content, I copied it to my D: drive. It’s still on my C: drive, Cubase just doesn’t see it. It’s getting too late here and I can easily use True Image and reset my C: drive back to before when all of this crap happened. When I do it from a fresh recovery maybe it’ll be fine.