Cubase 11 Score editor "Edit Midi note duration" only creates long notes

I was super excited about editing midi note duration in the score editor of Cubase 11, but whenever I try to edit the length of a midi note, it defaults the note I’m editing to a long held one, 150 bars longer than my midi event.

1 Open midi event with notes in score editor
2 Enable Note Editing Overlay
3 Select note and adjust “Midi Note duration”

It doesn’t matter if I extend or make the note smaller -same result.

I can edit “display duration” or velocity in the score editor without problem. “Snap” on or off makes no difference.

Cubase 11.0.30
MacOS Mojave 10.14.6



Could you please send a screenshot or a video? Under Win10, I can not reproduce the problem

Hi, Thank you for your reply, and for trying out. Maybe it’s a mac only thing?

I’ve made a screengrab of the issue:

Thanks for the explanatory video.
I tried to reproduce the error and make all the settings as far as possible in your video
But as I said, I cannot reproduce the error on Windows.

I have seen a similar issue on my system. I’ll do some testing later today.

Well, I couldn’t reproduce it just now. But I just saw this the other day (and previously too), and so far I haven’t been able to figure out a reproduction sequence for a bug report.

I’ll keep watching for it. It would seem to be non-OS specific as well, since I’m using Windows 10.


Thank you for trying out this, Steve.

I’ve had this issue on multiple occasions and on different projects, but trying again today it’s working fine for the first time. Not sure why it’s suddenly working, but it is. Fingers crossed it stays this way - it’s a dream feature of mine and I can hopefully rid myself of sibelius for writing purposes :slight_smile:

Well, if you notice what setting was different this time around, post your observation. If and when I see it again I will too. Another forum member, a real maestro that one, :wink: is also on the lookout for this.

1 Like

:grinning: I am watching secretly
Thanks for the compliment Steve, you flatter me* :slight_smile:
But for the moment the maestro feels a bit miserable with regard to the reproduction of this issue. :blush:

1 Like

To reproduce the issue, the track must be in Linear mode! :wink:


You got it! That’s it.

Yeah, yeah… :stuck_out_tongue:
Linear mode is kinda’ dangerous when working with the Score Editor. For instance, if you use “Build N-Tuplet” a lot and you accidentally modify the Tempo Track while the Layout’s track is on Linear mode, Cubase will/might crash at PDF export (when you print). This is why I created this feature-request:

The reason I created the topic is because the events generated by the “Build N-Tuplet” window are problematic (when doing some strange operations). I might be the only one performing unusual tasks like altering the tempo track in order to change how the notes are displayed in the Score editor, i.e. switching:
→ to a 3:1 ratio (quarter notes → dotted half notes)
→ or a 1:3 ratio (quarter notes → 8th note triplets)

Wow thanks! Excellent there is a workaround here :slight_smile:

I work in film, so linear mode is my standard track setting!

1 Like

@alin89c nice find!

Ooh! Sounds dangerous! :slight_smile:

1 Like