Cubase 12.0.40 maintenance update available

A post was split to a new topic: When aborting an Export Audio Mixdown. it now deletes the original file

So far so good here on macOS Monterey… Just recorded two projects yesterday and after updating this morning went through em and did some mixing/messing with inserts/etc… Same as it was before.

When are they finally going to update this thing so it makes me coffee? It does everything else just fine, now lets get to the real feature updates! :smiley:

I rolled back from 12.0.30 to 12.0.10 for the longest time because 12.0.30 was not stable on my 2021 MacBook Pro M1 Pro running macOS 12.5. So far, I have not seen any issues with 12.0.40. Seems to run smooth. Like the fixes that were applied. SO FAR SO GOOD is GOOD for me. I’ll report if I find anything. Thanks SO much to the Steinberg team.

Hi, the new update looks good (considering some little hours of working time), except this !!
Can anyone confirm if he has similar behavior?
(Windows 10 - C12.0.40)
As you can see from the images, outside the midi clips the notes look out of the grid.
Inside the midi clip, everything is as should be…

(I have restarted the PC, I have checked other projects, same behavior…


5 Likes

Thank you for putting a link to the “release notes” here.
FYI, I went to the downloads page and when I try to download the release notes from there it takes me to: https://www.steinberg.net/de/cubase/release-notes/12/
Which is a blank page. Just thought I would let you know.

This is from :Cubase Pro 12 Downloads | Steinberg

Cubase Pro 12.0.40
updated on August 3, 2022 · Release Notes

3 posts were split to a new topic: Waves license error after updating Cubase (No valid Waves licenses found)

@Orestis, @Louis_R, Confirmed this issue here as well. Everything is in time when I open the key editor, but in the channel, the quantization is outside the note.

1 Like

I just installed this update and it has messed up all my projects. they are missing all the plug-ins and VSti? What in the world is this???

What version are you updating from? Please check if Cubase 12.0.40 has been installed to the same drive as your previous version. On Windows, Cubase 12 is installed to C:\ by default.

In any case, you probably just have to rescan your plugins using the VST Plug-in Manager in the Studio menu. Check if any of your VST 2 plugin paths are missing.

1 Like

Many Thanks for the score editor improvements - next, horizontal scrolling please…

Sadly still no fix for the most annoying issue I have at the moment

i mean, this was working in 11… how long can it take to fix?? I do hope this will get fixed in another maintenance update and not only in 12.5 or later…

are you running Mac silicon? You might have to check the - run in rosetta - box again

Yes i can confirm this on Win 10 as well ,after quantising the editor behaves correctly but the main project page stays off bar

Are going to have to wait months for the next release to have this very annoying midi note issue sorted out ?

8 Likes

After the update it wont even open for me now. Details posted under a new topic, so to not overload this initial announcement of the new .40 release.

Error: Skin file “skin” not found!

Did not work

In that case, start a new topic for your issue, please.

Great and all, but I wish you would fix the issue with Komplete Kontrol S keyboards and Cubase. Any other DAW, I just load up a Komplete Kontrol track and I can use the dials and the lightguide on the Keyboard. In Cubase, not so much. It always loads up with MIDI information on the screen. Yes it’s an easy fix by disabling and re-enabling the track to put it in vst instrument mode, but c’mon guys! There are so many posts out there with this issue, and it’s been going on for years. I don’t know about anybody else, but I would like to easily use the functionality of my $800 keyboard.

Well i thought id post here again as my comment got flagged and deleted in the midi issue thread

Fix needed for the Midi note Asap please

2 Likes

Looks like 12.0.40 has a gap that is causing my loop to play incorrectly.

I tried selecting and re-selecting and moving loop points but there is this gap that causes a playback issue making this unusable. I cannot move the lop markers any further to the left and my volume automation does not work like it should.

image

I don’t think there was a gap in previous updates. Please fix. Thank you!

There is a loud pop when it cycles around. How can something like this get past QA???