Cubase 12 audio

I recently upgraded from Elements to Artist and have been using both without any problems. Today I launched Artist and was told no audio was connected. I went into Studio and looked at Asio4all ports and Inputs were OK, but Outputs weren’t connected.

So went to Asio control panel and whilst Inputs were OK, Outputs were not.


I’ve restarted computer and Cubase multiple times with the same result. Now I find the Elements has the same problem!! And considering they were working fine up to today, I’m lost for an explanation.
Any ideas??

Have you tried re-installing ASIO4All? Have you tried using the generic ASIO driver that is supplied with Cubase?

PS. I would change the title of this thread as the issue is unrelated to Cubase.

I’ve just reinstalled Asio4all and whilst the red cross has disappeared, there is still no sound. Selecting the generic Asio driver makes Cubase crash. All other programs using the USB codec work fine, its just Cubase.

Now reinstalled Cubase, but problem remains!!

What is your audio interface?
Looking at your screenshot again, it seems you have several audio options. Have you tried with the Realtek one?

I think that was expected since the problem doesn’t lie within Cubase’s realm.

U-Phoria UMC22 USB interface. I’ve changed it for an older UM2 but there’s still no sound. I’ve reinstalled the driver also but not a peep.
I’ve done a System Restore to yesterday when I know all was working, but still nothing.
On Elements I now have all ports connecting correctly, but there’s no sound output.
I’ve now, hopefully, covered all aspects of the system, but still nothing.

I’ve now checked with RealTek active, no sound.
I’m interested why you think this isn’t a Cubase problem, because everything else works through USB and RealTek. Its just Cubase progs that don’t work.

Please watch the various VU meters inside Cubase.
Do they show any activity where they are supposed to?
Are your tracks properly set up? Like is the correct output selected?

Try clicking the Reset buttons in the Studio Setup window (your first image) and see it it fixes it. There may be a port name conflict that is causing Audio Connections to lose connections.
Make sure the port name for the channel is the same in both places.

If everything’s okay up to this point but the issue persists, then it definitely doesn’t come from Cubase.

Make sure to set up the audio channels properly by disabling Exclusive Mode in Windows and disabling Release Driver in Cubase (or follow this guide if you don’t know how to do it).

Most importantly the sample rate must match between Cubase and your device, specifically when using ASIO4ALL since it doesn’t change it automatically. If your projects in Cubase are 48 kHz then set the channels in Windows to this same sample rate. In my opinion, it is very likely that your problem comes from here.

Thanks for the info. I’ve done all that and I’m seeing activity on the meters. Loading a completed music file from a couple of weeks ago has no sound, and still reports no audio output connection.As you can see from the Asio control panel, The Always resample 44.1kHz to/from 48kHz is ticked. Or is that not what you mean?
Let me add that I’ve been using Cubase since version4,(yes I’m that old!), and I’ve never seen this before. Its driving me mad.

Just out of interest, I’ve installed Reaper, and it works perfectly with the USB driver, so I’m still suspicious of Cubase.

I believe what you see “Not Connected 1/2” is the actual name of the port, this is a glitch.
What are the names of the ports inside the Audio Connection window? Are they the same as shown in the Ports panel? Try selecting a different driver and select ASIO4ALL again to see if anything improves.

I don’t think the resample box has an actual use in this case but it’s worth checking the guide first and make sure the sample rate is the same in Cubase and Windows.

Thanks, I’ll look into that when I’m back from work.

After playing about with Cubase settings, I eventually got some sound using the generic ASIO driver and RealTek speakers, but that doesn’t go through my main sound system. Then when I restarted Cubase, there was no sound, and Realtek didn’t appear as a choice in Control Panel!
It seems that each time I launch Cubase, the settings for audio vary each time. One of the dozen times I started Cubase, I got perfect audio settings…but no sound!


Next time I started it, got Not Connected, so it isn’t consistant.
I wondered if another program was hogging the audio, but checking Task Manager, nothing else is running.
All other sound files work OK through the default USB UMC22, but not Cubase.

Another thing I’ve noticed is when playing a project (even without sound), the cursor doesn’t move smoothly, it plays half a bar then stutters and carries on, then repeats that all the way through. So there’s something wrong with the program, I just don’t know what.

The jumpiness in Cubase scrolling is likely due to the audio setup conflict

A couple of thoughts that may help -

  • MOST IMPORTANT - Your UMC22 has to be powered on before you start Cubase. Cubase tries to load the last audio setup, but if it is not available at start up Cubase will load a generic setup, and you will have to re-aet the Studio driver setup and the F4 Audio Connections.
  • ASIO4ALL is finicky - if you are running multiple audio programs it gets confused. I use ASIO4ALL for a couple of uses, like on my laptop when I’m away from the USB audio interface.
  • If you try to use a BlueTooth speaker instead of the UMC22, you will need an additional program - BT2Reaper Microsoft Apps
  • Cubase takes over the audio system, so you wouldn’t expect to hear sound from the computer’s RealTek output unless you enable it in ASIO4ALL. I see in your screenshot RealTek isn’t enabled but I wonder if there is another audio out enabled if you scrolled down? You want the UMC22 outs to be the only ones enabled.

Hope some of this is helpful,

ASIO4all is a substitute for a real ASIO driver. Sometimes it fails.

Well, I bit the bullet and reinstalled Windows, Asio and Cubase, and now everything is working perfectly. Luckily this PC is dedicated to music production with all music files on separate SSDs, so it wasnt to bad. Two hours and I was back in business.
I’ve been using Cubase in its various forms since mid 2000s, and I’ve never encountered this before. Whether it was software or OS, who knows, i just hope I never see it again!
Thanks to all that offered help, and maybe this will help others with the same predicament.


It seems the same problem has returned! I don’t understand why it works one minute and not the next!
Any way, I did some research and found lots of examples where ASIO4ALL doesn’t work well with Windows 11 but found a workaround…sort of.


I found that selecting Hardware Buffer, I get sound. Trouble is there are lots of crackles, and sound quality isn’t brilliant.
Can someone explain what the Hardware Buffer is, and what I can do to get around this?
With the HB ticked I get sound, unticked just silence.

Try to turn off resampling.

And I highly recommend a real audio interface. There are some inexpensive devices available that use a real ASIO driver.

Well, I got a UMC202HD and problem is fixed. Thanks for all of your help.

1 Like