Audio Setup Guide - for Windows users

This guide will explain how to output the audio from both Cubase and Windows at the same time.


If you want to be able to listen to audio from Cubase, Windows or any other program at the same time, and record in multiple applications at once, the following points should be observed :

  1. You audio interface driver must be multi-client compatible,
  2. The sample rate must be the same between all programs,
  3. You must disable Exclusive Mode in Window,
  4. You must disable Release Driver in Cubase.

All these settings are explained below.

This guide will only teach you how to use the same device in multiple programs and how to avoid any further issues. It will not explain how to use Cubase and third-party programs.


Multi-Client

When a driver is multi-client, it means that its audio channels can be used by multiple programs simultaneously. Normally, almost all modern audio interfaces are multi-client compatible, so this should not be a problem.

Click to reveal details

We can distinguish two multi-client “modes”.

ASIO/Windows :
Is the ability to use the channels in one ASIO application and in one or multiple Windows applications simultaneously.

ASIO/ASIO :
Is the ability to use the ASIO driver in multiple programs at the same time.

Most audio drivers offer these two modes, and you cannot tweak this. When a multi-client driver can operate in ASIO/ASIO, it also operates in ASIO/Windows (the two combine).
However, some old drivers may only operate in ASIO/Windows mode.

Important note :
Some drivers are not multi-client, such as the Generic Low Latency ASIO Driver included with Cubase. If you don’t have an audio interface, of if you want to aggregate the channels of multiple devices, please consider using ASIO4ALL instead, which is now fully multi-client.

Also note that some devices like Virtual Cable don’t seem to work good with ASIO4ALL in Cubase (while it works fine in other software).


Sample Rate

For channels to output audio from multiple programs simultaneously, the sample rate must be the same between all of those programs.
Windows – and all its sub-applications, like media players, YouTube, Discord, etc – is considered a single program, so the Windows channels sample rate must be the same as your DAW / ASIO driver.

Click to reveal details

To open the Sound panel in Windows, go to Settings > System > Sound > More sound settings.
Now for each input and output channel, double-click on it then go to the Advanced tab.
Change the Default Format to the same sample rate and bit depth you plan to use in Cubase.

In Cubase, the sample rate and bit depth settings are found in the Project Setup Dialog.
I highly recommend creating a custom project template with these settings, which you will use when starting any new project. This way, there is no sample rate mismatch.

Additionally, when starting an audio program, make sure to stop playback in other programs and media players before doing so. If the audio is playing while the same channels are getting loaded in a different driver, this will eventually cause the audio stream to cut out and you’ll have to quit and restart the applications (and in the worst case this may even reset the device in Windows, and you’ll have to change the channel settings all over again).

Optional : While you are into the Sound panel, you can disable (with right-click) the channels from devices you don’t plan to use, for example the built-in channels or HDMI outputs. You should only keep what you will actually use. Also, you can right-click on the main output and set it as default.

Important note :
Most drivers may not allow to change the channels sample rate from Windows audio settings, and instead it has to be done from the device’s own control panel (i.e. the driver settings).
In other words, the sample rates are linked, making it impossible to work on multiple audio files that have different sample rates without making other programs crash (e.g. switching tabs in RX).
If you are in a such situation, then you should keep your working setup as simple as possible, and be careful not to have other programs opened when the driver changes the sample rate (some programs can handle this, but some can’t). Please read the following details :

Click to reveal details

Such drivers behave as follows :
They will create separate channel sets for each of the available sample rates. If you open Device Manager and view hidden devices, under audio inputs and outputs you will see duplicates for each channel. Those that are not grayed out correspond to the sample rate currently in use, and those that are grayed out correspond to other sample rates and are “unconnected” (they will only appear when the different sample rates have been loaded at least once). When you change the sample rate through the driver, or when you switch between programs that use different sample rates, Windows has to close the channels and load the appropriate set corresponding to the new sample rate, thus causing the audio to drop for several seconds. It’s literally like having multiple audio interfaces each running at a single different sample rate, but you only have one USB port and you have to unplug one interface to swap it out for another.

This can actually cause applications to crash, which isn’t pleasant at all, especially when working with multiple audio programs at the same time. That’s why I recommend, if your driver behaves like this, to use only one audio application at a time, or, to be careful not to do an action that will inadvertently switch the sample rate.


Exclusive Mode

This setting is enabled by default for every audio channel in Windows.
When enabled, these channels can only be used by one driver at a time, which means that they cannot be used simultaneously by Windows an by an ASIO driver (ASIO always has priority over Windows).
That’s why it is necessary to disable Exclusive Mode for each channel so that they can fully utilize the multi-client driver.

Click to reveal details

This setting is found just under the sample rate setting.
You must completely disable Exclusive Mode by unchecking the first option, “Allow applications to take exclusive control of this device”. This should disable both options.

However, some built-in devices and USB/Wireless headphones require Exclusive Mode to be enabled. If you disable it, this can give unpredictable results, like causing the channels to become unavailable in ASIO4ALL. If you own such a device, you won’t be able to take advantage of multi-client drivers.

The same goes for specific channels like the ones used by VoiceMeeter. They require Exclusive Mode to be enabled, or they can malfunction.


Release Driver

This setting in Cubase was designed to work only with single-client drivers (namely, the Generic Low Latency ASIO Driver, and other old hardware) or when the device is only running in Exclusive Mode.
It is absolutely necessary to disable this setting in order to take full advantage of a multi-client driver.

Click to reveal details

When Release Driver is enabled, Cubase unloads the driver when its window loses focus, e.g. when focusing the desktop or any other window, in order to make the channels available for Windows, thus preventing these channels to be used by both Cusase and Windows at the same time.

The “Release Driver when Application is in Background” option is located under Studio > Studio Setup > Audio System in Cubase, just below the driver selection.
You must uncheck the box to disable it.
Once disabled, Cubase no longer unloads the driver when it loses focus, so we can still hear Cubase sound.

Important note :
If for any reason you need to activate Release Driver, you must be very careful not to switch too quickly between Cubase and other programs. You should always wait enough time for the driver to load and unload properly. Usually 10 seconds is enough, but it depends on the number of channels.
If you cycle back and forth too quickly, it can lead to very unpredictable results, such as crashing programs, corrupting channel data in Cubase, and resetting the channels in Windows.
Either way, you should always stop playback before switching between apps.


Issues with Yamaha Steinberg USB Driver V2.1.0 or later

If you are using a Steinberg audio interface with the 2.1.0 or 2.1.1 driver, and are still not able to hear the audio from multiple programs simultaneously after following all the steps above, or are experiencing various issues, then please revert to the 2.0.4 version of the driver.

More info and download link

More information on Steinberg Support : Issues with Yamaha Steinberg USB Driver V2.1.0 or later
You can download the 2.0.4 version here.


Conclusion

If all the steps were followed correctly and as long as all the conditions are met, you should now be able to hear sound from multiple programs simultaneously.

Enjoy your trouble-free audio experience !

If you want to learn more about this topic, please feel free to read the following pages :

Click to show links
20 Likes

Hi, i have “hearted” this wonderful post, thank you @Louis_R , and would like to say two things:

  1. Since following your directions i have not had crashes switching back and forth between Cubase and youtube, yayy! I’ve tested and pushed a bit, and even been able to force a situation where both are playing at once, not musically helpful, but interesting nonetheless I thought.

  2. Since making the changes recommend in this post Cubase has taken a lot longer to close down when i did a CTRL-Q, maybe 15-30 seconds, as opposed to 5 sec (to about 10 sec max) beforehand.

Is that expected somehow?

Thanks again!

Hi @alexis , I’m glad this guide was able to help you.

  1. What do you mean by “forcing a situation” ? You should not have to force anything, they can play at the same time. Is that it ? If yes then it is working as it should :wink:

  2. I don’t know, this is not something I would expect to happen. My Cubase takes no more than 3 seconds to close. I don’t think this can be related.
    You can eventually revert the changes and see if it closes faster, but 5 to 10 seconds already seems quite long, I believe the issue comes from somewhere else.
    Keep me informed !

1 Like

Hello. I have some trouble with Win 10. I have strange behavior after update Cubase LE AI Elements to version 12.0.30. Before (at version 12.0.20) when i ran my application i heard a click at my headphones and for a second all sounds stopped. When application was started - all external sounds returned. And after closed application - I heard click and for a second all sounds stopped and then everything was going well. Today I updated my Cubase to 12.0.30 and after ran Cubase - all sounds from external applications (browser, windows sounds) - was missing…I think - okay…but after I was closed Cubase - sounds did not appear. After restart Windows Audio service - the sound appeared. May be you can help me. Thank you and sorry for my English.

Hi, and welcome to our community !

By any chance, are you using a Steinberg interface with the latest drivers ? There is a bug with the latest version which causes what you describe, and you should revert to the 2.0.4 version in order to fix it.

If that’s your case, another topic is already opened for this issue :

1 Like

Thank you very much. Driver of version 2.0.4 solve my problem. Thanks for fast answer. Will be waiting new version of driver with resolve this problem.

Guide on how to set up ASIO4ALL :

How to: Realtek/ASIO4ALL laptop settings

Hi! Thank you very much for this detailed guide! :slight_smile:
Unluckily I am still having trouble after following everything written in your guide (unless I am missing something).
Unluckily I still don’t hear any sound inside Cubase, but I can see Windows system sounds.
One thing that seems strange to me is that, when looking at ASIO4All control panel, I can see that my wireless headphones have a red cross that says device status “Not available!”, and suggests two possible problems:

  • In use by another application?
  • MS GS Wavetable Synth enabled?
    About first question, I don’t have any other application open in addition to Cubase.
    About the seconds one, I have already disabled “MS GS Wavetable Synth” under Windows Device Manager, Software Devices.
    Any idea about what could be wrong?
    Thanks in advance! And merry Christmas! :smiley:

EDIT: I’ve just tried turning off bluetooth headphones and reopening Cubase. Now in ASIO4All control panel I have the same red cross on the notebook’s built-in speakers (Realtek HD Audio output with HAP).

1 Like

@fedeali Hi! Maybe your devices are simply not multi-client compatible, I see no other explanation to this. The red cross means the channel is effectively being used by another application (Windows in this case) and cannot be used in two places at the same time.

1 Like

Please upload a screenshot of ASIO4All Control Panel

1 Like

Thank you both for helping me @Louis_R and @Geppastro !
Very strangely, today for the first time I don’t have the red cross anymore in ASIO4All Control Panel. However, I still can’t hear anything inside Cubase. Attached the screenshot.

Until yesteday I always had the red cross either on my bluetooth headphones, when trying to use them, but also on notebook’s built-in Realtek speaker.
Also another info, hoping it would be helpful to understand the problem: I have successfully used Music Maker on the same PC with the same bluetooth headphones. So you would say, “Why don’t you use that?”. :smiley: The reason is that Cubase is a far superior product, and I really would like to use it, to have nice features like Chord Pad. :smiley:
Thank you again for your help! I really would like to start using Cubase Elements demo! :slight_smile:

EDIT: I also add other screenshots.
Studio->Audio connections dialog

Studio->Studio setup dialog

(Sorry for Italian language in screenshots, I hope it is comprehnsible)

EDIT 2: After closing and reopening Cubase, now I still have the device “unavailable” in the ASIO4All Control Panel. After rebooting Windows, still the same. :frowning:

EDIT 3: Closed Cubase. Turned off bluetooth headphones. Turned off Bluetooth. Turned on Bluetooth. Turned on headphones and paired them again in Windows. Opened again Cubase: now the headphones are correctly visible in ASIO4All Control Panel just like in the very first screenshot of this post.

Sorry if I double post, but I think it’s better than editing again the previous message. :slight_smile: Actually, it works!! :smiley:
I don’t know why, but I couldn’t make it work with the only track I was testing using the HALion Sonic SE VST. I’ve tried adding another track using another VST and it works! Furthermore, I deleted the old track, and added a new one, still using HALion Sonic SE, and now it works!
Thank you all for your help! It seems the main problem I had until yesterday was the “unavailable” device under ASIO4All Control Panel. It seems to be fixable by closing Cubase, unplugging and replugging the bluetooth headphones again. I hope this will always work. :slight_smile:

2 Likes

Glad it works. BTW I’m Italian too.

1 Like

Some devices don’t work really good with ASIO4ALL.
I’ve experienced this too, and unfortunately when this happens we have to deal with it. No particular settings will fix it, sometimes it works, sometimes it doesn’t.

1 Like

Update regarding Issues with Yamaha Steinberg USB Driver V2.1.0 or later :
Version 2.1.5 and above should fix the broken behavior. Please update your driver.

I still have audio drop outs with 2.1.5. it’s completely random and I can’t reproduce it on demand.

2.1.2 was described with “reduced audio drop outs due to USB connection issues”. Reduced? Not fixed?

Just to share my multi-client experience with UR22mkII and Yamaha Steinberg USB driver 2.1.6:

  • The USB driver seems not to work for multiple clients, even if I follow all the things mentioned above
  • However I managed to put ASIO4ALL to work with the UR22mkII for my second DAW at the same time as the first DAW is using the Yamaha Steinberg USB driver
  • I am using an USB mixer and connect UR22mkII outputs to the USB mixer tape input channel, since Windows apps like a browser cannot access the UR22mkII anymore in this setup

This way I can run 2 DAWs and Windows native audio output, which is fine because I rarely do recordings using the USB mixer.
If there is an easier way (another audio interface?) please let me know.
Thanks!

Very useful information. I am also a Windows user, but just wondering if there should be a similar guide for Mac users? Or don’t they have these problems?