Cubase 12 - Beat Calculator appears to be inaccurate

Beat Calculator is an important part of my workflow.

I upgraded to Cubase 12 a week or so ago and Beat Calculator is no longer functioning correctly. It is reporting as 11.5 bpm lower than the actual bpm.


Huey Lewis and the News - The Power of Love. It’s 119 all day. We are all familiar with what 120 sounds like so it’s clearly around 120. When using Beat Calculator, the result is 107.5.


Any other beat calculator is giving me the correct result.

I’ve restarted the program and tried clicking Refresh and tried using the mouse. For whatever reason, Cubase is absolutely positive that this song is at 107.5. I don’t get it.

What’s strange is, if I use Tempo Detection, the engine knows the tempo:

huey lewis tempo track

Any advice or ideas? I looked in the manual and there wasn’t much.

If I turn on a metronome in my room to 119 and click along, this is the result of Beat Calculator even when I have no session open:

Any ideas on this? I’d love to get this fixed. Beat Calculator is exactly 11.5 bpm slow no matter what I do.

I really appreciate your time.

1 Like

I’ll try to reproduce. Are you saying it’s 11.5 bpm slower than whatever the tapped tempo is, or does the error scale proportionately?

Thanks Steve. I’ll try a different bpm and see if it changes the bpm delta.

Edit: I’ll try when Cubase gets done “Checking Licenses” yet again. This time it occurred when I closed the session. It locks up but if I wait 5 or so minutes it usually gets done checking whatever it is checking and will let go of the process. This behavior is far more frustrating than the bpm issue but there is a separate thread for it.


Actually, Shane, I just tried at 120 bpm but it worked okay. Tried both space bar and mouse click.

Can you try in an empty project?

For this, force quit Cubase, and the SteinbergLicensingEngine.exe, or restart the machine.

Impatience got the best of me and I killed the PID. I will try now with an empty session. Thanks for your help.

1 Like

Here is what I see on empty session when I open Beat Calculator.


Here are videos of the Test. Volume warning: sorry, the space bar sounds like a baseball bat hitting a block of ice. But this will show the experiment. It is not 11.5 bpm, it is scaling or it is just random.

140 test = 140 reporting as 127

120 test - 120 reporting as 109

Thanks again for your help.

Hmm… What happens if you start in Safe Mode?

Open in Safe Mode:

Get this error 3 times, while other items are loading:


I select my RME ASIO driver (I can try other devices if necessary):

Default News/Projects panel shows up:

Click Create Empty and select a project folder:

Select Project > Beat Calculator. Default panel appears:


I try Beat Calculator with spacebar at default 120 using Cubase metronome as guide for about 10 measures.

Cubase says 109


Repeat the test with mouse instead for about 10 measures:


I try again with empty session and set the bpm to 160. I do this test a couple of times and the result is 145.0:


I close Cubase and it locks up (this has happened for years so I’m used to killing the process, but it’s disappointing that the program can’t close itself properly even in safe mode with all plugins and prefs disabled):

Any ideas? Reinstall? I installed it one or two weeks ago. Version info below:


Send the logs. I do this many times a day:

I don’t think these are related, so I’ll focus on the beat detection thing. There are threads about it the stall during launch though. I would be patient and wait for the next update which will fix a bunch of stuff, and then revisit it.

The bpm thing is pretty weird. But since I can’t reproduce it, and there aren’t other reports in the forum about it, I figure it’s something local to you machine. What that might be, I don’t know, but maybe another forum member will weigh in with something more useful.

OK thank you. I will see if anyone else has the issue. I am going to test it now in Cubase 11 and see if it happens there.

OK now I’m totally perplexed. It is happening in Cubase 12, 11, and 10 on my machine.

I’ll do some troubleshooting with different devices unplugged, try some different interfaces, and will go over any configuration documentation I can find.

I will probably uninstall all versions of Cubase and reinstall from scratch.

[System Summary]
Item Value
OS Name Microsoft Windows 10 Pro
Version 10.0.19044 Build 19044
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name XDRC
System Manufacturer Micro-Star International Co., Ltd
System Model MS-7B09
System Type x64-based PC
System SKU To be filled by O.E.M.
Processor AMD Ryzen Threadripper 1950X 16-Core Processor, 3750 Mhz, 16 Core(s), 32 Logical Processor(s)
Edit: Machine info for anyone who happens to encounter this:
|BIOS Version/Date|American Megatrends Inc. 1.70, 12/18/2017|
|SMBIOS Version|3.0||
|Embedded Controller Version|255.255||
|BIOS Mode|Legacy||
|BaseBoard Manufacturer|Micro-Star International Co., Ltd||
|BaseBoard Product|X399 GAMING PRO CARBON AC (MS-7B09)||
|BaseBoard Version|1.0||
|Platform Role|Desktop||
|Secure Boot State|Unsupported||
|PCR7 Configuration|Binding Not Possible||
|Windows Directory|C:\WINDOWS||
|System Directory|C:\WINDOWS\system32||
|Boot Device|\Device\HarddiskVolume4||
|Locale|United States||
|Hardware Abstraction Layer|Version = 10.0.19041.1566||
|User Name|XDRC\shane||
|Time Zone|Pacific Daylight Time||
|Installed Physical Memory (RAM)|32.0 GB||
|Total Physical Memory|31.9 GB||
|Available Physical Memory|22.2 GB||
|Total Virtual Memory|36.6 GB||
|Available Virtual Memory|19.5 GB||
|Page File Space|4.75 GB||
|Page File|C:\pagefile.sys||
|Kernel DMA Protection|Off||
|Virtualization-based security|Running||
|Virtualization-based security Required Security Properties|||
|Virtualization-based security Available Security Properties|Base Virtualization Support||
|Virtualization-based security Services Configured|||
|Virtualization-based security Services Running|||
|Device Encryption Support|Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not Modern Standby, Un-allowed DMA capable bus/device(s) detected, TPM is not usable||
|A hypervisor has been detected. Features required for Hyper-V will not be displayed.|||

What were those other beat calculators you tested with?

Those are just free online BPM calculators. I just Googled BPM calculator.

If they were browser apps, can you try using an installed program?

My gut feeling is that it’s not a Cubase prob, and is related to how the programs interact with HIDs

I can but bear in mind, Cubase Tempo Detection logged that Huey Lewis song between 118-120 which is the expected result.
huey lewis tempo track

The BPM calc in cubase is completely unrelated to the tempo detect function. I think this is caused by some setting related to input devices like mouses and keyboards. Maybe dirver related, bios related… I’m really just guessing here.

I understand but you’re asking me to use a different beat calculator when I used three of them that all said 119, and the song is in 119. So I just wasn’t sure what you were getting at with that request, but I will try it.

Web browsers might very well use a different programmatic method to detect mouse clicks and keyboard keys.

This is the result from an iphone app: