Cubase 12 stuck on "Checking Licences"

I just bought Cubase Artist 12 for students and installed everything. When I tried to launch Cubase, it got stuck on “Checking Licences” and I can’t get past this point.

“No response” in the task manager :

Just for info, I tried a demo version of Cubase 11, months ago.

Windows :
Windows 11
Build 22000.556

Processor : AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx 2.10 GHz|
RAM : 8,00 Go
System : 64 bits, processor x64

Can anybody please help me? :cry:

1 Like

What does the Activation Manager show?

This is what I see.
(I clicked on the button to activate the licence)

Does it start now?

Nop, the same thing happens.

have you at least restarted the machine?

Yes I restarted several times since I activated the licence.
I also tried lauching Cubase as an administrator.

Oh… I think I have an idea… did you install Cubase 12 pro…by mistake?

Just checked, no.

Damn… I’m out of ideas now… maybe deactivate the license, reboot, activate it again and reboot again and try to start it… This is the last idea I have…

1 Like

But I have another version of Cubase I see in the Download Assistant.
It is Cubase Elements 11. Probably something my father installed way back, but I don’t know what it is doing here.

It was already installed before I installed everything from Artist 12., I uninstalled it when I realized.

What @st10ss said, plus uninstall Download assistant, Library Manager and Elicencer using Windows Programs and Features Control Panel

Restart and start from scratch. Download the Download Manager only, and install. It will install all three programs. Does it fix?

OK, maybe some content has no license anymore and that stops the process from going forward.

Ok, I’ll tell you how it goes.

Fine, good luck…

that would mean something’s broken, for sure

Also there was that long thread about getting stuck on some other start up detail, can’t remember which at the moment… @st10ss do you recall?

If I can’t get anywhere doing what you said, I will reformat the machine.

yeah… way back in my brain shimmers a light…

More than I can say!

Oh… I think I see where is the problem.

This is what I see when I install SpectraLayers 8… eLicenser cannot execute because it can’t find the file “CreateProcess”, if I understand well.

So I went to eLicenser and I get gray buttons, can’t click anywhere.

Are you familiar with this issue?

Oh and when I try to execute SpectraLayers 8, I get this message :
‘Steinberg License Engine’ caused the following error :