Cubase 12 VST3 Plugins (all 3rd party) not showing up

Just upgraded and tried two fresh installs but none of my VST3 plugins are showing up.

I’ve added the VST3 paths but even after multiple scans no VST3 plugins (apart from the Steinberg ones) show up anywhere (not in the blacklist nor plugin-in manager)

OS: Windows 10 Pro ( Build - 19042.1526)

that’s odd - my 3rd party VSTs are showing up fine in Cubase 12 Pro.

Are your 3rd party VST3’s 64bit and in the following folder:

C:\Program Files\Common Files\vst3

To the best of my knowledge they have to be in that folder.

1 Like

Maybe it’s not that widespread? Are you on windows or Mac?

Yeah, my vst3 are all in the default “Common Files/VST3” folder and they are all 64bit too.

I’ve also double checked to make sure that path shows up in plugin manager too!

VST2s shows up fine. Just all 3rd party VST3s.

I just found this thread with the same issue today btw.

Super weird :confused:

I’m on Win10 20H2 (19042)

A couple of things to maybe try:

Rescan all the plugins in the Plug-in Manager

Disable the preferences when starting Cubase.

p.s. I would also avoid adding the VST3 path, since to the best of my understanding, those paths are only intended for VST2. And I don’t know if adding a VST3 path might cause Cubase confusion.

1 Like

Normally not… but who knows… there could be a ghost in the machine…

2 Likes

the 3rd law of Arthur C. Clarke would seem to kind of agree with you!

1 Like

Ty! I’ll try again and come back with an update!

1 Like

Update:

I also had an error that VST3 could not be read by a third party.
I just solved it

C:\Program Files\Common Files\VST3
After moving the entire VST3 folder to another location, run Cubase and quit.
Then, move the VST3 folder back to the original location and run Cubase.

I wish you success.

3 Likes

Finally found the solution to my issue. So the reason why (for me at least) Cubase would skip scanning the VST3 folder entirely was that there were a couple of vst2 dlls inside the vst3 folder.

As soon as I took them out and ran a rescan, everything started to show up.

The same Problem here…Cubase 12 does NOT SCAN
C:\Program Files\Common Files\VST3 !
The only VST3 Folder scanned is
C:\Program Files\Steinberg\Cubase 12\VST3
So I created a new folder in
C:\Program Files\Steinberg\Cubase 12\VST3
and made a symlink to
C:\Program Files\Common Files\VST3

Now it works. For all: Search for a program called JunctionMaster Pro by Bitsum (can’t post links here), with it you can make symlinks.

1 Like

That’s so weird. On my system, I haven’t got anything in C:\Program Files\Steinberg\Cubase 12\VST3

Although you were right about C12 not scanning C:\Program Files\Common Files\VST3

But the reason why it was skipping VST3 scan on the above location (for me) was caused by a couple of VST2 DLLs in the folder. As soon as I took them out, it scanned the location.

Although I’m glad your solution worked for you too! :+1:

Thank you !
I have no VST2 DLL’s in the Folder C:\Program Files\Common Files\VST3, but Cubase 12 (also the Update to 12.0.10) keeps on skipping this Folder. I did not want to move all VST3’s to C:\Program Files\Steinberg\Cubase 12\VST3, so I made the symlink.

From the support pages:

Where are VST3 plug-ins installed?
In contrast to VST2 plug-ins, all VST3 plug-ins share the same installation folder. So it’s easy for both host sequencers and users to find the VST3 plug-ins. These are the installation paths defined in the VST3 specifications:

Windows 64 Bit: C:\Program Files\Common Files\VST3
Windows 32 Bit: C:\Program Files (x86)\Common Files\VST3
Mac OS X: Library/Audio/Plug-ins/VST3

so i have the same problem
i got cubase 12 on macbook pro 2020 m1 chip tried rosetta etc etc but still nada… when i rescan nothing shows up
help anyone

I Found the solution! I copied all Vst3 plugins from: prog files / common files/ vst3, to prog files/ Steinberg/ Cubase 12 / vst3. Then i deleted the shortcut folder in this folder that leads to : prog files / common files/ vst3 . Everything works perfect now.

If you think this is the solution, much luck for the future.

The problem has gone wit v. 12.0.20, thank you !!