Cubase 12 Waveform Drawing "More cluttered" than 11

@ggmanestraki No problem !

This function was added in Cubase 12 .
In previous versions it was just smoothing the samples at high zoom levels.
Now it also smooths the waveform globally.
image

12.0.2 And the problem is still here! :confused:

We are aware of the issue and working on a fix for the next update. Actually it’s just one pixel. The silence line was one pixel and with the interpolated waveforms its two pixels in height.

3 Likes

Thanks a lot for the offical reply, Matthias! I appreciate!

Funny how the tiniest things can actually make a big difference. Perhaps that indicates just how mature Cubase has become. People are beyond “controlling a computer application” and are more in the mode of living organically with the software. Even a small distraction breaks that mental bond.

I don’t mean to get too metaphysical, but it is actually pretty cool.

2 Likes

Thank for working on this as a priority. It really is important to many of us.

If you turn background color modulation on it seems better. I don’t really use this option but you do get a thinner line for zero db.

background-color-modulation-0n
background-color-modulation-0ff

Thanks

Just checked and still not fixed on 12.0.30 :confused:

Hi @pgstudio!

Would you please report that observation here: Cubase 12.0.30 performance issues ?

Thanks!

Hi,

This issue is not a performance issue.

1 Like

Still not fixed in 12.0.30.

I also checked and confirm that it is not fixed in 12.0.30. It has nothing to do with smooth waveform drawing either. That’s a red herring. For me, this causes me to revert to v11.

If I had Cubase 12 (only used trial for 30 days) I would open a support case. Everyone should who does not like thie new waveform display (which is really annoying).
Seeing CB12 in that state makes me already concerned that many things will be fixed with the new version release only. Being here with v11.0.x in “ok” (though there should have been more final maintenance updates even for 11).

That’s because you are on Mac, where Interpolate Audio Waveforms cannot be disabled because of a bug. It is enabled all the time even when the box is not checked.
Interpolate Audio Waveforms = Smooth Waveform Drawing, this is the same thing, in Cubase 12 Smooth Waveform Drawing was added as an improvement to Interpolate Audio Waveforms, but again since you are on Mac you can’t see the difference.

The official topic about these issues is that one, which includes all of the 3 issues related to the Interpolate Audio Waveforms setting :

Okay so my Support Request on this issue was marked as Solved this morning, without any explanation, and the ticket has been completely closed (comments no longer allowed).

Obviously the issue is still there as 12.0.30.
To me this is quite disrespectful. I spend hours everyday on this forum trying to find bugs, testing them thoroughly, then sending support tickets, and this is the result.

Edit : I also mentioned the “thick silence lines” issue in a separate ticket in which I explain the whole problem about Smooth Waveform Drawing (here on the forum).
This ticket last activity is from this morning too, so I guess the same person is currently investigating it, since it is still opened, though there is no comment yet.
Wait and see :wink:

Hello @Louis_R ,

Thanks for all your hard work on these fora, first of all. :slight_smile:

Quick question please about this post of yours: Cubase 12 Waveform Drawing "More cluttered" than 11 - #27 by Louis_R

I clearly see the difference between C11 and C12 when zoomed in. However though I see some difference when zoomed out, I find it hard to characterize, and the word “Smoothing” doesn’t really come to mind when trying to describe the C12 zoomed out waveform.

What exactly are you noticing as a difference in the Zoomed Out waveform between C12 (where Smoothing is applied), and C11 (where it is not)?

(I’m not referring, to clarify, about the 1- vs. 2-pixel line thickness difference when there is silence).

Thank you!

Well, I can’t explain it better than what I’ve already said in this topic, to be honest.

1 Like

Hello @Louis_R ,

Thanks for your response.

Those are waveform pics, or “silence line” pics? Where/how did you get them?

If waveform pics, it seems that Waveform Smoothing function is just blurring the edges … ? I’m not sure why someone would find that helpful … what problem did it solve?

I have a feeling I’m missing something major and obvious here!

Thanks -

This is just a generic image showing how anti-aliasing works, from the images results in Google.
It solves no problem appart from smoothing out the edges, just like in video game. Even your computer does this right now when you’re reading the characters that make up this text.

@Louis_R got it, thanks.

Still wondering, what problem did it solve, and who/why someone would find it helpful … I guess people were saying waveforms were too sharp and spikey before …?

The option has been added to meet everyone’s needs.
It all depends on your screen resolution and HiDPI settings.
If the resolution is too low, or HiDPI setting too high, the following happens :
smooth off

Now, thanks to Smooth Waveform Drawing introduced in Cubase 12 (and again, enabled with the Interpolate Audio Waveforms setting), it can look like this :
smooth on

Which one do you prefer ? Top or bottom ?

1 Like