Cubase 6 and Waves 9 [ CRASHES! ] on exit!

Well…I, along with everyone else have been waiting for Waves to provide a contribution to the 64bit revolution! They have with a very bold statement done so with the presentation of Version 9! :smiley:

Unfortunately for me…the upgrade has been problematic in that every time I try to exit Cubase 6.0.6…it hangs! :open_mouth:

I’ve been able to reproduce this 100% of the time using both 32bit and 64bit versions of Cubase!

I have also observed that if I remove the new Waves license authorization USB drive before attempting to close Cubase, and then try to close Cubase… it will still crash (hang on exit).

Windows 7 Ultimate 64 bit
Cubase 6.0.6 32bit and 64 bit
Waves Ver. 9 64 bit
HP DV9000 Laptop 4gig memory

Anyone else notice this?

I’ll keep tinkering, and if I find something new…I’ll report it!

Good luck all ye fellow early adopters!! :mrgreen:


I have since tried moving my Waves licences over to my hard drive… a process that works beautifully by the way!

Start Cubase - launch a project - try to exit Cubase - Cubase hangs…

So, it’s not isolated to a USB issue!

I’ll report back as this issue developes :wink:


Waves 9 = Cubase 6.0.2. Could that be the issue here?
I learned to be patient…the hard way. Had lots of trouble in the past with these kind of “almost compatible” related issues.

I have Cubase 6,5 and Waves 9, 64Bit.

Experience no such things!
Everything works as it suppose.

That’s a good point! I guess in an effort to be thorough, I could roll back to Cubase 6.0.2 just to test that theory! :wink:

I spoke with a Waves tech today, and he mentioned that he thought this was a known issue, and that he would enter this issue into their data base as a bug… Basically confirming that the issue is not PILOT error, but rather something that needs to be fixed by the software engineers. Either way, you are right…patience is a virtue! :slight_smile:


Thanks for the info Smedberg! What are your system specs?


FYI clean exits here on 6.0.5 and waves 9 (Gold and L3-16 tested)

Win 7 Professional 64 bit

Win7, 64 bit home…
8 gig ram
i7 920, 2,66GHz
Impact Twin, Firewire Audio

Thanks Noiseboy, and Smedberg!

The Waves tech didn’t seem to think it has to do with a specific hardware configuration, but that is why they call it troubleshooting!! He also didn’t think it was a rogue plugin.

NoiseboyUK has the closest software configuration with me, exept for I’m using Win7 Ultimate, Waves Diamond,L3-16, API,SSL,IR1…

My laptop hardware config. is in my signature below.

Well…practicing due diligence, I completely de-installed all versions of Cubase, and trashed both (32bit and 64bit) app data preference folders so I could start from scratch…I think! :laughing:

I re-installed only Cubase 6 64bit, and then updated to 6.0.2…since that is the documented version supported by Waves.

Na da! Still crashes while trying to exit Cubase. Cubase even crashed while trying to update (scan) the VSTplugins folder so I would have access to my Native Instruments Plugins… I don’t think I have ever had to explicitly set the path to the windows VSTplugins folder…don’t know what’s up with that! :astonished:

Anyway, I also have Wavelab 7.1.1 (32bit) and that doesn’t crash, and the 32 bit Waves 9 plugins work fine!

I also tried Reaper 4.20 64 bit and the 64 bit Waves plugins work properly here also.

So it is IMHO that this is a software glitch between Waves 9 64bit and Cubase 6.

The only reason I’m ruling out my hardware is because everything was working properly with Waves Version 8, although this may also have something to do with going from 32 to 64 bit and I only have 4 gig of ram.

Unless anyone has any more suggestions or insight on stuff to try…i may just go back to Waves 8 until the next update and try again. Good thing I still have my I-Loc ! :frowning:

Thanks for everyone’s help! :smiley:

I re-installed only Cubase 6 64bit, and then updated to 6.0.2…since that is the documented version supported by Waves.

That waves compatibility chart is actually now updated to 6.5.0

Yea…don’t believe everything you read…thats how I got into this mess! (just kidding) :laughing: It looks like the webmaster finally caught up!

Too bad for me there seems to be a bug on my system. I don’t know what the problem is, but Waves 9, and Cubase 6 will not play well together on my system. So I’ve reverted back to Waves 8 and Cubase 6.0.6 32 bit, and everything is working fine for now.

Let me just say that I had to jump through many hoops to go back to Waves 8… seems that Waves ver. 9 somehow inhibits the functionality of the licenses on the I-Lok. I had to completely remove all of ver. 9 and the new license application, and then re-install the I-Loc software and I still was getting popups saying that I didn’t have the proper licenses eventhough the I-Lok website clearly shows that they are all there! But when I checked the VSTplugins folders, the ver. 9 Waveshell was still there along with the ver. 8 Waveshell, so I removed the ver. 9 Waveshell from both VSTplugins folders and " Wham" everything started working again! :laughing:


I have Cubase 6.5 64x and installed the new Waves 9 but haven’t launched the program yet, but one note I made to myself which may or may not help anyone, is to remember to delete any bits that jBridge may have left floating around from bridging Waves 8.

Another thing I learned when updating is to be sure you run Windows Update. Sometimes new software depends on it whereas the old was doing fine without it…
Good luck!

Slightly off topic, I didn’t realise I could use v8 if I have upgraded to v9. I bring this up because I also hadn’t noticed until too late that v9 will not work on an XP PC. I use Windows 7 for 2 PCs but have one with XP. Can I simply plug in my iLOK and then run v8 on my XP PC?


I am running Waves v9 in Cubase 6.5.1 on XP SP3 without issue. I briefly ran v8 and v9 in the same project, but now I’ve updated everything to v9. I could still run v8, v7 whatever if I needed to.

Paul - Wait a minute? Did you download your former V8 Wave plugins again, but now V9 versions? In 32 bit? I was thinking that V9 was all about 64 bit, such that the Wave plugins are now all 64 bit. No?

So are you saying that the V9 downloader offers 32 bit versions of the plugins? Or that the V9 installer will work with the V8 version plugins? I am confused, sorry. Man, you seem to be defying gravity to me right now.

Waves V9 installs both 32 bit and 64 bit plugins! When you launch the installer, it will give you the option to download previous versions…it will also ask if you want to upgrade your previous versions to the latest version, which is what I did…but in hind sight should have kept both versions for a while, as Paul did.

But, if you upgrade as I did…then go from V9 back to a previous version where your licenses are still on the I-Lok…be prepared to tinker a bit! :nerd:


Hey thanks for that info Al. I have to make the crossover yet, from XP to Win7. I have my Win7 disc here and have done the Win7 transfer thing and basically I am trying to do this as smoothly as possible - if that’s an option. Too, I have a few Wave bundles and need to upgrade to V9 as well, all with the plan to run in 64 bit of course.

So, if I underestand you correctly, you upgraded to V9 and took your ilok out of play for Waves. Correct? But you could have kept your V8 Waves installer in play (and 32 bit Waves) and your Waves ilok as well, AND upgraded to V9 32/64 bit? Correct?? But that’s redundant, right? If you have a 32/64 bit OS that can be supplied by one Waves V9 installer, wouldn’t that be a cleaner path?

So, are you suggesting that Paul is on the V9 cloud and on the V8 ilok - and that you are only on the V9 cloud? Or are you saying that when you added the V9 installer you were left with the V8 ilok and can somehow manage to get back to that installer and those plugins? Is this the ‘tinker’-ing you are refering to? From the sound of the Waves V9 instructions, running the V8/ilok and the V9 cloud on the same computer is not an option, but maybe this is not the case. :confused:

You got anything else that can clear this up for me? Thanks. I am hating swapping OS’s on the same computer but this is what I have to do. Dragging my feet all the way.

I can’t answer for Paul!

What happened was after I upgraded to Waves V9…Cubase 6 32bit as well as 64bit would hang while trying to exit! So, it wasn’t about 32bit or 64bit, but rather a Waves V9 and Cubase 6.0.5, 6.0.6 issue (with my system)!

Since others didn’t seem to be having the same problem I was having… I decided to go back to the last version that worked for me, which is Cubase 6.x.x and Waves V8.

After re-downloading V8 with the Waves installer, I kept getting error messages saying I didn’t have the correct licenses! So at that point I just wanted to get back to my previous working solution! I de-installed V9, but the uninstaller left the V9 Waveshells in my VSTplugins flolders, and as a result I continued to get error messages saying I didn’t have any licenses. Once I removed the V9 Waveshells, and re-installed the I-Lok software…I was back in business!

My way of dealing with this situation may be a little unorthodox, but I asked as many people that I knew to ask…Including Waves tech support who indicated to me that the problem I was having was a known problem! The fact that it seems to be effecting only me and know one else that has answered this thread, suggests that it may be related to my system!

Either way, my system works with V8 and not V9… and my system passes the documented minimum requirements.

Until I successfully install all the software on a different computer I won’t know if the bug is just on my laptop, or applicable to multiple systems.

One thing for sure though…It’s been a PAIN IN THE ASS! :smiling_imp:

I’m sure I will eventually get it sorted, but it may take some time! :wink: